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Welcome

Layout program MarkStein Publisher

MarkStein Publisher is a program for graphic artists, layout artists and creative people comprising
an enormous range of functions, while remaining user-friendly.

MarkStein Publisher is suitable for both first-time users wishing to “quickly” create a letterhead or
business card, as well as for professionals wishing to create large documents for various output
formats.

You can use MarkStein Publisher to create typeset files for printing, output books in EPUB format,
or use the data to export HTML files to web pages.

MarkStein Publisher is not only a layout program with all the functions expected today, but also in-
cludes a powerful text editor, enabling users to quickly and easily create the layouts for written art-
icles.

How to get more support

If you have any questions about our programs, please use our free email support at support@mark-
stein.com or take a look at the FAQ and the Knowledge Base on our website markstein-publish-
ing.com.

As a user forum, the Facebook group Alternative Publishing (German spoken) is available for you to
exchange ideas.

We offer telephone support for MarkStein Publisher Workgroup Edition and working groups of five
or more users after signing an appropriate maintenance agreement. In order to build up your public-
ations, we recommend that you take advantage of our experienced team of trainers so that you can
work productively with your software as quickly as possible.

MarkStein Software Entwicklungs- und VertriebsGmbH
Riedstraße 2
D-64295 Darmstadt, Germany

https://www.markstein.com
http://www.markstein-publishing.com

Status of documentation

Version 8.1 – October 2022

Authors

Jochen Fröhlich, Michael Stühr, Marion Tramer

Translations

fine expression, D-64293 Darmstadt, Germany
deepl Online Translator

mailto:support@markstein.com
mailto:support@markstein.com
https://www.markstein-publishing.com/faq/?lang=en
https://www.markstein-publishing.com/en/knowledgebase/
https://www.markstein-publishing.com/
https://www.markstein-publishing.com/
https://www.facebook.com/groups/725527801310482
https://www.markstein.com
http://www.markstein-publishing.com
https://www.deepl.com/translate
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Introduction
This chapter will provide you with an initial overview of MarkStein Publisher.

The DTP program MarkStein Publisher is available in three variants: 

· MarkStein Publisher Standard Edition: Free version for private users and personal use

· MarkStein Publisher Professional Edition: Professional version for graphic artists and agencies
including Adobe-compatible PDF functionality

· MarkStein Publisher Workgroup Edition: Collaborative version for workgroups with separate editing
(text) and layout (graphics). Collaboration takes place via the cloud, for example with Dropbox or
Google Drive.

The three versions are based on each other. This means MarkStein Publisher Professional Edition
contains all functions of the standard version, plus additional extensions for professional use.
MarkStein Publisher Workgroup Edition is a professional version, which has been supplemented
with collaborative functions to enable for teams of editors/authors, copywriters and graphic artists to
work together.

The features of and differences between the three versions are described in the next section.
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What is different?

By procuring one of the editions of MarkStein Publisher, you have access to a layout software with
which you can easily create your own magazines, books, brochures and flyers. MarkStein Publisher
is characterized by its ease of use, despite its large scope of performance. Even newcomers can
work productively in just a short period of time, with the supplied design patterns providing both help
and inspiration. 

MarkStein Publisher differs from classic desktop publishing (DTP) programs, such as Adobe
InDesign and Quark XPress, in its innovative interface concept with panels and inspectors, which
considerably simplify work. All essential design settings are not located in hidden submenus, but in
clearly arranged inspectors. This provides a better overview and leads to faster results. 

The program interface can also be adapted to your preferences with many options. For example,
you can freely select the color of the tools and toolbars, or set a bright or dark overall image of the
software. 

The free basic version, MarkStein Publisher Standard Edition, allows private users to create, print
and output publications as e-books. The paid version, MarkStein Publisher Professional Edition, is
very inexpensive compared to common DTP programs, and also comes equipped with integrated
PDF functions for the output and placement of PDF files as per the industry standard.

The MarkStein Publisher Workgroup Edition version is aimed at small publishers and corporate
workgroups. This version offers additional functions for collaboration between graphic artists and
copywriters, as well as for exporting to digital media. 

A list of the features of the different editions can be found in the Features section of the program. 

Your advantages with MarkStein Publisher:

· Modern, independent layout program

· One-time license, no subscription with ongoing fees

· Easy to learn and use

· Extensive design capabilities

· Spell checking and hyphenation in five European languages

· PostScript and PDF workflow

· Many special functions, such as direct posting on Twitter and transferring content to a WordPress
blog

· Texts and documents saved in XML format

· Multimedia PDF support with audio and video

· Output of e-books without additional tools

· IDML filter for exchanging with Adobe InDesign

· MarkStein Publisher Standard Edition free of charge ("Freeware")
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Functions of the program

Below, you will find a list of the functions in the three versions of the software MarkStein Publisher.

STD = Standard Edition
PROF = Professional Edition
WG = Workgroup Edition

●= available
○= not available

Interface

Function STD PROF WG

Value entry via dialog windows, inspectors and panels ● ● ●

Control panel for quick access ● ● ●

Template panel and anchored frames ● ● ●

Parallel display of galley view and page view ● ● ●

Parallel editing of text on the page and in the galley editor,
updated in real time

● ● ●

Hybrid texts: Marking of use per paragraph (e.g.
print/web/mobile/e-book)

○ ● ●

Live view for pages, template and library elements ● ● ●

Page Overview ● ● ●

Zooming to 10,000% ● ● ●

Pages

Function STD PROF WG

Printer spreads as page containers for adjoining pages ● ● ●

Varying page size possible on the printer spread ● ● ●

Rotating of printer spread by 90 degrees for processing ● ● ●

Placing of reference lines via mouse or dialog ● ● ●

“Intelligent” reference lines referring to other objects ● ● ●

Optional (including asymmetrical) grids via custom grids from
the presettings

● ● ●

Assignment of one master page per page ● ● ●

Optional number of grids in a document ● ● ●

Optional number of levels ● ● ●
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Automatic rules ● ● ●

HKS and Pantone color palettes, optional ● ● ●

Integrated color management ● ● ●

Inclusion of a page status ○ ○ ●

Frame

Function STD PROF WG

General frame type, may contain text and images or be empty ● ● ●

Object types (frame, rule): rectangle, polygon / Bézier ● ● ●

Margin (every edge can be defined separately) ● ● ●

Stroke (border) ● ● ●

Text wrap ● ● ●

Corner shapes, can be defined individually for all four corners ● ● ●

Reference point-dependent coordinate display ● ● ●

Linking together of all frames possible (story focus) ● ● ●

Nested grouping ● ● ●

Anchored frames text, image in the variations left or right of
the paragraph or within the text (marginalia), can be stored in
libraries

● ● ●

Linked anchored frames ● ● ●

Multi-column text frames ● ● ●

Color gradients with two colors per frame ● ● ●

Gradient shadow for frames ○ ● ●

Transparencies ○ ● ●

Changing the frame type ● ● ●

Rules

Function STD PROF WG

Rotating of rules in 1/1,000º steps ● ● ●

Transforming straight rules into Bézier shapes ● ● ●

10 rule types, arrow heads and other rule end styles ● ● ●

Rules with round ends ● ● ●

Transparent rules ○ ● ●

Rules with shadows ○ ● ●
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Images

Function STD PROF WG

EPS, TIFF, JPG, GIF, PNG, BMP ● ● ●

PDF ○ ● ●

Placing of PSD files from Photoshop ● ● ●

Placing of AI files from Adobe Illustrator ○ ● ●

Placing of PDF files with page selection ○ ● ●

Automatic creation of image frames upon placement ● ● ●

Enlarging / minimizing images proportionally to the frame ● ● ●

Moving the image content per mouse or keyboard ● ● ●

Scaling, cropping, rotating and shearing of images ● ● ●

Evaluation of free-form selections of images using alpha chan-
nels and paths from Photoshop (EPS, TIFF, JEPG)

● ● ●

Transforming of clipping paths into Bézier shapes or polygons ● ● ●

Horizontal / vertical flipping of images ● ● ●

Rotating of image content within the frame in 1/1,000° steps ● ● ●

Display of IPTC information (corresponds to file information
from Adobe Photoshop)

● ● ●

Adoption of image captions from image text (IPTC) ● ● ●

Inclusion of an image status ○ ○ ●

Transparent display of invisible image sections when moving
images

● ● ●

Transparencies ○ ● ●

Tables

Function STD PROF WG

Comprehensive table tool ● ● ●

Column and row-oriented tables ● ● ●

Table wizard to easily create tables ● ● ●

Move rows and columns via drag & drop ● ● ●

Lock columns and rows ● ● ●

Automatic magnification of table rows when entering text ● ● ●

Merged cells ● ● ●
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Sheared cells ● ● ●

Multi-column texts in a table cell ● ● ●

Repeating of headers and footers ● ● ●

Table style sheets and cell styles ● ● ●

More detailed cell formatting ● ● ●

Horizontal and vertical table rules ● ● ●

Insertion of images in cells ● ● ●

Import and export of Microsoft Excel lists (XSLX, CSV) ● ● ●

Import of tables from Word (DOCX) ● ● ●

Sentence calculation / text / fonts

Function STD PROF WG

Optional real-time sentence calculation ● ● ●

Block logic for structuring (headline, abstract, body text, etc.)
with overset limitation

● ● ●

Style sheets with hierarchical text styles (assigned to para-
graph styles)

● ● ●

Dieckmann Hyphenation (DE,EN) ● ● ●

Duden Proof Factory spellchecker (DE, EN, FR, IT, SP) and
hyphenation (FR, IT, SP)

● ● ●

Support of PostScript fonts ● ● ●

Support of OpenType fonts ● ● ●

Support of typographic OpenType functions ○ ● ●

Support of TrueType version 2 fonts ● ● ●

Font selection with preview ● ● ●

Inclusion of a text status ○ ○ ●

Paragraph formatting:
· Definable alignment of the last line of a paragraph
· Individual word alignment in justified text
· Flush zone of last line in justified text
· Align to baseline grid
· Justify vertically
· Definable hyphen limit
· Definable hyphenation zone
· Leading, leading first line, leading before a paragraph,

leading after a paragraph

● ● ●
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· Indent left, indent left for n lines, indent first line, indent
right,
indent right for n lines, indent to current position

· Indent here (selected text)
· Drop caps
· Rules
· Paragraph break options: Keep lines together, keep lines

together at start, keep lines together at end,
keep all lines in paragraph together

· Bullets/Numbering
· Tabs, tabs at fixed positions (definable)

Text formatting
· Exclusion method definable for text section
· Underlining
· Superscript/subscript
· Shadow
· Background
· Hyphenation
· Spellchecker and hyphenation can be defined indi-

vidually for text sections
· Languages for spell checking and hyphenation can

be applied separately to any text range
· Small caps
· Outline font
· Breaking

● ● ●

Selection of characters/glyphs ● ● ●

Text to path (circle) ● ● ●

Libraries

Function STD PROF WG

Libraries for color definitions, style sheets, master pages,
grids, document templates

● ● ●

Library for design templates ● ● ●

Library for anchored frames ● ● ●
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Multimedia functions

Function STD PROF WG

Hyperlinks for PDF ○ ● ●

Embedding of video in PDF ○ ● ●

Embedding of audio in PDF ○ ● ●

Creation of image galleries for PDF ○ ● ●

Navigation buttons for PDF ○ ● ●

Printing/export

Function STD PROF WG

Print with print style ● ● ●

PostScript export ● ● ●

Preflight ● ● ●

PDF export with references and settings ○ ● ●

Navigable PDF ○ ● ●

Export via integrated Adobe PDF Converter (Distiller) ○ ● ●

Reduce transparency ○ ● ●

Blog function and social media

Function STD PROF WG

WordPress interface
(create, edit, publish, delete)

○ ○ ●

Interface to Twitter ○ ○ ●

Interface to Facebook ○ ○ ○

Text sections and components for HTML5-based web stories ○ ● ●

Import/export

Function STD PROF WG

Microsoft Word filter (DOC/DOCX) ● ● ●

Import of OpenDocument files (ODT) ● ● ●

Rich Text Format filter (RTF) ● ● ●

Excel filter (XSLX) ● ● ●
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ASCII and UNICODE text filters ● ● ●

IDML filter for documents from Adobe InDesign ○ ● ●

Import of Quark XPress Tags ● ● ●

Export PDF / Rich PDF with Acrobat functions / PDF with
watermark / PDF with color management

○ ● ●

Page exports EPS and JPEG ● ● ●

Export as EPUB with integration of CSS / fonts / cover image
(V2/V3)

● ● ●

Team function for collaboration

Function STD PROF WG

Collaboration via the internet (Dropbox, Drive, etc.) ○ ○ ●

Texts can be separately edited as stories ○ ○ ●

3 status each for pages, texts and images ○ ○ ●

Interface to PressMatrix (ePaper and app) ○ ○ ●

General functions

Function STD PROF WG

Loadable keyboard layouts ● ● ●

Loadable environments (panels and inspectors order etc.) ● ● ●

Automatic table of contents ○ ○ ●

Register function ○ ○ ●

Book functions (grouping of multiple documents) ○ ○ ●
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Document types

MarkStein Publisher is able to handle a vast number of document types that can be placed, impor-
ted or opened. When exporting your entire project or parts of your project, MarkStein Publisher also
shows its capabilities as a true all-rounder.

Which file formats can be placed and exported is documented in the Printing and exporting and
Working with images sections.

Document types specifically for MarkStein Publisher are:

.mxd = MarkStein Publisher page document

.mxt = MarkStein Publisher story document

.mxb = MarkStein Publisher book document

.mxf = MarkStein Publisher library document
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Story

This is a function of MarkStein Publisher Workgroup Edition.

A story is an editorial element of a publication and consists of a text that is linked to images. A story
can be created from a single text frame or by linking of several text frames. Naturally, it is possible
to create stories with multiple pages and a large number of text and image elements. Stories can
be edited independently from their layout.

More detailed information on working with stories is available in the Collaboration section of this
manual.
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Book

This is a function of MarkStein Publisher Workgroup Edition.

With this function in MarkStein Publisher Workgroup Edition, you can

·  group multiple documents for simultaneous export and adjust the pagination of the documents to
their order in the book

·  divide a publication into editorial blocks that can be edited separately, e.g. the individual chapters
of a book, or the columns of a magazine

·  create a shared table of contents or register for documents grouped together in a book.

A detailed description for working with the book function can be found in the Creating a book file
chapter.
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Table

Table basics

The MarkStein Publisher program has a powerful table tool which enables the creation of highly
complex tables.

You can also create tables entirely in MarkStein Publisher and insert the text directly in the table or
import and format tables from Microsoft® Excel.

In order for the text formatting in the table to have a uniform appearance, the required paragraph
styles and text styles are generated when creating the table.

In order for the visual appearance of tables to be uniform, table style sheets with the respective cell
styles are then created. The previously generated paragraph and text styles are then applied to the
individual cell styles.

For tables spanning multiple pages, the header and footer of the table can be set to repeat auto-
matically.
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Block logic

MarkStein Publisher is a program geared towards frames. This means all texts are placed in text
frames that can be linked with each other. To enable the assignment of specific styles to specific
text frames, there are logical blocks such as the Headline block, Abstract block, Body Text
block, Caption, Quote, Table, Keyword and Footnote.

The individual block types in MarkStein Publisher

Every text frame is assigned a block type via the Frame Properties or the Layout > Object Proper-
ties inspector or the Control panel. New text frames are created with the Body Text block type by
default.

The block type is assigned to the individual text frames via the frame properties.

You can assign the corresponding block type to the paragraph style via the paragraph properties
(Object > Properties > Frame). Every frame of a story is then also assigned a block type in the lay-
out. By selecting the block type, you define the text frames in which the paragraph should appear. A
paragraph that has been assigned the “Headline block” type is automatically placed in a frame with
this definition.

The block logic in MarkStein Publisher only allows for overset to occur in blocks. For example, if the
text of a headline block is too long, this is displayed in the page view by a red overset square. The
overset from the headline does not flow into the abstract and overset from the body text does not
flow into linked captions.
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Which block type the text should flow into can be specified in the paragraph properties.
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Style sheets

The meaning of style sheets

Working with style sheets is different from working with individual style templates (style sheets) of
other layout programs.

A style sheet includes one or several paragraph styles and unites them under a shared name. An
optional number of subordinate text styles can be assigned to every paragraph style.

This logic allows having only a reasonable number of styles available when editing a text. You no
longer need to choose between various headline styles or character styles. Via the style sheet, you
always have the right labeling in a text, such as “Headline”, “Abstract” or “Body Text”, regardless
whether you are working on a lead story, a message or the legal notice.

For this reason, a style sheet could also be referred to as a story type. Once you have completed
formatting a text, you can change the appearance of your story within a matter of seconds by chan-
ging the style sheet. This is only possible if you use the same names for the paragraph and text
styles in all style sheets.

For detailed information about creating style sheets and creating paragraph and text styles, see the
Working with style sheets section.
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Libraries

All recurring page and document elements are saved in a library. This includes colors, style sheets,
grids, master pages, table style sheets, document templates and layout templates. Within a library,
the objects are stored in folders. Multiple libraries can be created.

Further information is available in the Library section.
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Layout prior to text and image

This is a function of MarkStein Publisher Workgroup Edition.

This working method is suitable for publications for which the exact structure and extent have been
defined from the start. The layout is created with MarkStein Publisher Workgroup Edition and indi-
vidual stories can be checked out and shared on cloud-based services of your choice, such as
Dropbox or Google Drive. After editing, the stories are checked back into the layout and automatic-
ally deleted from the hard drive in order to prevent version conflicts.

Further information is available in the Collaborative work section.
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Text and image prior to layout

This is a function of MarkStein Publisher Workgroup Edition.

This working method is suitable for publications for which the exact structure and extent have not
been defined from the start. In this case, the layout is created after receipt of the manuscripts and
image files. First, stories are created from the texts of the received manuscripts with style sheets
(refer to New > Story). These are later placed in the layout.

Further information is available in the Collaborative work section.



Chapter 3

Interface

MarkStein Publisher Manual
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Interface
This chapter provides detailed information on the fundamental design of the MarkStein Publisher
program.

The working windows of the program are introduced here and you will learn how to structure a pub-
lication and create new documents and stories. You will also learn more about the concepts of
MarkStein Publisher, as understanding these is a prerequisite for effectively using the software.
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Home screen

The home screen opens upon starting the MarkStein Publisher program.

The home screen is your control center from where new documents, stories, tables and libraries
can be created, and existing templates, documents or libraries can be opened.

The home screen is divided into New, Recent, Open, Libraries, Help, Manual, MarkStein Pub-
lishing and Quit.

The home screen of MarkStein Publisher

https://publisherdoc.markstein-publishing.com/EN/Manual_Publisher.pdf
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New
If you wish to create a new document, a new story, a new book or a new table, then click on the
[New] button to switch to the New window.

If you wish to create a new flyer, a new booklet or a letterhead, you can use the pre-installed tem-
plates, which can be selected via the New window.

User-defined templates that you have created are also displayed here.

The commands for creating a new document, story, book, table, or a document based on a template, are available in the
New window.
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Document
1. In order to create a new document, click on the [New] button on the home screen to switch to

the window of the same name.

2. Double click on the New Document icon.

3. Then the New Document window opens, which is divided into three tabs: Document, Page
Size and Grid.

After double clicking on the New Document button, the New Document window opens.

In the Document tab, general settings, such as the library, document template, number of pages,
type of pages and master pages to be used can be selected.

The paper size, orientation and bleed can be defined in the Page Size tab.

In the Grid tab, the number of columns, the gutter, the line grid and the page margins can be
defined.

Once you have confirmed the settings made in the New Document window by clicking on [OK], the
new document is displayed in the working window.
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The new document is displayed in the working window.
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Structure of a document page

A: Printer spread, B: Page, C: Bleed, D: Grid, E: Line grid: F: Gutter, G: Margin

Creating a new story document
This is a function of MarkStein Publisher Workgroup Edition.

1. In order to create a new story document, click on the [New] button on the home screen to
switch to the window of the same name.

2. Double click on the New Story icon.

3. Then the New Story window opens.
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After double clicking on the New Story button, the New Story window opens.

4. Enter the name under which you wish to save the story in the Name entry field.

The name under which the new story is to be saved is entered in the Name entry field.

5. The directory in which you last saved a table, story or document is displayed in the Path entry
field. Clicking on the three dots ... next to the entry field opens the Select Path window which
enables you to change the location in which the file is saved.

6. Select the folder and click on [Select Folder].
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Selecting the storage path

7. In the lower part of the New Story window, you can select a library from the Library drop-down
menu.

8. After selecting a library, the style sheets saved in the library are available for selection from the
Style Sheet drop-down menu.

Display of the New Story window without a library

Display of the New Story window with selection of a library
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9. Once you have confirmed the settings made in the New Story window by clicking on [OK], the
new document is displayed in the working window and you can directly begin entering your text.

The new story document is already displayed in the working window.

Creating an new table document
1. In order to create a new table document, click on the [New] button on the home screen to

switch to the window of the same name.

2. Double click on the New Table icon.

3. Then the New Table window opens.
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After double clicking on the New Document button, the New Table window opens.

4. Enter the name under which you wish to save the table in the Name entry field.

The name under which the new table is to be saved is entered in the Name entry field.

5. The directory in which you last saved a table, story or document is displayed in the Path entry
field. Clicking on the three dots ... next to the entry field, opens the Select path window via
which you can change the location in which the file is saved.

6. Select the folder and click on [Select Folder].
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Selecting the storage path

7. In the lower part of the New Table window, you can select a library from the Library drop-down
menu.

8. After selecting a library, the style sheets saved in the library are available for selection from the
Style Sheet drop-down menu.

Display of the New Table window without a Library

Display of the New Table window with selection of a Library

9. Once you have confirmed the settings made in the New Table window by clicking on [OK], the
Table wizard opens, via which you can define the table properties and table structure.
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The table properties (page 1) are defined using the Table wizard
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The table structures (page 2) are defined using the Table wizard

10. Once you have defined the table properties, click on [Finish].

11. The new table document is displayed in the working window and you can directly begin enter-
ing your text.
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The new table document is displayed in the working window.
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Creating a new book
This is a function of MarkStein Publisher Workgroup Edition

In order to create a new book, click on the New Book icon on the home screen, name the file, se-
lect a save location and click on [Save].

A detailed description for working with the book function can be found in the Creating a book file
chapter.

Document based on a template
Use a template if you regularly create similar projects. Templates assist you in creating consistent
documents more quickly while protecting the original document.

Templates are a good starting point for standard documents, as they can be saved with presettings
for layout, graphics and text. For example, if you wish to create a magazine that is published on a
monthly basis, you can create a template that includes the layout of typical issue and reference
lines, grids, example pages, user-defined styles and color fields, placeholder frames or levels, as
well as standard graphics or standard texts. To create a new issue of a magazine, simply open the
respective template.

Templates are created in the same manner as regular documents, the only difference is that you
need to save template files to a specific directory.

Creating a new document from a template

1. To create a new document from a template, click on the [New] button on the home screen to
switch to the window of the same name.

2. Double click on the icon of the template you wish to use.
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In order to create a new document from a template, all you need to do is click on the respective template in the New tab
of the home screen.

3. Then the selected template document opens and you can start working.

The template document is opened as a new file.

4. Save the new document under its own name.
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Saving a new document as a template

1. In order to create a template from a currently opened document, select the menu option File >
Save as template.

2. Enter the name under which you wish to save the template in the File Name entry field

3. Switch to the ...\AppData\Roaming\MarkStein\Templates (Windows only) directory if its not
already opened.

4. Click [Save] to save the template in the directory.

In order to create a template file from a MarkStein Publisher document, the file needs to be saved to the Templates dir-
ectory.

5. After saving, the template will be directly available in the Start window via the New tab.
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After restarting the MarkStein Publisher program, the new template is available in the Start > New window.

Editing a template

1. Select Start > Open to edit a template file.

2. Open the file from the ...\AppData\Roaming\MarkStein\Templates (Windows only) directory.

3. Make your changes and save the template file under its respective name in the ...\Ap-
pData\Roaming\MarkStein\Templates directory.

Deleting a template

Switch to the ...\AppData\Roaming\MarkStein\Templates directory (Windows only) in your file sys-
tem and delete the template you no longer need.
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List of template files
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Recent
The list of recently opened documents and recently placed images is displayed when you click on
the [Recent] button on the home screen.

Information on the selected document is displayed in the Details window on the right-hand side.

Window of recently opened documents in icon view. Below the icon window you find a slider to enlarge or decrease the
size of the icons and two buttons to switch between icon and list view. 

You can display the recently opened documents as a list by clicking on the Switching to list view
button.

Window of recently opened documents in list view
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Open file
1. In order to open an existing file from the file system, click on the [Open] button on the home

screen.

2. In the Open Document window, select the directory which contains the file you wish to open.

3. Select the file and click [Open].

Use the drop-down menu to select the file type you wish to open.
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Opening book files, InDesign exchange files

You can also use the Open command to open InDesign exchange files (.idml) or MarkStein Pub-
lisher page documents (.mxd) or a MarkStein Publisher book file (.mxb). Then select the desired file
format from the drop-down menu next to the file name.

Selecting the file type to be opened
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Library

The significance of libraries

All recurring page and document elements can be saved in a library. This includes colors, style
sheets, grids, master pages, table style sheets, document templates and layout templates. Within a
library, the objects are stored in folders. Multiple libraries can be created.

You can create as many libraries as desired. When creating a new document, the contents of the
selected library are transferred to the library of the document.

A new library contains folders for colors, style sheets, grids, master pages and table style sheets by
default. Some elements, such as layout templates, document templates and story templates can be
saved in additional user-defined folders.

Standard elements of a new library

Note: The libraries in MarkStein Publisher are completely independent from the documents due to
the document focus. Changes to the library therefore do not automatically affect the document. You
need to drag the respective edited elements, such as style sheets or colors, to the existing docu-
ment and thus update the document.
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First steps
The first steps in using MarkStein Publisher are described in the Working methods chapter of the
manual.
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Online help
To open the online help, click on [Help] on the home screen, or press <F1>.

You can enter a search term in the Search entry field.
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MarkStein Publishing website
If you have an internet connection, click on [MarkStein Publishing] on the home screen to directly
access the website of https://www.markstein-publishing.com.

This website provides useful information as well as tips and tricks to make your life easier when
working with MarkStein Publisher.

https://www.markstein-publishing.com
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Quit Program
In order to quit the program, select File > Quit.

  

Menu option File > Quit. Left: menu of File tab in layout mode; right: menu of File tab in story mode.

You can also quit the program by switching to the Start tab in the working window and then clicking
on [Quit].
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The MarkStein Publisher program can also be closed via the Start tab by clicking on Quit.

When closing the program, all open documents are closed with it. If these documents contain un-
saved changes, a notification window appears via which you can save the changes, disregard them
or cancel the process of closing the program.
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Workspace

When you open a document in MarkStein Publisher, all tools, menus and panels for editing the lay-
out are available to you. You can activate and deactivate them as needed, for example in order to
have a less crowded screen.

The workspace of MarkStein Publisher:A: Menu bar for selecting menu options, B: Tab for Start and currently opened
document, C: Toolbar for Standard, View and panels, D: Horizontal ruler, E: Vertical ruler, F: Toolbar, G: Pasteboard,
H: Currently displayed and active page, I: Object on pasteboard, J: Status bar, K: Control panel, L: Displayed panel, M:
Inspectors

The menu bar, via which the individual menu options can be selected, is located in the upper area
of the program.

Use the Start tab to switch directly to the home screen, where you can create new documents.
Already opened documents are also displayed as tabs. Click on the respective tab to switch directly
to the document.

The Default, View and Panels toolbars are displayed immediately below the menu bar. The op-
tions displayed there can be executed by clicking on the respective button.

The buttons in the Default toolbar allow you to Save and Print the currently opened document.

It also contains the Undo and Redo buttons. Click the Undo button to undo the most recent steps.
You can undo up to 99 steps.

Undone steps can be retraced by clicking the Redo button. You can redo up to 99 steps.

IMPORTANT: Due to the consistent separation of layout and text in MarkStein Publisher, there are
separate buffers for deletions regarding text and layout. This means the editing command only af-
fects either layout or text changes. If you wish to undo changes to both layout and text, you need to
use Undo/Redo in both layout and text mode, in order to Undo or Redo your most recent actions.

The view toolbar contains the buttons via which you can switch to the various view modes.
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The toolbar for tools is located in the left-hand area in the window. It contains all tools you need to
create and lay out objects of any kind.

The inspectors for text, layout and tables are displayed on the right-hand edge of the window. The
inspectors contain all options with which you can define the parameters for text, graphic, image and
table objects.

The toolbar for the control panel is displayed in lower part of the window by default. You can also
drag the control panel to the upper edge of the window. Values displayed in this panel depend on
the selected objects. Changes can be made to objects and text immediately by using these values.

Below the document window, the status bar provides you with information on the chosen zoom
factor and currently selected object. Use the status bar to edit the current viewing size and navigate
between the pages of the current document.

You can also use the View > Rulers option to display or hide the horizontal and vertical rulers. If the
rulers are displayed, they can be used to draw reference lines.

The current page number is shown above the page.

Objects located on the pasteboard surrounding the pages are not taken into consideration in the
output or the original view. They are not displayed and not output.
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Tools

The toolbar contains numerous tools with which new objects can be created and existing objects
can be edited. The currently selected tool is highlighted in color.

A small triangle is located at the lower right-hand corner of some buttons. This means more tools
are hidden behind this button. These can be displayed by clicking on the respective tool and briefly
holding down the mouse button. You can then select the desired tool as you normally would.

The tools can be selected not only by clicking on them, but also by entering a letter; the keys as-
signed to each tool can be found in the table below.

The toolbar with the hidden tools displayed

The various tools

Selection: Activate and deactivate objects V

Image content: Manually move image content within image frame A

Text content: Insert and edit texts T
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Table: Convert selected text frames or linked text frames into a table,
edit existing tables

C

Rectangle Frame: Create rectangular image frames B

Ellipse Frame: Create elliptical or round image frames

Polygon Frame: Create polygon image frames

Rectangle Frame: Create rectangular text frames T

Ellipse Frame: Create elliptical or round text frames

Polygon Frame: Create polygonal text frames

Draw Line: Draw horizontal, vertical or diagonal lines L

Draw Line Orthogonal: Draw horizontal or vertical orthogonal lines
or lines at a 45° angle

Draw Bézier line: Creating Bézier lines and shapes N

Edit Bézier line: Edit Bézier lines and shapes, image and text
frames 

M

Rotate: Manually rotate activated objects R

Eyedropper: Select and transfer frame and text attributes P

Link: Link text frames, image frames, object frames and lines K

Move: Move the current view. To temporarily select the tool, press
<Ctrl> + <Alt> (Win) or <Cmd> + <Alt> (Mac). After releasing the
keys, the previously selected tool is active again. 

H

Magnify: Zoom in or out of the current view. Temporary selection
with <Ctrl> + <Shift> + <Alt> (Win) or <Cmd> + <Shift> + <Alt>
(Mac).

Z

Selection tool (V)

Use the Selection tool to select individual or multiple objects.

In order to select multiple objects, activate the first object with the Selection tool and activate fur-
ther objects by simultaneously pressing the <Shift> key and activating the next object.

Double-click on one object of a chain to select all objects linked to it.
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You can also activate multiple objects by drawing an activation rectangle with the Selection tool. In
doing so, all objects touching the activation rectangle are selected.

To deactivate all activated objects, use the Selection tool to click on the drawing area or press
<Esc>.

Hold down the <Shift> key and click on the object you wish to deactivate in order to deselect indi-
vidual objects from an activation.

If several objects are layered underneath or behind each other, you can activate the respective un-
derlying object by holding down the <Ctrl> or <Cmd> key and clicking on the activated object again.
This enables you to activate individual objects within the Z-order without changing the order of the
objects themselves. Once you have activated the last object in the order, the next click activates the
top object.

Image content tool (A)

Once an image has been assigned to an image frame, the part of the image located inside the
frame can be determined using the Image content tool. To do this, select the tool, then click on the
image while pressing down the left mouse button and move the image section within the frame. The
invisible part of the image is displayed less clearly, allowing you to also see the image contents not
displayed within the image frame.

By moving the image content using the Image content tool, the section of the image outside the image frame is dis-
played less clearly.

Text content tool (T)

If you wish to insert text in a text frame or edit existing text within the frame, select the Text content
tool and click inside the text frame. Then you can insert text or make corrections. Use the Text con-
tent tool to select texts you wish to format differently.
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Selecting the Text content tool activates the editing mode for text.

Table tool (C)

The program comes with a powerful table tool, which enables the creation of even the most com-
plex tables. When you activate a frame and then click on the Table tool in the toolbar, this frame is
converted into a table. The same applies for linked frames.

Rectangle Image Frame tool

Use the Rectangle Frame tool to create new rectangular image frames on the page. Press <Shift>
while creating an image frame to create square frames. Size and appearance of the image frame
can then be specified via the frame properties or the control panel.

Per default you can insert images but not text when creating an image frame. However, using the
Object > Content Typemenu option, or the frame properties, allows you to change the possible
content of an image frame retroactively. This means an image frame can later be converted into a
text or object frame. Choosing the Text option in an image frame allows you to load an image and
insert text in the same frame.

Further information on working with frames is available in the Working with frames section.

Ellipse Image Frame tool

Use the Ellipse Frame tool to create new elliptical image frames on the page. Press <Shift> while
creating an image frame to create elliptical frames. Size and appearance of the image frame can
then be specified via the frame properties or the control panel.
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By default you can insert images but not text when creating an image frame. However, using the
Object > Content Type menu option, or the frame properties, allows you to change the possible
content of an image frame retroactively. This means an image frame can later be converted into a
text or object frame. Choosing the Text option in an image frame allows you to load an image and
insert text in the same frame.

Further information on working with frames is available in the Working with frames section.

Polygon Image Frame tool

Use the Polygon Frame tool to create new polygonal image frames on the page. Press <Shift>
while creating an image frame to create an polygon with the size of a square. The size and appear-
ance of the image frame can then be specified via the frame properties or the control panel.

By default, you can insert images but not text when creating an image frame. However, using the
Object > Content Type menu option, or the frame properties, allows you to change the possible
content of an image frame retroactively. This means an image frame can later be converted into a
text or object frame. Choosing the Text option in an image frame when loading an image allows you
to insert text in the same frame.

Further information on working with frames is available in the Working with frames section.

Text Frame tool (T)

Use the Rectangle Frame tool to create new rectangular text frames on the page. Press <Shift>
while dragging a text frame to create square frames. The size and appearance of the text frame can
then be specified via the frame properties or the control panel.

By default you can insert text but not images when creating a text frame. However, using the Object
> Content Type menu option or the frame properties, allows you to change the possible content of
a text frame retroactively. This means a text frame can later be converted into an image or object
frame. Selecting the Image option allows you to insert an image in the frame in addition to the text.

Further information on working with frames is available in the Working with frames section.

Ellipse Text Frame tool

Use the Ellipse Frame tool to create new elliptical text frames on the page. Press <Shift> while
creating a text frame to create a circular text frame. The size and appearance of the text frame can
then be specified via the frame properties or the control panel.

By default you can insert text but not images when creating a text frame. However, using the Object
> Content Type menu option or the frame properties, allows you to change the possible content of
a text frame retroactively. This means a text frame can later be converted into an image or object
frame. Selecting the Image option allows you to insert an image in the frame in addition to the text.

Further information on working with frames is available in the Working with frames section.

Polygon Text Frame tool

Use the Polygon Frame toolto create new polygonal text frames. Press <Shift> while creating an
image frame to create a polygon with the size of a square. The size and appearance of the text
frame can then be specified via the frame properties or the control panel.

By default you can insert text but not images when creating a text frame. However, using the Object
> Content Type menu option or the frame properties, allows you to change the possible content of
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a text frame retroactively. This means a text frame can later be converted into an image or object
frame. Selecting the Image option allows you to insert an image in the frame in addition to the text.

Further information on working with frames is available in the Working with frames section.

Draw Line tool (L)

Use the Draw Line tool to draw new horizontal, vertical or diagonal lines. After selecting the tool,
click on the position in the document from which the line should start and drag the mouse in the de-
sired direction. During this process the line is displayed in red. It ends at the position where you re-
lease the mouse button and then appears on the page.

Creating a line with the Draw Line tool

In order to draw lines at a 45° angle with the Draw Line tool, hold down the <Shift> key while draw-
ing the line.

Draw Line Orthogonal tool

Select the Draw Line Orthogonal tool to draw horizontal or vertical lines at a right angle or draw
lines at a 45° angle. After selecting the tool, click on the position in the document from which the
line should start and drag the mouse in the direction the line should go. While doing this, the line is
displayed in red. The line ends at the position where you release the mouse button and then ap-
pears on the page.

Creating an orthogonal horizontal line with the draw line orthogonal tool

Bézier Shape (N)

With this tool you can freely create line elements or frames.

Further information on editing paths is available in the Editing Bézier paths section.
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Edit Bézier Elemets (M)

With this tool you can edit lines, frames or freely created Bézier elements.

Further information on editing paths is available in the Editing Bézier paths section.

Rotate tool (R)

You can rotate selected objects on an axis defined by you at an exact angle via the control panel or
frame properties.

You can freely rotate an activated object on the page using the Rotate tool. Left-click on the de-
sired position to define the pivot point. Hold down the mouse button and drag the mouse in the de-
sired direction. This creates a pivot lever with which you can move the object around the selected
pivot point. The bigger the distance of the tool to the pivot point, the more precisely the rotation can
be controlled. While rotating, the outline of the object is displayed. By releasing the mouse button
you place the object at the indicated position.

Free rotation of an activated object using the rotate tool.

Eyedropper tool (P)

The Eyedropper tool enables you to assume and transfer the properties of a text, paragraph or
frame to other objects. This is explained in detail in the Working with the eyedropper section.

Link tool (K)

The Link tool enables you to link multiple frames together. Any frames can be linked together. The
order in which they are linked defines the text flow in text frames.

Linking frames

Select the Link tool from the toolbar to link multiple frames and click on the frames in the desired
order. Either left-click on an empty area on the page, or select a different tool to complete the link-
ing process. Arrows indicate the linking order while linking objects.
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When creating the linking order, the currently selected frame is indicated with a green border. All
frames already linked together are displayed with cyan-colored border.

Fig. left: Selecting the first frame to be linked; Fig. right: Selecting the last frame to link additional frames

This is explained in detail in the Linking of frames section.

Move tool (H)

The Move tool enables you to move the current image section on the displayed page. After select-
ing the tool, the cursor transforms into a hand, which you can now use to left-click anywhere. Now
hold down the mouse button and drag the section to the desired position.

You can also use the tool to switch from one page to the next.

Hint: You can also temporarily call up the move tool without leaving your current tool by simultan-
eously pressing <Ctrl> / <Cmd> and the <Alt> key and moving the image section. The previously
selected tool is activated again upon releasing the mouse button.

Magnify tool (Z)

Use the Magnify tool and the option for maximizing and minimizing to zoom in or out of any de-
sired area in the workspace. The current zoom factor is shown in status bar in the bottom left
corner.

To maximize the current view, select the tool, then left-click on the area to be maximized. Every
click of the mouse maximizes the magnification by the value predefined in the preferences. The de-
fault value there is set to a magnification factor of 10%- This value can be increased up to 100%.
To do this, select the Extras > Preferences > Edit menu option and switch to the View tab. Enter
your desired factor in the Increment of Magnifying Glass (+/-)  entry field.
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In the Preferences of MarkStein Publisher, the increment of the magnifying glass can be set in the View tab in the
Zoom section.

Click with the right mouse button or press the <Ctrl> or <Cmd> key while clicking with the left
mouse button to minimize the view by the value defined in the preferences.

You can also draw a selection rectangle with the Magnify tool. After releasing the mouse button,
the selected area is then magnified until it fills the entire workspace window.

Another way to change the view size is to use the Zoom In and Zoom Out menu items in the View
> Zoom  menu. These menu items have keyboard shortcuts assigned to them, so you can perform
these functions with <Ctrl> key (Win) or <Cmd> key (Mac) and + (plus) or - (minus).

Hint: You can also temporarily use the magnify tool without leaving your current tool by simultan-
eously pressing <Ctrl> (Win) / <Cmd> (Mac), <Shift> and <Alt> key and zooming in the image sec-
tion as described above. The previously selected tool is activated again upon releasing the mouse
button.
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An area selected with the selection rectangle of the magnify tool is magnified once the mouse button is released.
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Frame tools

Different frame types

There are three different frame types in MarkStein Publisher: Text, Image and Box.

Select one of the Text Frame tools from the toolbar if you wish to create a frame that should con-
tain text. Four different text frame tools are available in MarkStein Publisher: rectangular text
frames, elliptical text frames, polygonal text frames and free-form text frames.

The various text frames can be selected from the toolbar.

Select one of the Image Frame tools from the toolbar if you wish to create a frame that should con-
tain an image or graphic. Four different image frame tools are available in MarkStein Publisher:
rectangular image frames, elliptical image frames, polygonal image frames and free-form image
frames.

The various image frames can be selected from the toolbar.

A separate tool for creating Box Frames is not available from the toolbar. However, you can create
a text or image frame and convert it into a box frame.

No text or images can be inserted into a box frame. Select a box frame if the frame should not have
any content. You can alter the appearance of a box frame via the Frame Properties (Frames con-
text menu) or the respective inspectors on the right-hand side of the window. You can add a
stroke, a margin or area fill to a box frame.

The different frame types from left to right: text frame, image frame, box frame and a frame containing both text and an
image. The upper row shows the appearance of a frame immediately after it has been created. In the lower row, the re-
spective frame content has been assigned to the frames.
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Creating frames

Select one of the frame tools, click with the left mouse button at the position where you want the up-
per left corner of the frame to be and drag the frame to the desired size while holding down the
mouse button. 
Frame edges that snap to the type area, page margin, guides or line grid are highlighted in red. 
When moving a frame with the selection tool, frame edges that correspond to edges of already ex-
isting frames are also highlighted in red.

If you also hold down the <Shift> key while drawing, the frame is drawn up proportionally, height
and width are then identical.

Converting frame types

Depending on the selected tool, a frame may contain either text or an image.

However, every frame can be altered to contain text and an image.

It is also possible to convert a text or image frame into a box frame at any time. A box frame can be
converted into an image or text frame.

A frame type can be converted via the Object > Content Type menu option or via Frame Proper-
ties.

Margin or stroke? Defining frame properties

For every frame, you can define a Margin and a Stroke in the frame properties.

You can also assign a different color to the background or stroke color for all edges or every indi-
vidual edge of a frame. Unlike the stroke, the specified Margins are always defined within the cre-
ated frame.

If you have added a margin to a frame which contains text, the text is not displaced by the defined
margins. The distances between the text and frame edge can be defined individually in the Text
tab.

Fig. left: Defining a margin does not displace the text within a frame. 
Fig. right: Text with margin to the frame

If an image is assigned to the frame with a defined margin, the image content is automatically
moved from its original frame position by the distance corresponding to the entry of the margin
value.
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Fig. left: Position of the image within the frame with left margin value = 0. 
Fig. right: In this image, a margin of 5 mm has been inserted and a margin color selected. The image content has been
moved corresponding to the margin settings within the image frame.

In the Frame Properties in the Stroke tab – or in the Layout > Stroke inspector – you can add an
outline to a frame if desired. Unlike a margin, a stroke is always applied to all edges of a frame. In
the frame properties in MarkStein Publisher, you can define how a stroke should be formed. You
can choose between the options Center, Outside and Inside.

Selecting the Center option positions half of the specified stroke weight inside the frame and the
other half outside the frame. Selecting the Outside option positions all of the specified stroke
weight outside the frame. The Inside option positions the specified stroke weight inside the frame.

Stroke: Line position from left to right: Center, Outside and Inside.

Grouping of objects

Individual active objects can be grouped together using the Object > Group option, meaning they
are treated as a unit when they are moved.

When grouping objects, the selected objects which overlap each other in the stack order (Z-order)
are united in the order behind the object which was selected first.

If you group objects located on different layers, all objects are moved to the top layer.

If you click a group with the Selection tool, the entire group will be activated. If you wish to edit a
single object in the group, you do not need ungroup. Individual objects within a group can be selec-
ted by clicking on the object in the group while pressing <Ctrl> + <Shift>.

To ungroup objects, activate the group with the selection tool and select the Object > Ungroup op-
tion. Individual objects can then be reactivated and edited again.

Another way of grouping multiple objects together is to link them with each other. Linked objects
can be selected by double-clicking and then moved together.
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Eyedropper
The Eyedropper tool can be used to select and transfer text and frame attributes.

Transferring text attributes

To select text attributes, click on the text with the formatting you wish to transfer using the eyedrop-
per. This saves the text properties at the cursor position.

Eyedropper before selection, “empty”

The eyedropper now shows that it has been “filled” with properties.

Eyedropper after selection, “filled”

Now, select the text you wish to format while holding down the left mouse button and with the filled
eyedropper. The eyedropper then transfers the text formatting of the original text to the selected
text.

Transferring the selected text formatting to the selected text.

Clicking on a random cursor position with the filled eyedropper formats the corresponding word.
Double-clicking on a paragraph with the filled eyedropper will format the entire paragraph and the
paragraph properties of the original text will also be transferred.

Transferring the selected text formatting to a random cursor position to format a word.

Another way to transfer a text attribute is to use the Text tool to select a text passage and then use
the Eyedropper to click the text passage whose attributes you want to transfer. This works both
within a chain and between unlinked text frames with different format groups. 
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Transferring frame attributes

You can also format frames in the same manner using the eyedropper. Click on a frame with the
empty eyedropper: The eyedropper is now filled with the frame properties.

Eyedropper before selection, “empty” and after selection, “filled”

Click on a new frame with the filled eyedropper to transfer the properties of the original frame to the
target frame.

Transferring frame attributes selected with the eyedropper to another frame object.

Press the <Shift> key while transferring frame properties if the target frame contains text to which
the properties of the source text should not be transferred. This way, only the frame properties are
transferred and not the text properties.

Refilling the filled eyedropper

Pressing the <Ctrl> key or <Cmd> key empties the eyedropper and fills it with the properties at the
current cursor position.

Emptying the eyedropper

Click on free space on the page to “empty” the eyedropper.
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Linking frames

Linking of frames

The Link tool enables you to link multiple frames together. Any frames can be linked together.

The order in which they are linked defines the text flow in text frames.

Select the Link tool from the toolbar and then click on the frames in the desired order to link mul-
tiple frames. Either left-click on an empty area on the page or select a different tool to complete the
linking process. Arrows indicate the linking order while linking objects.

All objects that are a linked together are activated by pressing the <Alt> key and clicking on one of
the linked elements. This way, entire groups of frames can be moved without having to be selected
or grouped first.

When creating the linking order, the currently selected frame is indicated by a green border. All
frames already linked together are displayed with cyan-colored border.

Fig. left: Selecting the first frame to be linked 
Fig. right: Selecting the last frame of a chain to add further frames

Select the Link tool and double-click on the last frame of the active chain to add additional frames
to the chain later on. This gives the frame a green border. Then click on the next frame you wish to
link.

If you subsequently wish to add one or multiple frames within a chain, select the Link tool and
double-click on the linked frame after which the additional frames are to be inserted. Then click on
the frame you wish to add. All subsequent, already linked frames of the original linking remain and
are continued after the inserted frame.

Links can be created across several pages. To continue linking on a subsequent page, use the
page panel or control panel to switch to the desired page and continue linking there.
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To remove a single frame from the chain, select the Link tool, press the <Ctrl> or <Cmd> key and
click on the frame that you wish to remove from the current chain, or select the Object > Unlink
menu option. The frame itself is not deleted and the chain automatically continues with the remain-
ing frames and is not deleted either.

To remove multiple frames from the chain, activate the frames with the Selection tool and select
the Object > Unlink option. Subsequent frame linkings remain the same.

Use the selection tool to activate and edit or move individual frames of a chain. To select multiple
linked frames, activate the first frame with the selection tool, then press the <Shift> key and activate
all further frames one after the other. To activate all frames in a chain, click on any frame within the
chain while pressing the <Alt> key.

You can delete one or several linked frames by selecting them and choosing the Edit > Delete op-
tion or pressing the <Del> key. If a text frame is deleted, the text contained in the frame automatic-
ally flows to the subsequently linked text frames.

To delete an entire chain, click on a linked frame while pressing the <Alt> key and select the Edit >
Delete option or press the <Del> key.

You can use the command View > Show Links to display the linking order of the current chain.
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Line grid and baseline grid

Line grid of the page

The type area specifications of a new document
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When you create a new document, you make the basic settings for the line grid of the newly created
pages. 
However, you can also set the line grid individually for each page at a later date. To do this, select
the command Page > Page size... or the Page size... command in the context menu of the relevant
page in the Pages panel.

By default, the line grid serves as a drag aid for your text and image frames.

Line Grid: The step size of the line grid is usually entered with the value of the line spacing of the
basic text. On the basis of the value entered and the upper and lower page margins, the number of
lines is shown aside.

Lines: Instead of the step size, you can also enter the number of lines. The step size of the line grid
in the line grid input field is calculated automatically on the basis of the number of lines entered and
the values of the upper and lower page margins.

Start: In this input field, enter the position of the first line of the row grid relative to the starting point
selected in the Relative to: drop-down list.

Relative to:

Margin Top: If you select the option, the first line of the row grid is at the position specified in the Start
input field relative to the top margin entered in the Margin Top input field.

Top of Page: If you select the option, the first line of the row grid is relative to the top of the page. In
this case, the value entered in the Margin Top input field is not taken into account.

Use as Baseline Grid: Activate this option if the line grid is to be used automatically in text frames
as baseline grid. Please note that you then have to set the paragraph format of the text to Baseline
Grid.
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Above: Line grid of the page starting at the margin top without space
Below: Line grid of the page starting at the top of page without space.
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Above: Line grid of the page starting at the margin top with space 10 mm.
Below: Line grid of the page starting at the top of page with space 10 mm.
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Baseline grid of frames

A baseline grid is usually used to simplify the registration of the continuous text/basic text in a multi-
page layout. You have several options for assigning a baseline grid to the text frame:

When creating a document, activate the Line grid as Use as Baseline Grid check box on the Grid
tab page. All text frames automatically adopt the line grid as the baseline grid.

If you have not selected this option, you can have the values of the line grid entered in the Text tab
of the Frame properties using the Object > Apply baseline grid command; then activate the
Baseline grid check box to apply the values.

To assign an individual baseline grid different from the line grid to a text frame, enter the desired
values in the Text tab of the Frame properties and activate the Baseline grid check box to apply
the values.

Using the menu command View > Line Grid > Show Lines you can show or hide the line grid.

If the option Magnetic is activated in the menu command View > Line Grid > Magnetic, an object
is automatically attracted by the nearest grid line when it is created or moved.

The line grid provides assistance when creating or moving objects.

As the line grid acts as a design aid, texts in a text frame are not automatically drawn to it.

Activating baseline grid for frames

If the text is to be created using the baseline grid, the increment of the baseline grid for the text
frame is first set via the Frame properties. The increment of the leading of the basic text is used
here as well. Using the Object > Apply Baseline Grid menu option, you can apply the increment of
the line grid as the increment for the baseline grid for selected frames.
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The increment of the baseline grid is entered in the frame properties.

The baseline grid for text frames can be displayed separately using the View > Text Frame >
Show Baseline Grid menu option.

Text frame with visible baseline grid.

If text is inserted in a frame for which a baseline grid has been defined, the text is not automatically
aligned with the baseline grid of the frame.
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The text in a frame is not automatically aligned to the baseline grid.

Aligning text with the baseline grid

If a paragraph is to be drawn to the baseline grid, the baseline grid needs to be activated for the
paragraph.

You can activate the baseline grid for all lines in a paragraph or only for the first line in a para-
graph.

The baseline grid can be activated for all lines or the first line only of a paragraph.

In order to avoid having to activate the baseline grid individually for every paragraph, the Align to
baseline grid option should be activated in the paragraph styles for all paragraph styles that should
align with the baseline grid.

After activating the Align to baseline grid option, the text is automatically aligned with the nearest
baseline grid.
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After activating the baseline grid, the text is automatically aligned to the nearest baseline.
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For marginal text, the baseline grid was only activated for the first line so the first line shares a baseline with the basic
text. All following lines have the leading which was defined for the paragraph.

Only paragraphs for which the Align to baseline grid option was activated are aligned to the
baseline grid.

If you have activated the baseline grid for a paragraph with a leading smaller than the increment of
the baseline grid, the text is automatically aligned to the baseline grid. An activated baseline grid al-
ways takes effect over the defined leading.

If the leading is larger than the increment of the baseline grid, the text is automatically aligned with
every second baseline.
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The text is automatically aligned with every second baseline, if the leading is larger than the increment of the baseline
grid.
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Toolbars

The Toolbars submenu, allows you to hide or show the Default, View, Collaboration, Panels,
Tools and Control Panel toolbars.

The individual toolbars can be hidden or shown via the Toolbars submenu.
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Toolbar Default
Select the Windows > Toolbars > Default option to show the main toolbar that is displayed imme-
diately below the menu bar by default.

Toolbar Default

Default Toolbar: A: Save, B: Print, C: Undo, D: Redo
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Toolbar View
Select the Windows > Toolbars > View option to show the View toolbar that is displayed immedi-
ately below the menu bar by default.

Toolbar View

View Toolbar: A: Original, B: Status View, C: Arrange Spreads Vertically, D: Arrange Spreads Horizontally, E: One Page
Back, F: One Page Forward, G: Script View, H: Galley View, I: Tile Horizontally

View toolbar in word processing mode

View Toolbar: A: Script View, B: Galley View, C: Tile Horizontally, D: Page View
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Toolbar Collaboration
Collaboration toolbar in MarkStein Publisher Workgroup Edition:

Select the Windows > Toolbars > Collaboration option to show the Collaboration toolbar that is
displayed immediately below the menu bar by default.

Collaboration toolbar: A: Check Out, B: Check In, C: Detach, D: Synchronize.
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Control Panel / Status Bar
Select the Windows > Toolbars > Control Panel option to show or hide the control panel. The
control panel display depends on the selections made on the page.

The control panel provides information on the selected object and allows you to make changes to
the object.

By default, the control panel is located at the bottom of the window, but you can also place it above
the document window by clicking on the dotted line at the left edge and dragging the panel to the
top of the window while holding down the mouse button.

Scale content (version 7.3 or higher)

Scale content: If you activate this option, the image and text contents are scaled proportionally when the frame is res-
ized using the input fields.

Status bar

The Status bar is located at the bottom of the window and provides information on the current view
and the X and Y positions of the cursor. The displayed values depend on the selected object.

A: Status bar, B: Control panel

Display of the control panel and status bar when a text frame is selected

The Status bar when a text frame is selected: A: Fit Page to Window, B: Select Zoom Factor, C: First Document Page,
D: Previous Page, E: Page Selection, F: Next Page, G: Last Page, H: Number of Lines, Display of Overset or Underset,
I: Selected Object, J: Current Library

The Control panel when a text frame is selected: K: Reference Point, L: X Starting Point, M: Frame Width, N: Block,
O: Rotate 90° Counterclockwise, P: Angle, Q: Columns, R: Close Control panel, S: Y Starting Point, T: Frame Height,
U: No Text Wrap, V: Offset, W: Gutter
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Display of the control panel and status bar when an image frame is selected

The Status bar when an image frame is selected: A: Fit Page to Window, B: Select Zoom Factor, C: First Document
Page, D: Previous Page, E: Page Selection, F: Next Page, G: Last Page, H: Number of Lines, Display of Overset or
Underset, I: Name of the current image and actual image resolution J: Current Library

The Control panel when an image frame is selected: K: Reference Point, L: X Starting Point, M: Frame Width, N:
Block, O: Rotate 90° Counterclockwise, P: Angle, Q: Columns, R: Reference Point Image Content, S: Scale X, T: Offset
X, U: Angle, V: Flip Vertically, W: Close Control panel, X: Y Starting Point, Y: Height, Z: No Text Wrap, 1: Offset, 2:
Gutter, 3: Scale Y, 4: Offset Y, 5: Transparency, 6: Flip Horizontally

Display of the control panel and status bar in word processing mode

The Status bar in word processing mode: A: Fit Page to Window, B: Select Zoom Factor, C: First Document Page, D:
Previous Page, E: Page Selection, F: Next Page, G: Last Page, H: Number of Lines, Display of Overset or Underset, I:
Selected Object, J: Current Library

The Control panel in word processing mode: K: Paragraph Style, L: Font, M: Font Size, N: Kerning, O: Left, P: Center,
Q: Superscript, R: Close Control panel, S: Text Style, T: Font Style, U: Leading, V: Tracking, W: Right, X: Justified, Y:
Subscript

Display of the control panel and status bar when a line is selected

The Status bar when a line is selected: A: Fit Page to Window, B: Select Zoom Factor, C: 1. Document Page, D: Previ-
ous Page, E: Page Selection, F: Next Page, G: Last Page, H: Current Library

The Control panel when a line is selected: I1: Reference Point (2 reference points: starting point and end point); J1: X1
= X starting point, K1: Y1 = Y starting point, L: Style, M: Beginning, N: Color, O: Close Control panel, P1: X2 = X end
point, Q1: Y2 = Y end point, R: Weight, S: Ending, T: Tint, U: Opacity

The Control panel when a line is selected: I2: Reference Point (1 reference point) J2: X = X starting point, K2: Length,
P2: Y Starting Point, Q2: Angle
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Panels
Select the Windows > Toolbars > Panels option to show the panels toolbar that is displayed im-
mediately below the menu bar per default.

Panels toolbar in mode Object

Panels toolbar: A: Pages, B: Layers, C: Templates, D: Colors, E: Styles, F: Table Styles, G: Glyphs, H: Notes, I: Align

Panels toolbar in mode Text

Panels toolbar: A: Styles, B: Templates, C: Glyphs, D: Notes
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Pages panel
Master pages and grids can be created, edited and deleted via the Pages panel.

Example pages are designed via the Pages panel. Double-clicking on a master page opens the ex-
ample page on which the default elements are created that should be identical on all pages.

Panel Pages: A: Detach Master Page Objects, B: Remove Master Page Objects, C: New Master Page, D: New Master
from Page, E: New Grid, F: New Grid from Page, G: Properties, H: Delete, I: Master Pages, J: Grid, K: Current Page, L:
Page list in Preview mode, M: Page Status Indicator, N: Snap panel, O: Keep Spreads Together, P: Slider for enlarging
and minimizing the page view in the pages panel, Q: Switching to preview, R: Switching to list view, S: Page list in Icon
mode, T: Spreads kept together, U: Page list in list mode
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Layers panel
All layers of a list are displayed in the Layers panel. Layers can be thought of as transparent sheets
which are perfectly aligned above each other. Objects placed on a layer cover objects located on
the layer below. The order of the layers in the list shows the order of the layers from top to bottom.
Layers affect all pages of a document.

Panel Layers: A: Show / Hide Layer, B: Lock / Unlock Layer, C: Layer Color, D: Layer Name, E: New Layer, F: Duplic-
ate Layer, G: Select All Objects on Layer, H: Merge Layers, I: Properties, J: Delete Empty Layers, K: Delete (selected
layer), L: Snap panel, M: Layer of the currently activated object, N: Paste Keeps Layers, O: Panel context menu
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Templates panel
The Templates panel shows the layout templates and document templates stored in the active lib-
rary.

Panel Templates: A: Show / Hide Details, B: Drop-down menu for the selection of created folders, C: Refresh, D: Con-
tent of the selected folder, E: Show / Hide Article Templates, F: Show / Hide Layout Templates, G: Show / Hide Docu-
ment Templates, H: Show / Hide Components, I: Change between list view and icon view, J: Snap panel, K: Save as
Layout Template / Document Template, L: Edit, M: Delete
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Colors panel
Use the Colors panel to create and name any colors, tints or gradients and edit existing colors.

The buttons at the top of the panel enable you to change the frame background, stroke, border, text
color and rule color of activated objects.

Panel Colors: A: Background, B: Stroke, C: Border, D: Text, E: Rule, F: New Color, G: New Tint, H: New Gradient, I:
Edit, J: Delete, K: List of all defined colors, tints and gradients, L: Snap panel, M: Display of a color in CMYK color
mode, N: Display of a color in HSB color mode, O: Display of a special color, loaded from a HKS library, P: Display of a
special color, loaded from a Pantone library, Q: Display of a color in RGB color mode, R: Display of a gradient, S: Tint,
T: Opacity, U: List view / icon view, V: Panel context menu
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Styles panel
The style sheets defined in a project and their paragraph and text styles can be selected in the doc-
ument from the Styles panel. Activated paragraphs and selected texts can be easily formatted us-
ing the listed paragraph and text styles.

Panel Styles: A: New Paragraph Style, B: New Text Style, C: Edit (active selection), D: Copy to Clipboard, E: Delete
(active selection), F: Popup menu style sheets, G: List of all defined paragraph styles of a style sheet, H: List of all
defined text styles of the selected paragraph style, I:  Snap panel, J: Panel context menu

Differences from the defined format within marked texts, which are caused by manual formatting,
are indicated in this panel and in the Text Inspector Styles by a plus sign (+) after the style name. If
you move the mouse pointer over the style marked in this way, the system displays the difference
from the style definition in the quick info text.
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The Styles panel with the quick info about the difference displayed

Select the text component that contains the manual formatting and, while holding down the <Alt>
key, click on the style name to remove any differences from the style definition. 
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Table styles panel
The table style sheets defined in a project and their cell styles can be selected in the document
from the Table styles panel. Via this panel you can change the style of one or several selected
cells, or change the style of an entire table by choosing a different table style sheet.

Panel Table Styles: A: New Cell Style, B: Edit, C: Copy to Clipboard, D: Delete, E: Popup menu table style sheets, F:
New Table Style Sheet, G: List of all cell styles, H: Snap panel, I: Table Styles context menu
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Glyphs panel
Use the Glyphs panel to insert all characters displayed in the glyphs table at the current position in
the text or copy them to the clipboard, including characters not directly available via the keyboard.

Panel Glyphs: A: Preferred Glyphs, B: Font, C: Selection of options to show (options depend on the selected font), D:
Table with all characters contained in a font, E: Snap panel, F: Font style, G: Zoom in or out of the glyphs table, H: Font
details, displays information about the selected font, I: Copies the entire character set of the selected font to the clip-
board. 
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Notes panel
Additional information, such as correction instructions on the text, can be inserted at the desired po-
sition in the text or on the page using notes.

Use the Notes panel to show existing notes and create new notes. The Notes panel contains the
Page and Text tabs.

The Page tab provides information on all (page) notes inserted in the currently opened document or
currently opened page section. The Text tab shows the text notes of the currently active chain.

Panel Notes, Tab Page: A: Active tab Page, B: Switch to the tab Text, C: New Page Note, D: Edit (selected note), E:
Delete (selected note), F: Next (next note), G: Previous (previous note), H: Show / Hide Page Notes, I: List of all inser-
ted page-related notes, J: Content of the active note, K: Snap panel

Panel Notes, Tab Text: A: Switch to the tab Page, B: Active tab Text, C: New Text Note, D: Convert Selection to Note,
E: Convert Selection to Note Instantly, F: Note to Text, G: Edit (selected note), H: Delete (selected note), I: Next (next
note), J: Previous (previous note), K: Show / Hide Text Notes, L: List of all notes inserted in the active text chain, M:
Content of the active note, N: Snap panel
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Align panel
Use the Align panel to horizontally or vertically align or distribute selected objects along the axis of
your choice.

When aligning objects, the respective outer object is the point of reference on the chosen axis,
whereas when distributing objects, the two outer objects serve as the point of reference.

Panel Align: A: Left: B: Right, C: Center Vertically, D: Center Horizontally, E: Bottom, F: Top, G: Drop-down menu for
horizontal alignment with frame / left edge / frame center / right edge, H: Button to activate the definition of a set offset
for horizontal or vertical distribution I: Activate / Deactivate Keep Link, J: Snap panel, K: Drop-down menu for vertical
alignment with frame / top edge / frame center / bottom edge

Linked Objects panel
This panel displays all images and graphics linked in the layout. You can reassign the images, for
example, to load a different version of the file, jump directly to the picture frame, change status, or
display the file in the file system.

The image information at the bottom can be hidden and you can switch between thumbnail view
and list view as well.

   

The Linked Objects panel, left with list view, right with thumbnail view. 

Click the button  to show or hide the file information; click the button  to switch between list
view and thumbnail view.
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Right-click on the name or thumbnail of the file to open the context menu.

Attach...: Opens the Select Image File dialog to reload the placed file or load an alternate file.

Show...: Triggers a jump in the layout to the frame that contains the file and centers it on the
screen.

Status: Allows you to change the status of the file.

Show in Explorer: Opens the folder containing the source file in the file system.
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Inspectors

The inspector windows contain the editing and settings options for the selected object.

Use the Windows > Inspectors > Show / Hide All option to show or hide the entire inspectors.
You can also place individual inspectors as floating windows in any position on the working window
by clicking on the name of the window and dragging it to the desired position while holding down
the mouse button.

For certain work processes, you can combine several inspectors in one panel to have faster access
to the required functions.
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Example of an individual combination

An individually defined panel for the process of adding image and text frames to a layout for corres-
ponding photo credits, formatting the photo credits and defining an offset for text could look like this:

Individually defined inspector panel

Drag additional inspectors to the floating inspector window (as described above). To assign the
panel a unique name, right-click on the title bar of the inspector that is highlighted in color and re-
name the panel.
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Use the Extras > Inspectors > Save Inspectors ... option to save the current state of the inspect-
ors and load them with the Extras > Inspectors > Load Inspectors ... option when needed.

The Extras > Inspectors > Reset Inspectors option returns the inspectors to their original state.

This subsection will provide an overview of the individual inspectors and their functions. Information
on the units you can use in the entry fields is provided in the Preferences chapter.

Hint: Hover the cursor over the icon in front of an entry field in MarkStein Publisher to show the
name of the icon.
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Text inspector

Styles

This inspector contains information and setting options for the style sheet and paragraph properties
of the text.

 Style Sheet ,  Paragraph Style,  Text Style,  Block,  Structure Level.

Style Sheet: Shows the current style sheet of the selected text. To edit it, click on the selection
menu and select a different style sheet.

Paragraph Style: Shows the current paragraph style of the selected text. To edit it, click on the se-
lection menu and select a different paragraph style.

Text Style: Shows the current text style of the selected text. To edit it, click on the selection menu
and select a different text style.

Block: Shows which block type the selected text belongs to. To edit it, click on the selection menu
and select a different block type.

Structure Level: Shows which structure level the selected text belongs to. To edit it, insert a value
or click on the arrows. A maximum of 100 structure levels are available.
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Text

This inspector contains information and setting options for the font.

 Font type and font style,  Color,  Tint,  Opacity,  Font Size,  Baseline Shift, 

 Kerning,  Tracking,  Horizontal Scale,  Vertical Scale,  Superscript,
Subscript, All Caps, Small Cap, Underline and Underline Words buttons.

Font: Select a font from the drop-down menu or enter the initial letters of your desired font until it is
identified.

Font style: Select the font style (e.g. Bold, Italic) from the drop-down menu. Only those font styles
will be displayed that have been installed with the selected font.

Color: Use the drop-down menu to select the font color.

Tint: Enter the tonality in % in the Tint entry field, or click on the arrows to increase or reduce the
current value. Permitted values range between 0.1% and 100%.

Opacity: Enter the opacity, i.e. the level of transparency of the font, in this entry field or click on the
arrows to increase or reduce the current value. Possible values range between 0.1% and 100%.

Font Size: Enter the font size in this entry field, or click on the arrows to increase or reduce the cur-
rent value. Font sizes can be entered in DTP point (pt), Didot point (P) or mm (mm).

Baseline Shift: The Baseline Shift option allows you to shift the baseline of the selected characters
above or below the general baseline of the text. Enter a positive value in the Baseline Shift entry
field to shift the selected characters above the current baseline of the text. Enter a negative value to
shift the selected characters below the current baseline of the text. Unlike superscript and sub-
script, a baseline shift does not minimize the text. The value must be between -9,999 and 9,999
mm.

Kerning: To use the kerning table of the selected font, select on. To disable the use of kerning, se-
lect off. Kerning means reducing the spacing between certain pairs of letters, such as WA, VA, To,
Ta, to decrease the blank space between the letters to prevent it from disrupting the typesetting and
readability. Each font has a kerning table in which the letter combinations for kerning are listed to
avoid requiring individual kerning of critical character combinations to be performed for a text.
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Tracking: Tracking defines the distance between the characters. In order to space the characters
manually, i.e. increase the space between them, enter a positive value in the Tracking entry field.
Enter a negative value to kern characters, i.e. reduce the distance between them. The 100% value
corresponds to a quad of the selected font size. If the kerning function is activated, manually
entered tracking changes are always entered in absolute terms to the values listed in the kerning
chart. The value must be between -1,000% and 1,000%.

Horizontal Scale: Enter the desired percentage to change the font width. Values larger than 100%
broaden the font horizontally, values lower than 100% decrease the font width, both without affect-
ing the font height. The value must be between 0.1% and 9,999%.

Vertical Scale: Enter the desired percentage to change the font height. Values larger than 100% in-
crease the font vertically, values lower than 100% decrease the font height, both without affecting
the font width. The value must be between 0.1% and 9,999%.

Attributes: Select the font attributes from the toolbar at the bottom. Selected attributes are high-
lighted in color.
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Paragraph

This inspector contains information and setting options for the paragraph.

 Left, Center, Right, Justified,  Leading,  First Line,  Space Before,  Space

After,  Indent Left / number of lines,  Indent First Line,  Indent Right / number of lines,  Align
to Baseline Grid, Do Not Align to Baseline Grid

Left: All lines of a paragraph are aligned with the left-hand margin or text indent.

Center: All lines of a paragraph are aligned with the center.

Right: All lines of a paragraph are aligned with the right-hand margin or text indent.

Justified: All lines of a paragraph are aligned with the right-hand and left-hand margin or text in-
dents. Only the last line of the paragraph is normally aligned with the left-hand margin or text indent.
Further options are available in the Break-Options tab in the Style > Paragraph menu.

Leading: Enter the line spacing. Leading is the space between the text lines and applies to all lines
of a paragraph.

First Line: This value determines the spacing of the first line of a paragraph, which diverges from
the leading.

Space Before: Enter the desired value to increase the space before the current paragraph. The
space between two paragraphs is the sum of the leading and the additionally entered values for
Space Before and Space After.

Space After: Enter the desired value to increase the space after the current paragraph. The space
between two paragraphs is the sum of the leading and the additionally entered values for Space
Before and Space After.

Indent Left: In the first entry field, enter the amount by which the left-side margin of a paragraph is
to be indented from the left-side margin of a column, text frame or text path. In the second entry
field, enter the number of lines to which the left-side indent shall be applied. If you do not enter a
value, the left-side indent is applied to all lines of a paragraph.

Indent First Line: The first line of a paragraph can be indented from the left-side margin or the left-
side indent separately from the other lines. Enter the value from the left indent to the beginning of
the first line of text. If a positive value is entered, the first line will start to the right of the left indent.
Enter a negative value to create a hanging indent, where the first line starts to the left of the left in-
dent.
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Indent Right: In the first entry field, enter the amount by which the right-side margin of a paragraph
is to be indented from the right-side margin of a column, text frame or text path. In the second entry
field, enter the number of lines to which the right-side indent shall be applied. If you do not enter a
value, the right-side indent is applied to all lines of a paragraph.

Baseline Grid: Activate one of these options to activate or deactivate the alignment of the text para-
graph with the baseline grid.

Drop Cap

This inspector contains information and setting options for a drop cap.

 Lines,  Characters,  Offset,  Font type and font style,  Color,  Tint,  Opacity,

 Horizontal Scale,  Vertical Scale

Drop Cap: A drop cap – or initial – is a letter at the beginning of a paragraph which is highlighted in
the text either by size and/or color.

Lines: Enter the number of lines across which the drop cap shall extend.

Characters: Enter the number of characters to be included in the drop cap.

Offset: Increase the spacing between the text and the drop cap via the value entered here.
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Rule

This inspector contains information and setting options for rules.

 Activation and selection menu Rule Above / Rule Below,  Style, 

 Weight,  Length,  Indent Left,  Indent Right,  Offset,  Color, Tint,  Opacity

Activation and selection menu: Here, you can select Rule Above and Rule Below and activate
the desired option(s) in the checkbox to the left.

Rule Above: With a rule at the top, the line weight always expands upwards from the baseline of
the first line.

Rule Below: With a rule at the bottom, the line weight always expands downwards from the
baseline of the last line.

Style: Select one of the defined line styles from the drop-down menu.

Weight: Enter the line weight of the rule.

Length: Here, you define whether the rule fills the entire space between the indents or adjusts to
the actual text length. Select the Indent option for the line to adjust to the indents.
Select the Text option for the line to adjust to the actual text length.

All lines: Activate this option if you want the line to be inserted at each line of the paragraph.

Indent Left: Enter a value in this field in order to create space between the rule and the left text
edge. Positive values move the starting point of the rule to the right, negative values move it to the
left. The indent is added to the text indent defined in Paragraph > Indent Left.

Indent Right: Enter a value in this field in order to create space between the rule and the right text
edge. Positive values move the end point of the rule from the right-side margin to the left, negative
values move it to the right. The indent is added to the text indent defined in Paragraph > Indent
Right.

Offset: Enter an offset of the rule based on the baseline of the first line (Rule Above) or last line
(Rule Below) of the paragraph. Positive values move the rule down from the baseline, negative val-
ues move it up from the baseline. With the default value of 0, the line is positioned directly on the
baseline of the first or last line of the paragraph.
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Bullets & Numbering

Use this inspector to define paragraphs as lists with bullet points or numbering and manage the
corresponding options.

 Activation and drop-down menu Numbered List,  Level,

 Activation and selection Glyphs for List,  Activation of Continue

numbering,  Activation of Restart at,  Start Value, 

 Drop-down menu text format for bulleted or numbered lists,  Indent Text,

 Indent Bullet,  Left//Right/Center alignment of bulleted or numbered lists.

Activation and drop-down menu Numbered List: Select the style in which the list should be
numbered and activate numbering by clicking on the icon. Possible options are Arabic numerals,
lower-case and upper-case Roman numerals and lower-case and upper-case alphabet.

Level: Here, you can define a new list level that can have different attributes. Select the desired
paragraphs and enter a value or click on the arrows. Possible options are Arabic numerals, lower-
case and upper-case Roman numerals and lower-case and upper-case alphabet.

Activation and selection Glyphs for List: To create a list with different list styles, select one or mul-
tiple list styles from the Glyphs menu and activate the list by clicking on the icon.

Activate Continue numbering: Activate this option if the numbering of paragraphs should be con-
tinued after paragraphs with regular text.

Activation of Restart at: This allows you to restart numbering within a list.

Start value: Enter the value with which the numbering should restart.

Text Style drop-down menu: Select the text style to format the numbered or bulleted list charac-
ters.

Indent Text: Enter the amount to which the text of the list should be indented from the left-side
margin.

Indent Bullet: Enter the amount to which the numbering or bullet of the list should be indented from
the left-side margin.
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Alignment of bulleted or numbered lists: Defines the alignment of the numbering or bullet of the
list. Left: within the text frame at the left frame edge, Right: outside the text frame at the left frame
edge, Center: centered on the left frame edge.

HTML

Use this inspector to control linking of your texts with HTML tags and CSS to export as EPUB or
HTML formats.

 Block Level Element,  CSS Class and Style,  Inline Element.

Block Level Element: Select the block element with which the exported text should be annotated.

CSS Class: Select the CSS class with which the exported text should be annotated.

CSS Style: Select the CSS style with which the exported text should be annotated.

Inline Element: Select the inline element with which the exported text should be annotated.

Detailed information on HTML and CSS is available in the Initial steps > Printing and exporting >
Output as e-book > General introduction > HTML basics section of this manual.

Conditional Text

This inspector allows you to assign text conditions to texts independently of their formatting. To do
this, select the paragraph to which you want to assign a text condition and select one or more text
conditions. If you select [Unconditional], all previously activated text usages are deactivated.
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Layout inspector

Object Properties

This inspector contains information and setting options for the currently selected object.

 Source,  Position X,  Position Y,  Angle,  Width,  Height,  Options

for scaling content,  Options for selection of the frame type,  Color,  Tint,

 Opacity,  Gradient,  Block,  Justification

Source: This defines the point of the object from which the coordinates are calculated, which point
serves as the rotation axis when rotating an object and from which point a change in size begins.
The upper left point is the source by default; to select a different point, click on the point you wish to
define as the source.

Position X: Shows the horizontal position of the object source point on the page. To edit it, insert a
value or click on the arrows.

Position Y: Shows the vertical position of the object source point on the page. To edit it, insert a
value or click on the arrows.

Angle: Rotating the object on the source point. To edit it, insert a value or click on the arrows. En-
tering positive values or clicking the upward arrow rotate the object counterclockwise.

Width: Shows the current width of the object. To edit it, insert a value or click on the arrows.

Height: Shows the current height of the object. To edit it, insert a value or click on the arrows.

Scale Content: If this option is enabled, the image or text content is scaled proportionally when the
frame size is changed via the input fields.
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Content: This indicates the frame type of the selected object. Click the button to activate or deac-
tivate the options and change the frame type.

Gradient: Define a gradient to fill the object. To do so, click on the Gradient text and set the de-
sired options in the dialog window that opens.

Block: Shows the block type of the selected frame and provides the option to change it via the drop-
down menu.

Justification: This defines how the text should be aligned in a frame that is only partially filled.

Top aligns the text with the top edge of the frame.

Distribute Paragraphs With Vertical Justification distributes the available space evenly between
paragraphs to which a vertical justification was assigned in the paragraph properties or in Menu >
Style.

Distribute all Paragraphs distributes the available space evenly between all paragraphs.

Distribute all Lines distributes the available space evenly between all lines.

Center distributes the available space evenly above and below the text.

Bottom aligns the text with the bottom edge of the frame.

Please note: These settings only take effect for text that is not aligned with the baseline grid; text
aligned with the baseline grid is always aligned to the top!
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Image

This inspector contains information and setting options for placed images.

 Source,  Horizontal Scale,  Vertical Scale,  X Offset,  Y Offset,  Angle,  Opacity,

 Flip Vertically,  Flip Horizontally, Color,  Tint.

Horizontal Scale: Shows the horizontal scaling of the placed image in relation to the original file.
To edit it, insert a value or click on the arrows.

Vertical Scale: Shows the vertical scaling of the placed image in relation to the original file. To edit
it, insert a value or click on the arrows.

X Offset: Shows the value of the horizontal offset of the image within the frame. To edit it, insert a
value or click on the arrows.

Y Offset: Shows the value of the vertical offset of the image within the frame. To edit it, insert a
value or click on the arrows.

Angle: Rotation of the image within the frame. To edit it, insert a value or click on the arrows. En-
tering positive values or clicking the upward arrow rotate the object counterclockwise.

Opacity: Shows the current opacity of the selected image. To edit it, insert a value or click on the
arrows.

Flip Vertically: Activating the button flips the image along the vertical axis.

Flip Horizontally: Activating the button flips the image along the horizontal axis.

Color: Select a color via this menu to color a placed image.

Tint: Use this function to define the tint of a colored image. To edit it, insert a value or click on the
arrows.
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Text Frame

This inspector contains information and setting options for text frames.

 First Baseline,  Minimum / Fixed,  Baseline Grid,  Inset Left,  Inset Right,  Inset Top,

 Inset Bottom,  Make all Settings the Same,  Number of Columns,  Gutter, 
 Fixed.

First Baseline: You can use this selection to define where the first text line is positioned in relation
to the upper edge of the frame. 

Leading: Positions the baseline of the first line to the defined leading.

Ascender: The ascender of the first line of text is positioned at the upper edge of the frame. 

Cap Height: The cap height of the first line of text is positioned at the upper edge of the frame.

Accented Char Height: The position of the first baseline complies with the height of uppercase letters
with accents, and at least complies with the cap height.

Lowercase Height: Positions the first line of text in a way that the upper edge of lowercase letters hits
the upper edge of the frame.

Text Height: The position of the first baseline complies with the height of uppercase letters, and at
least complies with the cap height.

Fixed Value: Defines that the baseline of the first line of text is located at a fixed position. This position
is defined in the Minimum / Fixed field.

Minimum / Fixed: From the First Baseline drop-down menu, select the option Fixed Value, then
enter the value at which the baseline of the first line of text should be positioned to the upper edge
of the frame.

Baseline Grid: Enter the increment of the baseline grid for the frame here or click on the arrows.

Inset Left: The distance of the text to the left edge of the frame. To edit it, insert a value or click on
the arrows.

Inset Right: The distance of the text to the right edge of the frame. To edit it, insert a value or click
on the arrows.

Inset Top: The distance of the text to the top edge of the frame. To edit it, insert a value or click on
the arrows.
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Inset Bottom: The distance of the text to the bottom edge of the frame. To edit it, insert a value or
click on the arrows.

Make all Settings the Same: All insets are automatically set to the same value when this option is
activated. Deactivate this function to set varying insets.

Number of Columns: Number of columns within the text frame. To edit it, insert a value or click on
the arrows.

Gutter: Distance between the columns within the frame. To edit it, insert a value or click on the ar-
rows.

Fixed: Shows the current column width depending on the frame width, number of columns and gut-
ter. Changing one parameter causes the other parameters to be recalculated. If the Fixed button is
activated, the column width is fixed. Columns are added or removed when changes are made to the
column width, the gutter initially stays the same, but can be changed. To enter a fixed column width,
click on the lock icon next to the entry field and enter a value or click on the arrows.

Text Wrap

This inspector contains information and setting options for how text should wrap around objects.

 None,  Bounding Box,  Object Shape,  Ignore (option),  Offset Left,  Offset

Right,  Offset Top,  Offset Bottom,  Make all Settings the Same,

 Type.

None: The text does not wrap around the object; it flows over or under the object.

Bounding Box: The text is wrapped along the object frame.

Object Shape: This option can be used to define whether the text should wrap around the object
frame or the object within the frame.

Ignore (option): Activate this option to exclude a text frame from the wrapping, e.g. to insert a
photo credit in an image around which text is wrapped.

Offset Left: The distance of the text to the defined left edge. To edit it, insert a value or click on the
arrows.

Offset Right: The distance of the text to the defined right edge. To edit it, insert a value or click on
the arrows.

Offset Top: The distance of the text to the defined top edge. To edit it, insert a value or click on the
arrows.
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Offset Bottom: The distance of the text to the defined bottom edge. To edit it, insert a value or click
on the arrows.

Make all Settings the Same: All offsets are automatically set to the same value when this option is
activated. Deactivate this function to set varying insets.

Type: Use this drop-down menu to define the section of the object that the text should wrap around.
Selecting the Frame option causes the text to wrap around the object frame. The Image Frames
option lets texts wrap around the image and its frame. Selecting the option Non-white areas cre-
ates a virtual wrapping path which ignores white areas and causes the text to wrap around the ac-
tual image content. If the image contains a clipping path or an alpha mask, select the respective
option for the text to wrap around this path or the edge of the mask.

Another option is the Create Path function, which is explained in the Working with Paths > Fur-
ther path operations section.
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Margin

This inspector contains information and setting options for a margin within a frame. In image
frames, the placed image is moved by the entered value from the left and from the top, and cut by
the same value to the right and at the bottom. Text contained in the frame is not moved.

 Left,  Right,  Top,  Bottom,  Make all Settings the Same,  Color,  Tint, 
 Opacity.

Left: Left margin. To edit it, insert a value or click on the arrows.

Right: Right margin. To edit it, insert a value or click on the arrows.

Top: Top margin. To edit it, insert a value or click on the arrows.

Bottom: Bottom margin. To edit it, insert a value or click on the arrows.

Color: Use the drop-down menu to select the margin color.

Tint: Enter the tonality in % in the Tint entry field, or click on the arrows to increase or reduce the
current value. Permitted values range between 0.1% and 100%.

Opacity: Enter the opacity, i.e. the level of transparency of the margin, in this entry field or click on
the arrows to increase or reduce the current value. Possible values range between 0.1% and 100%.
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Stroke

This inspector contains information and setting options for frame contours and lines.

Left image: the inspector when a frame is selected.  Weight,  Style,  Position,  Color, 

Tint, Opacity,  Line caps (inactive for frames with solid line),  Join,  Miter limit, 
Feather.

Right image: the inspector when a line is selected. Added are  Start,  End. The options feather and join are
omitted. 

Weight: Enter the line weight or click on the arrows.

Style: Select one of the defined line styles from the drop-down list.

Position: 

Frame: Use this option to define how the contour is positioned on the object frame. If you select the
Align to Center option, half of the entered contour weight is positioned inside the frame, the other half
outside. If you select the Align to Outside option, the contour is positioned outside the frame. Selecting
Align to Inside positions the contour inside the frame.

Line: For a line, the thickness is built up from its position displayed in the Layout panel and in the In-
spector Object Properties, depending on the option selected.

Miter limit: With the value in the input field, you determine the point at which the program switches
from a pointed to a flattened corner. The default value entered is 2, i.e. the program switches from a
pointed corner to a flattened corner if the length of the tip is twice as long as the line weight. A miter
of 1 always forms a flattened corner.

Feather: This option allows you to give the contour a soft edge, running outwards, that changes
from the frame color to transparent. To change it, enter a value or click the arrows. This option is
not available for single lines or unclosed paths.

Caps: Allows you to specify the line ends, available options are Butt Cap, Projecting cap and
Round cap. For frames or closed Bézier shapes with solid lines, the function has no effect and is
therefore inactive. For dotted or dashed lines, the function is activated and you can assign the de-
sired caps to the resulting line ends. 
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Start of line/End of line: Here you can assign an arrowhead, an arrow end or a circle to a line at
the start and/or end.

Corners

This inspector contains information and setting options for the corners of a frame.

Corner radii:  Corner Radius Top Left,  Corner Radius Bottom Left,  Corner Radius Top Right, 

Corner Radius Bottom Right,  Make all Settings the Same. Corner styles:  rounded outwards,  rounded

inwards,  slanting.

Edge radius: Dimensions of the effect, calculated from the selected frame edge. To edit it, insert a
value or click on the arrows.

Corner style: Select the effect for the respective corner here.

Make all Settings the Same: All entry fields are automatically set to the same value when this op-
tion is activated. Deactivate this function to set varying dimensions or effects.
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Shadow

This inspector controls how objects and texts cast shadows.

Icon for object shadow,  Color,  Blurred edges,  Tint,  Opacity,  Width +/-,  Height

+/-,  Offset,  Angle,  Icon for text shadow.

Color: Drop-down menu for the color of the shadow, to remove the shadow select None.

Blurred edge: The width of the gradient from the defined color to the transparency. The higher the
value is selected, the greater the blur.

Width +/-: Use this option to define by how much the shadow should be wider or narrower than the
object throwing the shadow. Positive values enlarge the shadow, negative values make it smaller.
To edit it, insert a value or click on the arrows.

Height +/-: Use this option to define by how much the shadow should be longer or shorter than the
object throwing the shadow. Positive values enlarge the shadow, negative values make it smaller.
To edit it, insert a value or click on the arrows.

Offset: Use this option to define by how much the shadow should be offset from the object casting
the shadow. To edit it, insert a value or click on the arrows.

Angle: The angle at which the simulated light hits the object. To edit it, insert a value or click on the
arrows. Alternatively, you can click on the dial and drag the point to the desired position. The point
indicates the position of the shadow.

Object knocks out shadow: Here you define whether or not the object casting the shadow should
be knocked out of the shadow. 
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Table inspector

Rules

This inspector contains information and setting options for rules for table margins.

 Margin Rule Top,  Margin Rule Left,  Stroke,  Style,  Weight,  Color,  Tint, 

 Opacity,  In Front,  Position.

Margin Rule Top: This defines a line that is placed at the upper edge of the table spanning its en-
tire width. The rule weight falls inside the table.

Margin Rule Left: This defines a line that is placed at the left edge of the table spanning its entire
height. The rule weight falls inside the table.

Stroke: Here you define a line frame that encloses the entire table. Use the Position buttons to
define how the stroke is positioned.

In Front: If you have defined overlapping lines with different colors, tints or opacities, you can
choose which overlapping line is at the top by activating one of these buttons.
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Stroke/Background

This inspector contains information and setting options for the backgrounds and strokes of cells,
rows and columns.

 Color,  Tint,  Opacity,  Gradient,  Margin Left,  Margin Right,  Margin Top, 

Margin Bottom,  Make all Settings the Same,  Style,  Weight,  Hide Row Strokes,  Hide

Column Strokes,  Hide First Row Stroke,  Hide First Column Stroke,

Margin Left: This function adds an outline to the left edge of the selected part of the table. The rule
weight falls inside the table, text is not moved.

Margin Right: This function adds an outline to the right edge of the selected part of the table. The
rule weight falls inside the table, text is not moved.

Margin Top: This function adds an outline to the top edge of the selected part of the table. The rule
weight falls inside the table, text is not moved.

Margin Bottom: This function adds an outline to the bottom edge of the selected part of the table.
The rule weight falls inside the table, text is not moved.

Make all Settings the Same: All margins are automatically set to the same value when this option
is activated. Deactivate this function to set varying margins.

Hide Row Rules: This function interrupts or completely hides a row rule defined in the Table In-
spector - Rows in the selected parts of the table.

Hide Column Rules: This function interrupts or completely hides a column rule defined in the
Table Inspector - Columns in the selected parts of the table.
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Hide First Row Rule: This function interrupts or completely hides a Margin Rule Top defined in
the Table Inspector - Rules in the selected parts of the table.

Hide First Column Rule: This function interrupts or completely hides a Margin Rule Left defined
in the Table Inspector - Rules in the selected parts of the table.

Cell

This inspector contains information and setting options for text within the cells of a table.

 Inset Left,  Inset Right,  Inset Top,  Inset Bottom,  Make all Settings the Same,  Ver-

tical Justification,  Horizontal Alignment,  Entry field for decimal

character and its position,  Angle,  Horizontal,  Vertical,  Columns,  Gutter:

Inset Left: The distance of the text to the left edge of the cell. To edit it, insert a value or click on
the arrows.

Inset Right: The distance of the text to the right edge of the cell. To edit it, insert a value or click on
the arrows.

Inset Top: The distance of the text to the top edge of the cell. To edit it, insert a value or click on
the arrows.

Inset Bottom: The distance of the text to the bottom edge of the cell. To edit it, insert a value or
click on the arrows.

Make all Settings the Same: All insets are automatically set to the same value when this option is
activated. Deactivate this function to set varying insets.

Vertical Justification: This defines how the text should be aligned vertically within the cell.

Top: aligns the text with the top edge of the cell.

Justify Paragraphs with vertical Alignment: distributes the available space evenly between para-
graphs to which a vertical justification was assigned in the Paragraph Properties in the Menu > Style.

Block Paragraphs: distributes the available space evenly between all paragraphs. 

Block Lines: distributes the available space evenly between all lines.

Center: distributes the available space evenly above and below the text.



Interface   InspectorsMarkStein Publisher Manual

© 2022 MarkStein Software GmbH 123

Bottom: aligns the text with the bottom edge of the cell.

Horizontal Alignment: This defines how text and numbers should be aligned horizontally within the
cell.

[None]: The alignment follows the properties of the assigned paragraphs style.

Decimal: Aligns numbers with decimals on decimal characters defined in the Align on: entry field. The
numbers are initially left-aligned. The alignment only takes effect once a value has been entered in the
Pos.: entry field that is larger than the largest width of the characters in front of the decimal character.

Left: Aligns text or numbers with the left edge of the cell. A left indent defined in the Paragraph Proper-
ties is ignored.

Center: Aligns text or numbers centrally. Indents defined in the Paragraph Properties are ignored.

Right: Aligns text or numbers with the right edge of the cell. A right indent defined in the Paragraph
Properties is ignored.

Decimal Center: Centrally aligns the decimal character assigned in the Align on: entry field.

Decimal Right: Aligns numbers with decimals to the right on decimal characters defined in the Align
on: entry field. The numbers are initially aligned to the right, and the alignment only takes effect once a
value has been entered in the Pos.: entry field that is larger than the largest width of the characters be-
hind the decimal character.

Entry field for decimal character and its position: Enter the decimal character used for the table
data here to define it as the basis for alignment. Entering a value in the Pos.: entry field places the
character in the entered position in the cell.

Angle: Enter an angle by which the cell should be rotated.

Horizontal: The button is activated by default and aligns the cell horizontally.

Vertical: Activating this button rotates the cell.

Columns: Defines the number of text columns within the cell. To edit it, insert a value or click on
the arrows.

Gutter: Defines the distance between the text columns. To edit it, insert a value or click on the ar-
rows.
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Rows

This inspector contains information and setting options for rows in a table.

 Position Y,  Locked Height,  Height,  Fit Height To Text,  Style, 

 Weight,  Color,  Tint,  Opacity,  In Front.

Position Y: Shows the current Y position of the marked row within a table. The upper edge of the first row

of the table acts as the point of reference. Changes made by entering values or clicking on the arrows
move the row up or down. The value of the changed position is added to or subtracted from the row
above.

Locked Height: Activating this function locks the height of the row, which means editing it with the
Table tool and the Fit Height To Text: function is no longer possible. Changes can still be made in
the Height: entry field.

Height: Shows the current value of the row height. To edit it, insert a value or click on the arrows.

Fit Height To Text: Activating this option causes the row height to adjust automatically when text is
added or removed.

Style: Select one of the defined line styles from the drop-down menu.

Weight: Insert the line weight of the row rule or click on the arrows. The rule extends from the cen-
ter of the bottom edge of a row and does not displace text.

Color: Use the drop-down menu to select the rule color.

Tint: Enter the tonality in % in this entry field, or click on the arrows to increase or reduce the cur-
rent value. Permitted values range between 0.1% and 100%.

Opacity: Enter the opacity, i.e. the level of transparency of the rule, in this entry field or click on the
arrows to increase or reduce the current value. Possible values range between 0.1% and 100%.

In Front: If you have defined overlapping lines with a different color, tint or opacity, you can choose
which overlapping row rule is at the top by activating one of these buttons.
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Columns

 Position X,  Fixed Width,  Width,  Style,  Weight,  Color,  Tint,  Opacity,

 In Front.

Position X: Shows the current X position of the marked row within a table. The left edge of the first
column of the table acts as the point of reference. Changes made by entering values or clicking on
the arrows move the column to the left or right. The value of the changed position is added to or
subtracted from the column to the left, columns to the right are moved to the left or right by the
value of the change.

Fixed Width: Activating this function locks the width of the column, which means editing it with the
Table tool function is no longer possible. Changes can still be made in the Width entry field.

Width: Shows the current value of the column width. To edit it, insert a value or click on the arrows.
Columns to the right are moved to the left or right by the value of the change.

Style: Select one of the defined line styles from the drop-down menu.

Weight: Insert the line weight of the column rule or click on the arrows. The rule extends from the
center of the right edge of a column and does not displace text.

Color: Use the drop-down menu to select the rule color.

Tint: Enter the tonality in % in this entry field, or click on the arrows to increase or reduce the cur-
rent value. Permitted values range between 0.1% and 100%.

Opacity: Enter the opacity, i.e. the level of transparency of the rule, in this entry field or click on the
arrows to increase or reduce the current value. Possible values range between 0.1% and 100%.

In Front: If you have defined overlapping lines with a different color, tint or opacity, you can choose
which overlapping column rule is at the top by activating one of these buttons.
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Working methods
On the next few pages, you will find information on working with the DTP program MarkStein Pub-
lisher.
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Recommended folder structure

If this is your first time using a layout program to create a project, this section provides some useful
hints that will help make working on a project easier for you.

Creating folder structures

Creating a folder structure to save the documents of your project in your computer’s file system and
using it consistently makes working with MarkStein Publisher easier.

Example of a folder structure for your project:

Example of a possible folder structure

Creating a backup of your files

If your computer has no automatic backup function, we recommend creating manual backups of
your files at regular intervals.

The consistent use of fixed structures for projects also pays dividends here. You only need to copy
the folder that contains all files related to the project to your backup media.
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Creating new documents

On the next pages, you will find information on how to create new documents in MarkStein Pub-
lisher.
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Creating a new document
1. In order to create a new document, click on the New button on the home screen to switch to the

window of the same name.

2. Double-click the New Document icon.

3. The New Document window opens, which has three tabs: Document, Page Size and Grid.

Double-clicking the New Document button opens the New Document window.

In the Document tab, general settings such as the library, document template, number of pages,
type of pages and master pages to be used can be selected.

The paper size, orientation and bleed can be defined in the Page Size tab.

In the Grid tab, the number of columns, the gutter, the line grid and the page margins can be
defined.

Once you have confirmed the settings made in the New Document window by clicking on [OK], the
new document is displayed in the working window.
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The new document is displayed in the working window.
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Structure of a document page

A: Printer spread, B: Page C: Bleed, D: Grid, E: Line Grid, F: Gutter, G: Margin

Document tab
In the Document tab, all general settings such as the library, document template, number of pages,
type of pages and master pages to be used can be selected.
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Tab Document of the window New Document

Library: In addition to frequently used layout templates, colors, images, etc., document templates,
master pages and grid definitions can be saved in a library and then directly selected when creating
a document. If you have already created one or multiple libraries, you can transfer the contents of
one of these libraries into the document you are creating by selecting it from the drop-down menu.

Document Template: In MarkStein Publisher it is possible to save one or several pages of a docu-
ment as a document template and store them in a library. In addition to all objects created on the
pages, a document template also contains information on the style, grid, number of pages and mas-
ter page. Therefore, selecting a document template disables the option of making further entries in
the Document tab.

Pages: Enter the number of pages you wish to set up when creating a document. Pages can be ad-
ded or removed from already existing documents at any time.

Facing Pages: Activate this option if you want to create documents in which the left and right pages
have different margins and face each other, as in magazines, brochures and books. Deactivate this
option if you want to create pages as individual pages such as for ads, leaflets, etc.

First Page Left: By default, the first page of the document is created as a right-hand page. Activate
this option if you want to begin the document with a left-hand page.

Master: In MarkStein Publisher, you can save master pages that contain the page size and grid
definition in a library. From the Master drop-down menu, you can select a saved master page from
a library or choose a default master page.
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Page size tab
The paper size, page orientation and bleed area can be defined in the Page Size tab.

Tab Page Size of the window New Document

Paper Size: The paper size defines the size of the final size, i.e. the trim size. Use the drop-down
menu to select a predefined page size. To define a user-specific paper format, enter the page size
in the entry fields Width and Height. This causes the option User Defined to appear in the Paper
Size drop-down menu.

Width: When selecting a default paper size, the page width is automatically entered in the Width
entry field.If you need a user-defined paper size, enter the required document width in the entry
field.

Height: When selecting a default paper size, the page height is automatically entered in the Height
entry field.If you need a user-defined paper size, enter the required document height in the entry
field.

Page orientation: To define the orientation of the document, activate either the Portrait or Land-
scape option.The values in the Width and Height fields are adjusted accordingly.

Bleed: The bleed area serves for the alignment of objects that are created to bleed off the page, i.e.
protrude from the page. The bleed prevents white margins from appearing on the pages during fur-
ther editing when misalignments happen once the pages are cut to their final size. For facing
pages, enter the values of the bleed in the Top, Bottom, Inside and Outside entry fields or in the
Top, Bottom, right and left entry fields for individual pages.
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Grid Width/Height: The current grid width and height are displayed in the bottom part of the dialog
window.

Grid tab
The number of columns, gutter, line grid and page margins can be defined in the Grid tab.

If a saved grid was already selected in the Document tab, its values are automatically adopted in
this tab but can be changed if necessary.

The margin and column reference lines, as well as the line grid, are automatically created using the
entries from this window. The entries also define the default master page of the document that is
automatically used for all pages to ensure a uniform appearance.

Tab Grid of the window New Document

Name: If a library containing various grids was selected in the Document tab, you can choose one
of the saved grids from the Name drop-down menu.

Columns: Enter the number of columns. The value needs to be between 1 and 99.

Gutter: Enter the distance between the columns here.

Width: The width of the individual columns is calculated based on the number of columns and the
defined gutter, with the result displayed here. After defining the page margins, you receive the width
of the individual columns in relation to the defined grid.
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Line Grid: The line grid provides assistance when creating frames. The increment of the line grid
is usually set to the height of the leading of the basic text. The number of lines shown to the right is
based on the entered value and the top and bottom page margins.

Lines: Instead of defining a line grid, you can also enter the number of lines. The line grid is then
automatically entered in the Line Grid entry field based on the entered value and the top and bottom
page margins.

Start: Enter the starting point of the first line of the baseline grid in the Start entry field in relation to
the starting point selected from the Relative To: drop-down menu.

Relative To:

Margin Top: The first line of basic text or the first baseline grid is placed in the position entered in the
Start entry field, relative to the margin top of the page which was defined in the Margin Top entry field.

Top of Page: The first line of basic text or the first baseline grid is placed relative to the top edge of the
page. In this case, the value entered in the Margin Top entry field is disregarded.

Use as Baseline Grid: Select this option if you want the line grid to be automatically used as the
baseline grid.

Margin: Enter the page margins in the Top, Bottom, Inside and Outside entry fields for facing
pages or the Top, Bottom, Right and Left entry fields for individual pages. Entering the margins
defines the grid.

Grid Width/Height: Shows the current width and height of the defined grid.

Page Width/Height: Shows the current width and height of the defined paper size.
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Options for documents

Properties

Select the command File > Document > Properties to display this dialog window.

Document > Properties window

Name: Shows the file name, which cannot be changed here.

Status: Shows the document status, which you can change here.

First Page: Define the starting value of the pagination here. A setting defined here applies to the
entire document as long as you do not make any deviating settings in the File > Document > Pa-
gination tab.

This window contains three additional tabs in which you can enter information.

Description: Enter a description of the document content here.

Keywords: Enter keywords here which can be used to categorize the content.

Dublin Core: Enter the title, author, language and publishing house here.

This information is automatically included in the description of the file when exporting the docu-
ment, for example when exporting the document as an EPUB.
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Pagination

Select the command File > Document > Pagination to display this dialog window. You can change
the pagination within the document here.
You can create different versions and save them in the document by clicking the Add button. An ad-
ded rule applies from the document page entered in the From Page: entry field to the end of the
document as long as no other rule was defined.

Document > Pagination window

From Page: Shows the current page number from which the pagination will be changed.

Start Value: Enter the new page number with which the page and the subsequent pages should be
numbered.

Type: Select a type of numbering from the drop-down menu. Possible options are Arabic, Roman
Numerals Upper Case, Roman Numerals Lower Case, Upper Case Letters and Lower Case
Letters.

Prefix: Enter a text in the entry field if text should be inserted before the numbering.

Suffix: Enter the text in this entry field if it should be inserted after the numbering.

For the pages to be automatically numbered when printing, you need to add numbering on the
pages. To do this, create a text frame at the desired position on the document pages or the master
page and add the placeholder for the page number via the Insert > Text Variable > Page Number
menu item. The pagination begins with the start value defined for the first page in the document
properties.
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Conditional Text

Select the command File > Document > Conditional Text to display the following dialog window: 

Document > Define Conditional Text window

Use a usage-related text output to create multiple versions of a text in a story, for example using
separate headings in online and in printed publications. The assignment is done per paragraph.

Stories which contain different areas of conditional text (for example “print” and “e-book”) are called
hybrid texts. Usage-dependent text areas are marked via the paragraph properties in MarkStein
Publisher.

20 predefined conditional text usages are possible in MarkStein Publisher that are listed as “Condi-
tional Text 1” to “Conditional Text 20”.The assignment of conditional text usage applies for the re-
spective current document. For example, if “Conditional Text 1” is specified for the document, only
text sections marked with “Unconditional” (= default, without explicit marking) or “Conditional Text
1” are taken into consideration.

The Text Condition inspector lets you assign text usages to texts regardless of the paragraph
format.
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Multi-page document
Enter your desired number of pages in the Document tab in the Pages entry field when creating the
document.
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User-defined page sizes
In order to create a document in a paper size not included in the drop-down menu, enter the desired
values in the entry fields Width and Height in the Page Size tab of the New Document dialog win-
dow. This causes the option User Defined to appear in the Paper Size drop-down menu.

Window New Document > Page Size with user-defined page size
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How do I create a letterhead?
For letters sent in a window envelope, the sender’s address and the address box need to have spe-
cific dimensions.

A template in which these text frames are already in the correct position can be found under Home
screen/New. Overwrite the text while retaining the positions and dimensions of the text frames. You
can freely design all other elements of the letterhead.

Save your private or business letterheads under a new name under ...\AppData\Roam-
ing\MarkStein\Templates in order to have them available as templates in the future.
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How do I create a 6-page flyer?
To simplify the creation of printed materials for you, we have included several templates in the
MarkStein Publisher package, including a template for a 6-page flyer with letter fold.

Create a new document from the Faltblatt DIN A4 Wickelfalz.mxd template as described in the
Creating a new document from a template section.

The flyer is based on a paper size of DIN A4 landscape and consists of two printer spreads with
three pages each, where one of the three pages has been made 3 mm smaller to simplify folding
during further processing.

Spread 1

The first spread with the left page minimized by 3 mm.
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Spread 2

The second spread with the right page minimized by 3 mm.

You can use the text and graphic elements, as well as the paragraph and text styles in this template
and change them as desired.

If you would prefer to start with an empty page and develop your own layout, you can remove all
page content and background colors at once by using the menu option Page > Content > Re-
move....

Define the range of pages from which you wish to remove all content via the entry fields.
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Different page sizes in the document
If you wish to change the size of an existing page, go to that page and select the command Page
Size... from the Page menu or right-click on the page background and select the command from the
context menu. Enter the values you want in the entry fields and confirm them with OK.

Automatically placed master page objects are removed when changing the page size. If you wish to
preserve them, activate the checkbox Detach all Master Page Objects. This preserves all placed
master page objects and allows them to be adjusted to the new page size.

Dialog Page Size
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Creating a new master page

If you need this differing page size multiple times in the document, it is advisable to create a new
master page. 
Proceed as follows:

Open the Pages panel and click on the button New Master Page

Assign a name and prefix for the new master page and enter the desired values in the entry fields.

Dialog Create New Master

Confirm your entries by clicking [OK]. Then the new master page is displayed in the overview.
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Pages panel with added master page "Foldout”.

Drag and drop the page from the overview to the document section of the Pages panel or select the
command Page > Insert. Enter the number of pages, position in the document and the master
page and confirm them with [OK].

Dialog Insert Pages
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Pages panel with added page “Foldout”
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Working with images

MarkStein Publisher provides the means to place images and graphics created in other programs,
edit them and export them in different formats.

Image formats

You can import and place the following image formats:

.bmp (Windows bitmap)

.eps (Encapsulated Postscript)

.gif (Graphics Interchange Format)

.jpg/.jpeg (Joint Photographic Experts Group)

.png (Portable Network Graphics)

.psd (Adobe Photoshop)

.tiff/.tif (Tagged Image File Format)

MarkStein Publisher Professional Edition and MarkStein Publisher Workgroup Edition support the
following additional formats:

.ai (Adobe Illustrator)

.pdf (Portable Document Format)

You can export the following image formats:

.eps (Encapsulated Postscript)

.gif (Graphics Interchange Format)

.jpg/.jpeg (Joint Photographic Experts Group)

.png (Portable Network Graphics)

.svg (Scalable Vector Graphics)

.tiff/.tif (Tagged Image File Format)

Place/Assign

Placing without first creating an image frame

From the File menu, select Place... and choose the image file to be placed from your file system.
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File system with selected image file

Click [Open].

The cursor now shows a small preview of the selected image. Click on the position in your docu-
ment at which the left upper edge should be placed.

MarkStein Publisher automatically creates an image frame and positions the image with a resolu-
tion of 96 dpi, regardless of its actual resolution. You can achieve the same result by dragging and
dropping the image from your file system to the document page.

Placing after creating an image frame

There are two possible ways to do this:

1. Follow the instructions above and click into the already created frame with the cursor displaying
the image. The image is then placed in the selected image frame according to the settings
defined in Preferences > Image Frame / Image.

2. Select the already created image frame using the selection tool and choose Content > Image >
Assign...; alternatively, right-click on the image frame and select the command Image >
Assign.

With both methods, the image is placed in the selected image frame according to the settings
defined in Preferences > Image Frame / Image.

Adjust Size

The following commands are available to adjust the size of the image to a specific resolution from
the Content > Image > Adjust Size menu or the Image > Adjust Size context menu:

Adjust Size menu
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Default: The image size is scaled proportionally to the value selected in the Preferences > Image
Frame / Image dialog.

300 dpi-72 dpi: The image size is proportionally scaled to the selected value.

Align

The following commands are available from the Content > Image > Align menu or the Image >
Align context menu to align the image to the frame:

Align menu

Center: Positions the image content on the center of the image frame, both horizontally and vertic-
ally.

Left: Positions the left edge of the assigned image on the left edge of the image frame without
changing the vertical alignment.

Right: Positions the right edge of the assigned image on the right edge of the image frame without
changing the vertical alignment.

Top: Positions the top edge of the assigned image on the top edge of the image frame without
changing the horizontal alignment of the image.

Bottom: Positions the bottom edge of the assigned image on the bottom edge of the image frame
without changing the horizontal alignment of the image content.

Fit

The following commands are available from the Content > Image > Fit menu or the Image > Fit
context menu to fit the image into the assigned frame:

Fit menu

Proportionally: If the frame is larger or smaller than the assigned image, select the command Pro-
portionally to proportionally fit the image into the frame. This fills the entire frame, parts of the im-
age extending outside the frame are hidden.

Non-Proportionally: If the frame is larger or smaller than the assigned image, select the command
Non-Proportionally to fit the image into the frame without preserving proportions. This fills the en-
tire frame and the image is distorted.
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Horizontally: Proportionally adjusts the image to the width of the image frame. The image height is
adjusted by the same scaling ratio that was used to change the image width.

Vertically: Proportionally adjusts the image to the height of the image frame. The image width is
adjusted by the same scaling ratio that was used to change the image height.

Fit Frame to Image: Adjusts the frame to the current size of the image.

Further information and editing options for positioned images are available in the Layout > Image
inspector.

Working with the content tool

Use the Image content tool to move the image content inside the frame or adjust the size of the
image.

Move

Click on the image with the tool. A frame showing the content size appears. Holding down the
mouse button causes areas of the image outside the image frame to appear with a lower opacity so
you can choose the image section by moving the image.

Image content activated with the image content tool while holding down the mouse button.
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Change Size

Click on the image with the tool. A frame showing the content size appears. Click on the edges or
corners of the displayed image content and enlarge or minimize the content by dragging while hold-
ing down the mouse button.

If you have activated Keep Aspect Ratio When Changing Size under Preferences > Image
Frame / Image, the image size is always changed proportionally. If this option was not selected,
press the <Shift> key while dragging to scale the image proportionately.

Vertically scaled image content.

Hint: To change the size of an image frame and its content, click on one of the edges or corners
while pressing the <Ctrl> / <Cmd> key and drag the frame larger or smaller while holding down the
mouse button. To scale the image proportionally, also press and hold the <Shift> key while drag-
ging.

Insert IPTC data

Many images from image databases contain IPTC information such as title, key words and copy-
right information. MarkStein Publisher can read this information and insert it in your document.

To do this, place the cursor in the image caption linked to the image and select the command In-
sert > IPTC Information...

The available information and an image preview are displayed in the window that opens. If the chain
contains multiple images, you can select the image for which you want to insert IPTC information
via the drop-down menu above the image preview.

https://de.wikipedia.org/wiki/IPTC-IIM-Standard
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Double-click on the information you wish to copy in the desired order, this information is then trans-
ferred to the preview window and separated by commas. Clicking the [Apply] button inserts the dis-
played text in the document and closes the window.

The IPTC Information window, the Object Name and Author Image attributes were double-clicked on and thus inserted
into the preview window for the text.
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Working with text

Basics

Before you start creating or editing text, it is recommended that you familiarize yourself with the
preferences for text and adapt them to your way of working.

To add text to an empty text frame or edit existing text, select the Tool Text content and click in the
text frame. The text cursor is placed at the clicked position.

Views

For creating and editing texts you have the possibility to select different view modes. Click on an
icon in the toolbar View to switch to the desired view.

View Toolbar: A: Script View, B: Galley View, C: Tile Horizontally, D: Page View

Script view: The text runs across the entire window width, only the paragraph formats are dis-
played, there is no line counting, thus no display of underset or overset.

Galley view: Checked out articles are opened in this view by default. This already takes into ac-
count the typeset width, which is defined by the frame or column width.

The serial line numbering, separately for each paragraph style, and the name of each paragraph
style are shown in the line ruler to the left of the story text. You can hide or show the line ruler in the
View menu.

The color in which the numbering of the body text is shown changes depending on how “full” the
size of the text frame or link defined in the layout is.

Black = underset: The text frame or link is not quite full.

Green = full: The text fits perfectly into the text frame or link.

Red = overset: One or more characters do not fit into the text frame or link.

The exact number of lines is shown in the status bar at the bottom of the window, including the
number of missing or excess lines.

Tile Horizontally: Simultaneously shows the galley and page views in a divided window.

Page View: Layout view with images.

Quotation marks, spelling and autocorrection

The settings and instructions for this can be found here.
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Navigation within text

To place the cursor at a specific location in the text, click with the text tool selected. However, if you
prefer to work with the keyboard, you can also navigate in the text using the arrow keys.

Following are the commands:

Arrow up moves the cursor one line up

Arrow down moves the cursor one line down

Arrow right moves the cursor one letter to the right

Arrow left moves the cursor one letter to the left

<Cmd>/<Ctrl> + Arrow right moves the cursor one word to the right

<Cmd>/<Ctrl> + Arrow left moves the cursor one word to the left

Pos 1 moves the cursor to the beginning of the line

End moves the cursor to the end of the line

<Cmd>/<Ctrl> + Pos 1 moves the cursor to the beginning of the text

<Cmd>/<Ctrl> + End moves the cursor to the end of the text

Selecting text

In order to perform certain text operations such as formatting, moving, copying or deleting text
blocks, you must first select these text passages. To do this, click at the beginning of the text to be
selected, hold down the left mouse button and move the cursor to the end of the text to be selected.
Selected text is highlighted with the color selected in the preferences.

Sometimes it is difficult to select text passages in a very small text with the mouse. You can use the
same commands for selecting as for moving in the text, you just have to press the <Shift> key addi-
tionally. 

You can select a word by double-clicking on it. In the preferences, you can specify whether the fol-
lowing space is included in the selection. A triple click selects the paragraph.

Further selection options are provided by the context menu (right mouse button) or the menu item
Edit > Select Text:

Context menu / Edit menu > Select Text

Text editing by drag and drop

If you activate this option in the preferences for text, selected texts can be moved and dropped with the
mouse button pressed. The behavior of the program corresponds to the Cut and Paste functions.
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If you hold down the <Cmd> or <Ctrl> key at the same time, the text is not moved but copied. The beha-
vior of the program corresponds to the Copy and Paste functions.

Select the text passage you want to move.

Click in the selection and hold down the left mouse button.

Move the cursor to the place where the passage is to be inserted and release the mouse button.
The passage is moved or copied.

The following operations are possible:

· Drag and drop within an article

· Drag and drop between different articles

· Drag and drop from an external program

· Drag and drop into an external program

If you enable the Insert text without style when using drag & drop option in the Preferences,
moved texts will automatically take on the style of the target paragraph.

Autotext

Frequently used phrases or terms can be saved as text modules via this function and called up as
required via their name. To save Autotext, proceed as follows:

Enter the text to be saved as autotext and select it.

In the menu, select the command Edit > Autotext...

In the following window, the selected text area is already entered in the lower field. Enter a name for
the text module in the Name field and click the upper [Insert] button. The text module is saved and
the window is closed.

The window Autotext

The saved text modules can be inserted into the text in two ways:

1. Place the cursor at the intended text position and select Edit > Autotext in the menu. Select the
desired text module, then click the [Insert] button. The text module is inserted at the cursor posi-
tion.
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2. Enter the name of the text module at the designated position and select Edit > Replace Auto-
text in the menu. The text module is inserted at the cursor position, overwriting the name.

Find and replace

You can find a detailed description of this function here. 

Loading text

The MarkStein Publisher offers the possibility to load externally stored texts. An overview of the nu-
merous document formats that the program can process can be found here. 

To do this, place the cursor at the intended position and select the Insert > Text... command in the
menu. Select the desired text file in your file system and click the [Open] button.

Insert special characters

The Insert menu allows you to insert numerous special characters into the text that are difficult or
impossible to reach using the keyboard.

The first four menu items Space, Line Break, Dashes and Quotation Marks can also be found in
the context menu.

 

The menu Insert
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Path text

Proceed as follows if you want to create a text that runs along a path:

Create the path using the Draw Bézier Line tool. The basics of how this tool works and how to use
it can be found here. 

The path intended for the text.

Select the object and open the properties window via the menu Object > Properties or with the key
combination <Cmd>/<Ctrl> + <Shift> + I. 

Switch to the Text tab and select the Type on path check box.

Confirm your settings by clicking the [OK] button. To enter the text, click on the path with the text
content tool selected.
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The Properties window, Text tab.

Effect: Rainbow aligns the characters along the path, Stair steps aligns the characters vertically.

Placement: Outside places the text above the path, Inside below.

The different effects and placements

X Offset: This value moves the text along the path, so it acts like an indent.

Y-Offset: This value regulates the distance of the text to the path.
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Here, an X offset of 10 mm and a Y offset of 3 mm is entered.

In the properties window shown above, you can assign a background color to the path object in the
Frame tab and specify the weight and color of the stroke in the Stroke tab. 
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Anchored frames
Anchored frames included in the text stream retain their position in the text, even if the text be-
comes longer or shorter due to changes in the text or layout. Anchored frames may include text, im-
ages, or both. With one exception*, they are also displayed in Galley or Script view and are included
in typesetting calculations. They can be deleted in these modes, but not edited.

There are several types of anchored frames available. These are selectable via the Insert menu.

The properties of an inserted frame can be edited at any time using the inspectors or the Object >
Properties... menu command if the frame has been selected with the selection tool.

If you have accidentally anchored a frame that already contains text or an image in the wrong place,
cut it with the Edit > Cut command or with the <Cmd> / <Ctrl> + X shortcut and paste it back into
the document with the Edit > Paste command or with the <Cmd> / <Ctrl> + V shortcut. The link is
now removed and you can reinsert the frame elsewhere as an anchored frame. To permanently re-
move an anchored frame, select it with the Selection tool and press the <Del> key. 

The Insert menu with commands for inserting anchored frames
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Anchored frame at paragraph

This type of anchored frame is either at the beginning of a paragraph or forms a paragraph of its
own.

Place the text cursor anywhere in the paragraph where you want to insert the frame and select
Anchored Frame - Paragraph... from the Insert menu. In the following Properties - Frame win-
dow set the desired frame properties and confirm the selection by clicking the [OK] button.

The frame is inserted as the first element in the paragraph. The properties of the frame can be ed-
ited at any time using the Selection tool, the Inspector or the Properties - Frame dialog.

Anchored frame at the paragraph with a decorative initial that is an image file

To place an anchored frame in its own paragraph, first create an empty paragraph with the
<Return> key, place the cursor there and proceed as described above.

The created frame can be moved horizontally and vertically using the selection tool or the arrow
keys.

Anchored frame at the paragraph as single paragraph, used here as chapter numbering

Paragraph frame from clipboard

If you have already created the frame to be inserted, you can copy it to the clipboard using the Edit
> Copy command or the <Cmd> / <Ctrl> + C shortcut, place the cursor anywhere in the selected
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paragraph, and add it to the paragraph using the Insert > Paragraph Frame from Clipboard com-
mand.

Anchored frame at text

These anchored frames can be positioned anywhere in the text.

Place the cursor at the position in the text where you want the frame to be inserted and from the In-
sert menu, choose Anchored Frame - Text... In the following Properties - Frame window set the
desired frame properties and confirm the selection by clicking the [OK] button.

The properties of the frame can be edited at any time using the Selection tool, the Inspector or the
Properties - Frame dialog.

Anchored frames at text. Frames retain their position in the text stream despite changes in line length.

Anchored frames at text can also rotate

Text frame from clipboard

If you have already created the frame to be inserted, you can copy it to the clipboard using the Edit
> Copy command or the <Cmd> / <Ctrl> + C shortcut, place the cursor at the intended location in
the text and use the Insert > Text Frame from Clipboard command to insert the frame.

Insert anchored frames from library

This function allows you to insert image or text frames already saved as Layout templates into the
text. To do this, select the command Anchored Frame from Library... in the Insert menu. In the
following dialog box, select the desired folder of your library from the Folder drop-down menu and
specify whether it should be an anchored frame at text or paragraph.

Then select the frame you want to insert and click [OK].
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The properties of the frame can be edited at any time using the Selection tool, the Inspector or the
Properties - Frame dialog.

The Anchored Frames from Library dialog box; in the Image frames folder, the Portrait image frame is selected as
Anchored Frames - Paragraph.

Select paragraph frame to create a Marginalia

Another way to anchor a frame to a specific text location is to use the Insert > Select Paragraph
Frame command. This function is intended, for example, to anchor marginalia to a specific text loc-
ation so that they retain their position to the anchor when text or layout changes are made.

The options shown so far for linking a frame to a paragraph or a specific text passage include the
frames within the text stream. Thus they are also displayed in the script or galley view and are taken
into account in the typesetting calculation. With this function, the linked frames retain their original
position in relation to the source and are not integrated into the text stream. For this reason, they
are editable only in page view mode, since they cannot be displayed in the script or galley view. 

In order to provide the possibility of using different style sheets for the main text and the marginalia,
it is not possible to apply this function in a created article that has already been assigned a style
sheet.

Proceed as follows to apply this function:

1. Position the frame to be linked and place the cursor at the text location to which the frame is to
be linked.

The text frame to be linked is positioned at the planned position of the margin, the cursor before the keyword.

https://en.wikipedia.org/wiki/Marginalia
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2. Choose Select Paragraph Frame from the Insert menu. The mouse pointer changes to an ar-

row with a chain symbol . 
If you move this mouse pointer over the frame to be linked, it will be highlighted in light blue and
a green arrow will connect the two frames.

The cursor with the chain icon

3. Click with the left mouse button on the frame to be linked. The link is created and displayed with
a green arrow.

The link has been established; the dot on the green arrow points to the line where the anchored frame is linked to.

If you right-click the linked frame immediately after this action, this context menu will be displayed:

The context menu of the anchored frame

Delete: Removes the linked frame.

Copy: Copies the linked frame.

Properties: Opens the Properties window of the linked frame, where you can set background color,
border, outline, etc.

Properties Anchored Object:

The options for the linked frame.

Anchor to Line: Here you can specify at which line of the paragraph the anchored frame - para-
graph should be anchored. 
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The default setting is always the line at which the cursor was located when the Select Paragraph
Frame command was entered.

Position on page: Here you specify where the anchored frame should be positioned when the
source of the link flows to another document page due to cuts, additions, or layout changes. 

Left: The linked frame always remains to the left of the text frame from which the link originates after a
page change.

Right: The linked frame always remains to the right of the text frame from which the link originates after
a page change.

Inside: The linked frame always remains oriented toward the inside margin in double-sided documents
after a page change.

Outside: The linked frame always remains oriented towards the outside margin in double-sided docu-
ments after a page change.

Double-sided document, the marginalia are positioned outside.
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Adding an image moved one of the marginalia to the right side and is automatically oriented to the outer margin.

If the selection of the linked frame has already been deselected, you can reach these setting op-
tions via the context menu of the frame using the Anchoring Object menu item.
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Footnotes and Endnotes
Footnotes and endnotes are used to manage references, explanations, source or literature refer-
ences, translations or similar. They consist of three independently formatable elements:

· Reference to footnote in the text

· Footnote count

· Footnote text

The latter corresponds to a separate paragraph inserted at the end of the text. Endnotes are at the
end of the text, for example a list of sources or literature. Footnotes are on the same page as the
footnote reference, such as a translation of a foreign language term.

Styles

The description of the necessary styles can be found here.

Footnote options

Use the Style > Footnote Options... menu to specify how footnotes should be numbered.

The Footnote Options window

Number Format: Use this drop-down menu to specify the way the footnote reference is numbered
in the text as well as in the footnote paragraph.

The options in the Number Format menu

Prefix: Enter a text in the input field if you want to insert a custom text before the footnote count.
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Suffix: Enter a text in the input field if a user-defined text (for example, a closing bracket) is to be
inserted after the footnote count.

Start At: Here you specify with which starting value the numbering begins. Footnotes are automat-
ically numbered according to the order in the text. If a footnote is inserted before already existing
footnotes, the value of the following footnotes is automatically increased.

Continue Footnotes of the previous Story: Check this option if you don't want the footnote count
to start at the defined starting value for each text section in the document, but to be numbered con-
secutively throughout. The footnote count of all text sections follows the order in the layout. If there
are several text sections on a page, the order is determined from top left to bottom right.

Footnote: Characters Between Numbers and Text: The program inserts a tab separator
between the footnote count and the footnote text by default. You can enter any character in the input
field.

Usage

Place the cursor where you want to insert the footnote reference. Choose Insert > Footnote from
the menu or the context menu. 

The reference is created and marked with a gray flag. At the same time, a paragraph is inserted at
the end of the text, which already contains the corresponding footnote count. The cursor automatic-
ally jumps to the place where the footnote text begins, so you can immediately start entering text.
With each footnote reference, another paragraph is appended with the continuous count.

Hint: The footnotes of MarkStein Publisher are always endnotes, which means that footnote texts
are placed as separated paragraphs at the end of the text.

To place the paragraph in question on the page with the reference, proceed as follows:

1. On the page that contains the footnote reference, place a text frame to which you assign the
block type “Footnote”. 

2. Link the created frame to the last text frame of the text section. 
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The footnote placed on the page with the references and linked to the text section

Additional footnote frames are added as described above and linked to the last footnote frame in
each case.

For works that contain a large number of footnotes, it is recommended to provide an empty footnote
frame with the desired attributes and save it as a layout template. 

Import options

The description of options when importing text that contains footnotes can be found here.
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Find and Replace

When working with larger documents, you may need to search more often for a specific term, pas-
sage, or section to make text changes.

To do this, you can use the Find/Replace function to search for words, character strings, and
formatting such as paragraph format, text format, paragraph attributes, or text attributes in the docu-
ment and have them replaced.

This function can be used via the menu Edit > Find/Replace or via short command <Ctrl> + F or
<Cmd> + F.

The Find / Replace window

Search For: Input field for the searched string.

Style: A format or attribute assigned to the search term is displayed here.

Replace With: Input field for the replacement string.

Style: A format or attribute assigned to the replacement is displayed here.

Continue: Click on this button to jump to the next occurrence of the search term.

Cancel: Cancels the process and closes the window.

Replace: Replaces the search term at the current location.

Replace All: Replaces the search term at all locations of the current chain or if All pages is activ-
ated in entire document.

Search Direction: 

    Up: The search is performed from the current cursor position to the beginning of the chain.

    Down: The search is performed from the current cursor position to the end of the chain.

    Total: The entire chain is searched.

Note Upper/Lower Case: Activate this option so that the upper/lower case of the searched charac-
ter string is taken into account during the search.

All Pages: If you want to limit the search to the current chain, deactivate this option.
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Search Whole Word: If this option is deactivated, the searched string will also be displayed as
found if it is only one element of a word. 

Style: By selecting one of the options, you can restrict the search to certain paragraph or text styles
as well as paragraph or text attributes. You can also assign a paragraph or text style and paragraph
or text attributes to the replacement term.

Glyphs: This window can be used to select all characters in a font that cannot be entered directly
using the keyboard.

Special Characters: Here you can select special characters such as spaces, line ends, dashes,
quotation marks, and so on.

Remove Styles: Here you can delete attributes assigned to the search term or replacement term.

Example:

In an article, all mentions of a name that were previously set in the default straight font are to be it-
alicized.

1. Enter the name in the Search For field.

2. Click the Style button and select the text style used to format the name.

3. Enter the name in the Replace With field.

4. Click the Style button and select the text style you want to use to format the name.

5. Click the [Replace All] button to perform the replacement.

Find / Replace example
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Working with markers

With MarkStein Publisher, you have the option of using markers to create 

· Text notes, 

· Registers (only MarkStein Publisher Workgroup Edition), 

· Bookmarks, 

· Hyperlinks, 

· Text anchors and 

· Footnotes.

The functions of the various markers are described below.

Text notes

With text notes, you can attach additional information or correction instructions directly to a position
in the text. Place the cursor where you want to insert the text note.

Select the command Insert > Text Note..., enter the subject and message in the Note window that
opens and select a color for the icon. When you click the [OK] button, the icon – two overlapping
squares – is inserted into the text and the window closes.

Using the Notes panel, you can view and edit the notes, even if they are hidden using the View
menu. Double-clicking the icon opens the note.

If a PDF of the page is generated, the text note can be applied to the PDF, where it is displayed as a
comment.

Text frame with text note inserted as correction instruction
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Page notes

If you want to place a page note, you must first open the notes panel.

The Notes panel

Switch to the Page tab and click the icon with the + sign, then the position on the page where you
want to place the note. In the Note window that opens, enter the subject and message and select a
color for the icon. When you click [OK], the icon – a notepad on which the author and subject is
shown – is inserted on the page.

Placed page notes

To read a page note, double-click it or select it in the panel. The message will be shown at the bot-
tom of the window.

If a PDF of the page is generated, the page note can be applied to the PDF, where it is displayed as
a comment.
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Register

This is a function of MarkStein Publisher Workgroup Edition.

To create a register entry for a register of keywords or names, highlight the word in the text or posi-
tion the cursor in the word that you want to add as a register entry.Select the command Insert > Re-
gister...

In the Insert Register window that opens, the selected text is automatically shown in the Term sec-
tion. Clicking the [Add] button adds the term to the register and closes the window. 
The terms marked as register entries are marked in the text with purple flags.

Editing register entries in the text and in the Edit Register window

You can find a detailed description of the function and how to place the register in the document
here.
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Bookmarks

This function enables you to place bookmarks in longer texts, helping you find those passages
again quickly.

To do this, place the cursor at the point in the text where you want to insert the bookmark, select the
command Insert > Bookmark... and enter a name in the Bookmark window that opens.

The Bookmark window. Depending on the option you select under Sort by:, the entries will be shown in alphabetical or-
der or in order of their position in the text.

Clicking the [Add] button adds the name of the bookmark list and inserts a red flag in the cursor po-
sition.

To jump to a passage of text marked in this way, open the Bookmark window and double-click the
bookmark you want, or select the command Insert > Bookmark..., select the term you are looking
for and click the [Go to] button.

Hyperlink

Here you can insert Hyperlinks into the text.Use this function to define jump addresses within the
document, to other documents or to websites. To do this, highlight the text passage or place the
cursor at the point in the text where you want to insert the hyperlink and select the command Insert
> Hyperlink... In the Hyperlink / Link window, switch to the relevant tab to define the type of hyper-
link. In the Text: box, enter the text you want to be shown as a hyperlink and confirm your entry with
[OK].
You will find a list of the different types of hyperlink below.

When text is exported as a PDF or e-book, these links are exported too and aid navigation. In e-
book readers, the hyperlinks are automatically highlighted so they can be easily recognized; if you
wish this to be the case in a PDF, you need to create a style for this highlighting and use it to format
the hyperlinks.

Here you will find a description of how to format hyperlinks automatically.
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Paragraph

To link to a specific paragraph, the paragraph must be assigned a structure level higher than 0.
When a hyperlink is inserted, all paragraphs with this attribute are listed in the Paragraph tab,
where they can be selected as a jump target.

Hyperlinks to paragraphs are marked with a red flag.

Hyperlinking a paragraph

Text anchors

The Text Anchors tab lists all the text anchors contained in the document and enables you to se-
lect them as a jump target.

Hyperlinks to text anchors are marked with a green flag.

Link

The Link tab lists all the links contained in the document and enables you to select them as a jump
target.

Hyperlinks to links are marked with a small red flag.

Page

The Page tab lists all the pages contained in the document and enables you to select them as a
jump target.

Hyperlinks to pages are marked with a small red flag.

Visited URL

The Visited URL tab shows the jump targets that have already been linked in this document.

Internet address: In the Text: box, enter the text you want to be shown as a hyperlink. Enter the in-
ternet address in the URL: box and confirm your entries with [OK].
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Hyperlinking a web address

File: In the Text: box, enter the text you want to be shown as a hyperlink. Enter the file path in the
URL: box. To enter the path automatically, under Find:, click on the [File] button and confirm with
[OK].

Text anchors

Text anchors serve as jump targets for hyperlinks within a document.

To insert a text anchor, highlight a word and select the command Insert > Text Anchor...

Footnote:

To insert a footnote, position the cursor and select the command Insert > Footnote.

The reference will be entered in the cursor position, the footnote text with numbering will be entered
at the end of the text. Footnotes are formatted automatically where respective paragraph and text
styles have been selected. This is explained here.
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Working with templates

Recurring elements (layout templates, document templates, story templates, snippets) can be
saved in the library as templates for repeated use.

These elements are created from the layout and directly saved in the active library, which is dis-
played in the status bar at the bottom of the window, via the commands Object > Save as Layout
Template..., Object > Save as Snippet... or Page > Save as Document Template.... To select a
different library as the target location, go to the Start window and click on Libraries, right-click on
the desired library and select the [Default] command.
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Document templates
The complete page structure of one or multiple consecutive pages is saved as a document tem-
plate in the library. 
A document template may contain all page definitions and content, such as styles and grid as well
as included text and images or only the frame geometry.

Saving a document template

In the Templates panel, click on the + sign or select the command Page > Save as Document
Template...

Dialog window Save as Document Template

Library: The name of the active library is displayed in this field. If you wish to save to a different lib-
rary, you need to cancel the process and define the desired library as Default.

From Page: / To Page: Define the range of pages you want to save as a document template.

Folder: If you have already created folders in the library, you can select one of them via the drop-
down menu. If no folders exist, a folder is automatically created using the designation you enter
here.

Designation: Enter a designation for the document template being saved.

Options:

Save Text: Activate this option if texts contained in the pages should also be saved in the template. For
text chains which extend beyond the selected page range, the entire text in the chain is saved.

Save Image(s): Use the drop-down menu to specify whether images should also be saved in the tem-
plate. If you choose Yes, only a low-resolution preview of the image and the image reference (path) are
saved, not the image file itself. If you choose No, only the image frames are saved.

Using a document template

A document template saved in the library can be applied to one or several pages of an open docu-
ment or be selected when creating a new document.

To place a document template in a document, drag the template from the Templates panel to the
document page on which or from which the template should be applied. The template is placed at
the cursor position in this case.
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If you double-click on the template in the Templates panel, the template is placed at the position on
the page at which it was saved.

With both approaches, style sheets included in the layout template are applied to the target docu-
ment and displayed in the Styles panel.
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Layout templates
Frequently used objects can be saved in the library and used in the document as needed.

Unlike document templates, layout templates do not contain page definitions such as size and grid.
They only contain the geometry of the chain and, if defined when saving, text and images. 
These layout templates can not only be placed on the page, but can also be used to assign a differ-
ent geometry and style sheet to a chain in one work step.

Saving a layout template

Select the chain or element in the chain and use the command Object > Save as Layout Tem-
plate... The entire chain is saved in this process, however, it is not possible to also save objects
outside the chain.

Dialog window Save as Layout Template

Library: The name of the active library is displayed in this field. If you wish to save to a different lib-
rary, you need to cancel the process and define the desired library as Default.

Folder: If you have already created folders in the library, you can select one of them via the drop-
down menu. If no folders exist, a folder is automatically created using the designation you enter
here.

Designation: Enter a designation for the layout template being saved.

Options:

Story Template: Activate this option if you want to save the element as a story template.

Save Texts: Activate this option if text contained in the chain should also be saved in the template.

Save Image(s): Use the drop-down menu to specify whether images should also be saved in the tem-
plate. If you choose Yes, only a low-resolution preview of the image and the image reference (path) are
saved, not the image file itself. If you choose No, only the image frames are saved.

Placing a layout template

To place a layout template in a document, drag the element from the Templates panel to the docu-
ment page. Here the object is placed at the position of the cursor.
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If you double-click on the element in the Templates panel, the element is placed at the position on
the page at which it was saved. 
With both approaches, style sheets included in the layout template are applied to the target docu-
ment and displayed in the Styles panel.

Applying a layout template to an object

In general: Text contained in the layout template is not transferred when applying the template. The
text contained in the target object remains; for images you can specify whether they should remain.

Select an element in the chain and select the command Object > Apply Layout Template…

The Apply Layout Template dialog window will open. If you have created several folders in the lib-
rary, you can select the folder containing the layout template from the Folder drop-down menu.

Dialog window Apply Layout Template

Select the layout template with the properties you wish to transfer; this activates the options below
the drop-down menu.
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Dialog window Apply Layout Template. Selecting an object activated the options.

Fit Frames to Text: Activating this option automatically adapts the text frames to fit the text. If it is
not activated, the geometry of the layout templates is applied.

Apply Images from Link: Activating this option retains the images contained in the chain which is
to be changed. If it is not activated, the images contained in the chain are removed, the frames re-
main unchanged.

Remove Blank Image Frames: Activating this option removes blank image frames in the chain and
frames from which images were removed by deactivating the Apply Images from Link function.

Remove Corresponding Photo Credit Frames: Activating this option removes empty photo credit
frames contained in the chain.

If the layout template you want to apply to an object contains a different style sheet, you can use the
following dialog to specify whether the style sheet should be changed or remain the same.

Dialog window Select Style Sheet.

You can also apply a layout template by dragging it to an object while pressing the <Ctrl> / <Cmd>
key. The options defined in the Templates panel under Details are applied here.
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Story templates
The functions and approaches when working with story templates are essentially the same as those
for document templates described in the previous section. The difference here is that the geometry
and style sheet can be defined when creating a new story by selecting a story template (document
template with story template option).
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Snippets
You can save chains or an individual object from a chain as a snippet. Snippets can only be placed,
they do not have any function.

Double-clicking on a snippet in the template panel places it in the position it was in when saved,
drag and drop it to position it where you wish.
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Working with libraries

On the next few pages, you will find information about using libraries with MarkStein Publisher.
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Libraries
All recurring page and line elements can be stored in a library. This includes colors, style sheets,
grids, master pages, table style sheets, document templates and layout templates. Within a library,
the objects are stored in folders.

When MarkStein Publisher is installed, the “Standard” and “Templates” libraries are installed auto-
matically. The “Standard” library is empty apart from objects that are technically necessary. The
“Templates” library contains a lot of ready-to-use elements that help you get started with MarkStein
Publisher. You can also create as many libraries as you like.

Internal vs. external libraries

The default location of the libraries is ...\AppData\Roaming\MarkStein\Library. However, you can se-
lect a different location in your file system (for example, in Dropbox as a shared library for use by
multiple users) when you create a library. Libraries saved in a location other than the default loca-
tion are automatically linked and marked with an appropriate icon. When you drag an existing lib-
rary from the file system to the Libraries list, you can choose to link the library or to place a copy of
the source library in your local Libraries folder.

The icon of a linked library

Functions of libraries

When a new document is created, the contents of the selected library are transferred to the docu-
ment and shown in the assigned panels, e.g. master pages and grids in the Pages panel.

Please note that new objects that you create in the panels and save with the document are not auto-
matically transferred into a library. For example, if you create a new style sheet or color in your doc-
ument, you need to manually transfer it into the relevant library if you want the style sheet to be
available in any new document you create. You can find a description here.

Exceptions to this principle are sample lines, sample elements, and story templates, which are
saved directly in the active library and shown in the Templates panel. When these elements are
saved, it is always in the active library – the library that is currently defined as “Default”. It is marked
with an orange icon in the Start > Libraries window and shown in the status bar of MarkStein Pub-
lisher.
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The icon of the library defined as the default is shown in orange.

To select a different library as the default, right-click the icon of the library you want and select De-
fault from the drop-down list.

Drop-down list with Default

Important: Any modification or deletion of library content is saved immediately and cannot be un-
done!
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Creating a library
In the Start tab, click the Libraries button and double-click the New Library icon.

Assign a name in the following dialog Create library. In the Path: input field, the path to your local
folder is entered as the default. If the library is to be saved in a different location, select a different
location in the file system after clicking on the icon with the three dots and click on [OK] to complete
the process.

Libraries window with New Library dialog

The library opens immediately and can be edited, for example by adding colors needed for a public-
ation.
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The new library



Working methods   Working with librariesMarkStein Publisher Manual

© 2022 MarkStein Software GmbH 193

Contents of a library
A newly created library has the following contents:

 One folder for each colors, style sheets, grids, master pages and table style sheets.

The content of a newly created library

The Colors folder contains the colors “[None]” = transparent, “White” (opaque), the colors “Black”,
“Cyan”, “Magenta” and “Yellow” for four-color printing, “All” (brand color) and “[Undefined]”.



Working methods   Working with librariesMarkStein Publisher Manual

© 2022 MarkStein Software GmbH 194

The content of the Colors folder.

The Master Pages folder contains a template for a DIN A4 page, the Grid folder contains the cor-
responding 3-column grid. The other folders are empty.

You can create additional folders when saving document templates, layout templates and story
templates. It is not possible to create folders in the library window.

Hint: When getting started with MarkStein Publisher, we suggest using the “Templates” library,
which contains many ready-to-use elements that simplify working with MarkStein Publisher.
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Elements in the library

Colors

The colors in the library

You have the option to work with colors from different colorspaces and color types.

Colorspaces:

CMYK: The primary colors Cyan, Magenta, Yellow and Key (black) for four-color printing.

RGB: The primary colors Red, Green and Blue for screen display.

Pantone: Specialist colors for the printing industry, developed by the American company Pantone
LLC.

https://en.wikipedia.org/wiki/CMYK_color_model
https://en.wikipedia.org/wiki/RGB_color_model
https://en.wikipedia.org/wiki/Pantone
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HKS: The trademark of specialist colors from a cooperation between three German color manufac-
turers. The acronym stands for Hostmann-Steinberg Druckfarben, Kast + Ehinger Druckfarben and
H.Schmincke & Co.

HSB: A variant of the device-independent colorspace HSV. The acronym stands for Hue, Saturation
and Brightness.

Color types:

Process: A color that comprises different proportions of the primary colors for four-color printing.
Colors that were originally defined in other colorspaces as full-tone colors with specialist pigments
can usually only be shown approximately as process colors.

Full-tone color: A color that is used in addition to the primary colors.

If you would like more detailed information on colorspaces and color types, click on the bold term at
the start of each explanation, which links to the respective Wikipedia article.

Style sheets

The library with the Style Sheets folder open, in which the Default Style Sheet folder is open. The Body text paragraph
style is selected in this folder; the text styles it contains are shown on the right.

A style sheet contains at least one or more paragraph styles, which it combines in a group. Each
paragraph style contains at least one or more text styles.

Every text element, be it an individual text frame or an extensive chain, must have a style sheet as-
signed to it. This makes the structure clearer and also provides the option of, for example, giving a
story or a book a totally different style by switching style sheets. Each text element with a paragraph

https://en.wikipedia.org/wiki/HKS_(colour_system)
https://en.wikipedia.org/wiki/HSL_and_HSV
https://en.wikipedia.org/w/index.php?title=Process_color&redirect=no
https://en.wikipedia.org/wiki/Spot_color
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style of the same name and the subordinate text styles are reformatted when the style sheet is
switched.

Grid

A grid is the area on a page in which the printing elements, such as text, images or charts, are ar-
ranged.

As this area is defined by the margins, you can use the same grid for different page sizes, such as
DIN A4 or 1/6 DIN.

The library with the Grid folder selected; the grids it contains are shown on the right.
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Master pages

A master page is a combination of the page style and an assigned grid. In the library, you can ini-
tially only define the page size and the grid. You can add further elements, such as page numbers,
in the layout.

The library with the Master Pages folder selected; the master pages it contains are shown on the right.
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Table style sheets

You can use table style sheets to ensure that all the tables in a publication have a uniform appear-
ance. They contain cell styles, with which you can design the different cells in the table.

Before creating a table style sheet, you should first create the paragraph styles you need with the
assigned font styles, so that the text styles within the tables also look the same.

The library with the Table Style Sheets folder open. The Default table is selected; the cell styles it contains are shown
on the right.
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Editing library content
Library content can be created and edited in the window of the relevant library. The creation of con-
tent is described below. You can edit existing content by right-clicking the element you want to edit
and selecting Properties... from the drop-down menu.

You can also create the elements described here in a document and save them in the associated
panel. However, you need to transfer them to the relevant library if you want them to be available in
any new documents you create.

To do this, in addition to the document containing the newly created elements, you must also open
the target library via Start > Libraries. Click on the element you want to transfer and drag it to the
tab that contains the name of the target library. A small arrow will appear below the cursor. If you
now release the mouse button, the object will be automatically copied into the correct folder in the
library. This function also enables you to transfer library content between libraries and from libraries
to documents.
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Colors

The Templates library; the Colors folder is selected in the overview on the left. The colors it contains are shown in a list
view on the right of the window. You can find information on the various colorspaces here.

Creating a new color

Right-click on the Colors folder or in the space in the color list and select New...

The Process Color box is checked by default and the colorspace CMYK is preset, which is correct
for print projects. Uncheck the Process Color box to create a full-tone color. Click the Colorspace
drop-down menu to select a different model. Here you will find the RGB colorspace, for example,
which is intended for on-screen projects, and the full-tone and process scales from Pantone and
HKS.
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Left: a dark blue color made from 100% cyan and 100% magenta with individual name. Center: the name comprises the
individual color values. Right: the same color in the RGB colorspace.

Move the sliders for the individual colors, enter a value, or click the arrow to create the color you
want. Then enter a name for the new color in the Name box or check the box next to Name with
color value.

Confirm by clicking [OK]. The color will be shown in the color list immediately.

Creating a new tint

Right-click on the color from which you want to create a tint and select New > Tint...

The Properties - Color window when creating a tint

Move the Tint slider, enter a value, or click on the arrow to create the tint you want. The name, color
type, and colorspace cannot be edited, as the tint is based on the original color.

Confirm by clicking [OK]. The tint will be shown in the color list immediately.
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Creating a new gradient

Right-click on a color from which you want to create a gradient and select New > Gradient...

The Properties – Color Gradient window will open; the color you clicked is entered as Color 1.
The default presets are white as Color 2 and the Type “Linear” with an angle of 0°. 100% is
entered as the tint for both colors.

The Properties - Color Gradient window.

Name: Enter a name for the new gradient.

Color 1: Use the drop-down menu to select the first gradient color and define the tint you want by
entering a figure in the box or clicking on the arrows.

Color 2: Use the drop-down menu to select the second gradient color and define the tint you want
by entering a figure in the box or clicking on the arrows.

Type: Select one of the defined gradient types. The available options are Linear, Linear from
Center, Rectangular, Diamond, Radial Inside, Radial Outside and Shadow.
Select Shadow if you want to create a shadow gradient. Here, again, define “Color 1”. For “Color 2”
the option [None]  – i.e. transparent – is shown automatically.

Angle/Width: The value in the Angle box defines the direction of the gradient. If you select Shadow
from the Type drop-down menu, use the Width box to enter the width that you want the gradient to
cover.

Gradient slider: You can move the start, middle, and end point of the gradient using the triangles
on the slider.

The result of your settings is shown in the preview. To save the gradient, click [OK].

Editing a color

You can edit an existing color by right-clicking the color and selecting Properties... from the drop-
down menu. Confirm your changes with [OK].
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Style sheets

A style sheet contains all the paragraph styles needed for a specific project or type of project. Each
paragraph style contains various text styles.

The Templates library. The Style Sheets folder is selected in the overview on the left; the style sheets it contains are
shown on the right of the window as a list.

Edit style sheet 

You can edit an existing style sheet group by right-clicking on the style sheet group and selecting
Properties... from the context menu. Make the desired changes and confirm them with [OK].

The paragraph and text styles contained in the style sheets can be edited in the same way.

How to create and edit style sheets, paragraph and text styles on the layout is described in the
Working with style sheets section of this guide.
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Grid

The Templates library. The Grid folder is selected in the overview on the left; the grids it contains are shown in a list on
the right of the window.
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Creating a new grid

Right-click on the Grid folder or in the space in the grid list and select New...The New Grid window
will open.

The New Grid window

The process for creating a new grid within a library is identical to the process for creating a new
document, described in the section Grid tab.

Editing a grid

You can edit an existing grid by right-clicking the grid and selecting Properties... from the drop-
down menu. Make the changes you want and confirm with [OK].
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Master pages

The Templates library. The Master Pages folder is selected in the overview on the left; the master pages it contains are
shown in a list on the right of the window.
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Creating a new master page

Right-click on the Master Pages folder or in the space in the master pages list and select
New...The New Master window will open.

The New Master window.

Assign a name and prefix for the new master page and check the box next to Facing Pages if you
are creating a master for a multi-page document. You can find an explanation of the Facing Pages
option here.

Enter the values you want in the Page Size tab. You can find a detailed explanation of this in the
section Creating a new document > Page Size tab.

Enter the values you want in the Grid tab. You can find a detailed explanation of this in the section
Creating a new document > Grid tab.

Editing a master page

You can edit an existing master page by right-clicking the style sheet and selecting Properties...
from the drop-down menu. Make the changes you want and confirm with [OK].
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Table style sheets

The Templates library. The Table Style Sheets folder is open in the overview on the left; the cell styles it contains are
shown in a list on the right of the window.

Creating a table style sheet / Basic Options tab

Right-click on the Table Style Sheets folder and select New Table Style Sheet... The Properties -
Table Style Sheet window will open.

The Properties - Table Style Sheet window, Basic Options tab
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Name: Enter a name for the table style sheet here.

Orientation: Here you can define whether the table is oriented according to the row or the column,
i.e. whether you want to work through the table horizontally or vertically.

Row Rules In Front/Column Rules In Front: If you have defined overlapping lines with different col-
ors, tints, or opacities, you can choose which overlapping line is at the top by activating one of these but-
tons.

CSS Class/CSS Style: Enter the CSS class and style for the table style sheet here. You can find an
introduction to this here.

Creating a table style sheet / Margin Rules tab

In this tab, you can define whether to give a table a margin rule on the left and/or on top.

The Properties - Table Style Sheet window, Margin Rules tab

Margin Rule Top: This defines a line that is placed at the upper edge of the table spanning its entire
width. The rule weight falls inside the table.

Margin Rule Left: This defines a line that is placed at the left edge of the table spanning its entire height.
The rule weight falls inside the table.

Style: Select one of the defined line styles from the drop-down menu.

Weight: Insert the line weight or click on the arrows.

Color: Use the drop-down menu to select the rule color.

Tonal value: Enter the tonality in % in this box, or click on the arrows to increase or reduce the current
value. Permitted values range between 0.1% and 100%.

Opacity: Enter the opacity, i.e. the level of transparency of the margin, in this box or click on the arrows
to increase or reduce the current value. Possible values range between 0.1% and 100%.

In Front: If you have defined overlapping lines with a different color, tint or opacity, you can choose which
overlapping line is at the top by activating one of these buttons.
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Creating a table style sheet / Stroke tab

Here you can define a line frame that encloses the entire table. Using the Position buttons, you can
define how the stroke is positioned: Center, Outside or Inside the frame.

The Properties - Table Style Sheet window, Stroke tab

Creating a table style sheet / Rows tab

 In this tab, you can define whether the individual rows are separated with horizontal lines.

The Properties - Table Style Sheet window, Rows tab

CSS Class/CSS Style: Enter the CSS class and style for the row lines here. You can find an intro-
duction to this here.
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Creating a table style sheet / Columns tab

In this tab, you can define whether the individual columns are separated with vertical lines.

The Properties - Table Style Sheet window, Columns tab

CSS Class/CSS Style: Enter the CSS class and style for the column lines here. You can find an in-
troduction to this here.
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Transferring library contents

Transfer selected library content

The colors, style sheet, table style sheets, grids and master pages created in a document are part
of the document and are not automatically saved to the active library. 

To transfer selected content to a library, follow these steps:

1. Switch to the Start tab.

2. Click on the [Libraries] button.

3. Open the library to which you want to transfer content by double-clicking or using the context
menu with the Open command.

4. Switch to the document that contains the contents to be transferred.

5. Open the panels from which content is to be transferred to the library.

6. To transfer style sheets or table style sheets, put the panel in edit mode by clicking the gear icon
in the lower right corner.

The Styles panel in edit mode; all available style sheets are displayed

7. Holding down the mouse button, drag the element to be transferred to the tab of the target library
and release the mouse button there.
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Dragging the item to the target library tab

Done. The transferred item is automatically copied to the correct folder in the library.

The transferred style sheet in the target library
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This method can also be used to transfer all contents mentioned at the beginning to another open
document. Simply drag the element from the panel to the tab of the target document. The exchange
of content between libraries also works this way.

Transfer document content to library

If you want to save not only selected, but all newly created or changed library contents to the cur-
rently active library at the same time, select the menu item Extras > Sync Library from Docu-
ment...

The menu item Extras > Sync Library from Document.

The Sync Library from Document dialog box opens.
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The Sync Library from Document dialog

The Library: and Document: fields are for information only, the name of the active library and the
document name are entered here. Entries are not possible.

If you leave the overwrite existing elements option enabled (default), elements with the same
name in the library will be replaced with those from the document. 
If the option is disabled, only newly created elements will be transferred, changed elements will be
ignored.

Transfer library content to document

In the same way, you can transfer content from a library to an open document, for example, when
you receive information that a shared library has been modified.

To do this, select the menu item Extras > Sync Document from Library... 

The Sync Document from Library dialog
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The Library: and Document: fields are for information only, the name of the active library and the
document name are entered here. Entries are not possible.

If you leave the overwrite existing elements option enabled (default), elements with the same
name in the document will be replaced with those from the library. 
If the option is deactivated, only newly created elements are transferred, changed elements are not
considered.
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Working with style sheets

Creating a new style sheet / Basic Options tab

Right-click on the Style Sheets folder or in the space in the style sheet list and select New Style
Sheet. The Properties – Style Sheet window will open.

The Properties – Style Sheet window, Basic Options tab

In the Name: box, enter a name for the new style sheet.

If you want to work with a grid within the style sheet, check the box and enter the start value, the ref-
erence point and the spacing of the grid in the relevant boxes.

Optical Alignment: Letters with a lot of Sidebearing such as A, V and W, can leave the left-hand
side of a paragraph looking uneven; punctuation can do the same on the right. This function helps
to compensate.

Left Margin

No Alignment: Select this option if you do not want any alignment.
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% Relative to EM Space: The optical alignment is conducted with a fixed value that relates to the width
of a square of the selected font size. With a font size of 12 pt, a quad is 12 pt wide.

From Font: The values are taken from the Kerning table of the font selected in each case. The charac-
ters are moved to the left by the Kerning value from the space defined in the font.

Left: no alignment. Center: 10% of quad. Right: from font.

Right Margin:

No Alignment: Select this option if you do not want any alignment.

% Relative to EM Space: The optical alignment is conducted with a fixed value that relates to the
width of a quad of the selected font size.

             

Left: no alignment. Right: 15% of quad.

Use Next Style Feature:

In all paragraph styles, you can define a next style that will be automatically applied for the next
paragraph when the end of a paragraph is entered. Select this option if you want defined next styles
to be applied.

CSS Class/CSS Style: Enter the CSS class and style for the style sheet here. You can find an in-
troduction to this here.
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Creating a new style sheet / Styles for Links tab

The Properties – Style Sheet window, Styles for Links tab

Hyperlink to Website: In the box, enter the text style that is to be applied automatically when a hy-
perlink to a website is inserted. If a hyperlink to a website is inserted in the text, the program checks
whether the text style entered exists in the current paragraph style. If it does, the markup will be
formatted in the respective text style. If no text style has been entered or the text style entered does
not exist in the paragraph style, the markup will be formatted in the style of the current cursor posi-
tion.

Internal Link: In the box, enter the text style that is to be applied automatically when a hyperlink to
another object is inserted. If a hyperlink to another object is inserted in the text, the program checks
whether the text style entered exists in the current paragraph style. If it does, the new markup will be
formatted in the respective text style. If no text style has been entered or the text style entered does
not exist in the paragraph style, the markup will be formatted in the style of the current cursor posi-
tion.

Hyperlink to Text Anchor: In the box, enter the text style that is to be applied automatically when a
text anchor is inserted. If a text anchor is inserted in the text, the program checks whether the text
style entered exists in the current paragraph style. If it does, the markup will be formatted in the re-
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spective text style. If no text style has been entered or the text style entered does not exist in the
paragraph style, the markup will be formatted in the style of the current cursor position.

Creating a new style sheet / Styles for Footnotes tab

The Properties – Style Sheet window, Styles for Footnotes tab

A footnote consists of three elements that can be formatted separately:

· Reference to the footnote in the text

· Footnote paragraph at the end of the text

· Footnote numbering in the footnote paragraph

Text Style Reference to Footnote: Enter the text style with which the reference to the footnote in
the text is to be formatted. This text style must be part of the paragraph style used to format the
paragraph containing the footnote.

Paragraph Style Footnote: Enter the paragraph style with which the footnote text is to be format-
ted.

Text Style Numbering: Enter the text style with which the footnote numbering in the footnote para-
graph is to be formatted. This text style must be included in the paragraph style of the footnote.
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When a footnote is inserted, the defined styles will be automatically assigned to the components of
the footnote.

Creating a new style sheet / Attributes tab

The Properties – Style Sheet window, Attributes tab.

In this tab, you can enter the HTML tags, the CSS class, and the CSS style for superscript, sub-
script, underline, and underline words.

Click the [OK] button to create the style sheet.

Editing a style sheet

You can edit an existing style sheet by right-clicking the style sheet and selecting Properties... from
the drop-down menu. Make your changes and confirm with [OK].
The paragraph and text styles contained in the style sheets can be edited in the same way.
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Creating styles
The previously created style sheet so far contains only one predefined style, the "body text". Other
formats necessary for an article, such as "Title", "Leader", "Subtitle", etc., still need to be created.

There are several possibilities for this:

Create paragraph style by input

In the structure tree of the library, select the style sheet to which you want to add a paragraph style
and choose New Paragraph Style... from the File menu or the context menu.

The New Paragraph Style menu item in the context menu of a style sheet group

The Properties - Paragraph window opens on the Paragraph tab
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Paragraph tab

The Paragraph tab

Name: Here you assign a name for the new paragraph style.

Next style: Here you can specify a paragraph style that will automatically be applied to the follow-
ing paragraph when you enter text after entering the end of a paragraph. Select the desired style
from the drop-down list. Make no selection if no style change is to take place.

First text style: Here you can specify a text style to be applied to the first paragraph with this para-
graph style.

Alignment

Left: All lines of a paragraph will be aligned to the left edge of the frame or the column or to the
left text indent.

Centered: All lines of a paragraph are center-aligned.

Right: All lines of a paragraph are aligned at the right edge of the frame or the column or at the
right text indent.

Justified: All lines of a paragraph are aligned to the left and right frame or column edges or to
the left and right text indents.

Last line: Specify here how the last line of a paragraph should be aligned.

Leading: Enter the line leading. Line leading is the distance between the type lines and affects all
lines in a paragraph.

First line: Use this value to set the line spacing of the first paragraph line different from the line
spacing.
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Space before: To insert an additional spacing before the current paragraph, enter the desired
value. The space between two paragraphs is the sum of the leading and the additionally entered
value. 

After: To insert additional spacing after the current paragraph, enter the desired value. The space
between two paragraphs is the sum of the leading and the additionally entered values Space Be-
fore and Space After.

Indent first line: The first line of a paragraph can be indent from the left edge of the sentence or
from the left indent, independent of the other lines. Enter the distance from the left indent to the be-
ginning of the first line of text. If the value is positive, the first line starts to the right of the left indent.
To create a hanging indent, where the first line starts to the left of the left indent, enter a negative
value in the input field.

Left indent: In the first input field, enter the distance by which the left edge of a paragraph should
be indent from the left edge of a column, text frame, or text path. In the second input field, enter the
number of lines to which the left indent should be applied. If you do not enter a value, the left indent
will be applied to all lines of a paragraph.

Right indent: In the first input field, enter the distance by which the right edge of a paragraph is to
be indent from the right edge of a column, text frame, or text path. In the second input field, enter
the number of lines to which the right indent should be applied. If you do not enter a value, the right
indent will be applied to all lines of a paragraph.

Block: Select from the drop-down list the block type in which text marked with this style should be
placed.

Structure Level: From the drop-down list, choose the structure level to which text marked with this
format should belong.

Baseline Grid: Check one of these options to turn baseline grid alignment on or off.
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Rules tab

The Rules tab

Rule above: Here you specify whether a line should be inserted before the paragraph. For a para-
graph line at the top, the line thickness always builds up upwards from the baseline of the first line.

Weight: Enter the weight of the paragraph line.

Style: Use the drop-down list to select one of the defined line styles.

All lines: If this option is checked, the line will be inserted in all lines of the paragraph.

Color: Select a color from the drop-down list and set the tonal tint and the opacity.

Offset: Enter an offset of the paragraph line, starting from the baseline of the first (Rule above) or
last (Rule below) line of the paragraph. Positive values move the paragraph line down from the
baseline, negative values move the paragraph line up from the baseline. With the default value "0"
the line is exactly on the baseline of the first or last paragraph line.

Length: Use this to specify whether the paragraph line fills the entire space between indents or ad-
justs to the actual text length. Select the Indent option to make the line fit the indents. Select the
Text option to make the line fit the actual text length.

Indent left: To create a space between the paragraph line and the left edge of the text, enter a
value in this field. Positive values move the starting point of the paragraph line to the right, negative
values to the left. The indent is added to the text indent defined in Paragraph > Left Indent.

Indent Right: To create a space between the paragraph line and the right text edge, enter a value
in this field. Positive values move the end point of the line from the right edge of the sentence to the
left, negative values to the right. The indent is added to the text indent defined in Paragraph > Right
Indent.
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Rule below: Here you specify whether a line should be inserted after the paragraph. With a para-
graph line at the bottom, the line weight builds up from the baseline of the last line downwards.

Background Tab

The Background tab.

Top Edge: Select the position of the top edge of the color area: Leading, Ascender, Cap height, Ac-
cented Char height, Lower case height, Text height or Baseline.

Bottom Edge: Specify the position of the bottom edge of the color area: Baseline or Descender.

Width: Specify the width of the color area: Indent, Text or Column. 
Selecting Column extends the color area across the entire text column. Selecting Text extends the
color area across the text only.

Background: Choose a color for the color area.

Tint: Specify the value for the color tone.

Opacity: Specify the value for the opacity.

Inset Top: Specify the value you want the color area to extend beyond the top edge.

Bottom: Specify the value you want the color area to extend beyond the bottom edge.

Left: Specify the value you want the color area to extend beyond the left edge.

Right: Specify the value you want the color area to extend beyond the right edge.

Corner Radius and Corner Shape: Choose a size and a shape for the corners. You can select a
different size and shape for each of the four corners.

Clip to frame edges: Select this option to crop the color area at the edges of the frame.
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Do not print or export: Select this option to have the background area ignored when the document
is printed or exported.

Continue identical backgrounds: Seamlessly continued backgrounds with identical settings.
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Drop Cap tab

The Drop Cap tab

Lines: Enter the number of lines over which the drop cap should span.

Characters: Enter the number of characters to be defined as the drop cap.

Spacing: Use the value entered to increase the spacing of the text from the drop cap .

Font/Style: In these selection lists, you can define a font for the drop cap that differs from the
standard font for this paragraph.

Scale horizontal/vertical: Here you determine whether the drop cap should be scaled. Positive >
100% as well as negative values < 100% are possible.

Color: Here you select a color from the drop-down list and set the tint and opacity.
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Tabs tab

The Tabs tab

Fixed positions/Default width: If this option is activated, a tab stop will be inserted in the entered
default width every time a tab is entered.

Position: Enter a position for the tab here.

Alignment: Enter the alignment for the tab here. Available options are left, center, right and
decimal.

Leader: The character selected here will be used to fill the space between the text and the tab.

· Decimal mark: Decimal numbers placed one below the other at this tab position will be aligned
with the character entered here, such as a decimal comma. The input field is only active if
"Decimal" is selected in the Alignment field.

Styles Tab/Leader: In these selection lists, you can specify text styling for the tab and the leader
that differs from the standard styling for this paragraph.

To create a freely defined tab, specify the position and alignment and click the [Insert] button to add
the tab to the list. Alternatively, first select the alignment and click in the ruler at the desired posi-
tion.

To change an already defined tab, select it in the list, edit the settings and press the [Change] but-
ton. Alternatively, after marking the tab in the list, you can drag the tab symbol in the ruler to the de-
sired position.

To delete a tab that has already been defined, select it in the list and press the [Delete] button.
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Break-Options tab

In the Break tab, you control paragraph sticking together, optimization, flush zone, and alignment of
one-word lines in justified text, and you specify the maximum number of consecutive hyphens.

The Break-Options tab

Keep with the previous paragraph: Check this option if you want the paragraph to be in a text
frame with the previous paragraph.

Keep with next paragraph: Check this option if you want the paragraph to be in a text frame with
the following paragraph. This is useful, for example, with subheadings in body text, so that a sub-
heading does not stand alone at the end of a column, but automatically jumps to the next column if
the following paragraph (or the minimum number of lines defined in the next item) does not fit in the
previous column.

Keep lines together:

All lines in paragraph: activate this option if the paragraph should always be in a text frame as
a whole.

At start/At end: Define here how many lines of the paragraph should be at least at the end or
beginning of a column.

Start paragraph: Using this option, you can specify at which position of your layout a paragraph
should be placed. The following options are available:

Default: Select this option if the paragraph can be anywhere on the layout.

Next column: Select this option to cause a column jump,

Next frame: Select this option to cause a frame jump.
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Next page: Select this option to cause a jump to a text frame on the next page.

Next even page: Select this option to cause a jump into a text frame on the next even page.

Next odd page: Select this option to jump to a text frame on the next odd page.

Go back to previous block: When this option is selected, image lines, for example, can be integ-
rated into the body text at the point where the images are in the text flow. This optimizes the digital
utilization of the articles.

Optimize justification: In the text properties, the word and text spacing is defined in the Spacing
tab, which determines the size of the spaces between words in justified and flush typesetting. Via
the selection list Optimize justification you now have the possibility to determine whether the op-
timal word spacing should be achieved by creating more separations or whether the word spacing
should be extended or reduced before a separation takes place.

Flush zone: Unattractive tight output lines at paragraph ends can be prevented via this option. Out-
going lines that exceed the entered range will be expanded to full line width.

Single-word justification: The selection you make controls the behavior of a word when it is the
only word on a line, which is especially common when flowing around images. You have the option
via the selection to place the single word left, center, right or justified width if you choose the justi-
fied option.

Hyphenation limit: Enter the maximum number of hyphenations allowed in succession.

Hyphenation zone: Use this value to control the line drop for flushed typesetting. As soon as a
word reaches the hyphenation zone, hyphenation is attempted or, if hyphenation is deactivated, the
entire word is taken into the following line. The larger this value is, the more the line ends flutter.



Working methods   Working with style sheetsMarkStein Publisher Manual

© 2022 MarkStein Software GmbH 233

 Bullets & Numbering tab

The Bullets & Numbering tab

Bullets & Numbering: Select List, Numbered list or Outline. You activate a list by selecting the
appropriate symbol. 
The choices for enumeration are Arabic numbers, small and large Roman numbers, Capitals and
small letters.

Outline: Here you define a new enumeration level, which can be equipped with other attributes. 

Select Glyphs: If you want to create a list with eye-catching glyphs, select one or more glyphs from
the Glyphs menu and activate the list by clicking on the icon.

Continue Numbering: If you want a numbered list to continue consecutively after paragraphs with
normal text, activate this option.

Restart at: Here you can start a new count within a bulleted list. Enter here the value with which the
new count should start.

Text style: Select here the text style in which the enumeration or list character should be formatted.

Indent bullet: Enter the value you want the bullet or list character to be indented from the left record
edge.

Alignment: for list or bullet character: Specifies the alignment of the bullet or list character. Left:
inside the text frame on the left frame edge, Right: outside the text frame on the left frame edge,
Centered: centered on the left frame edge.

Indent text: Enter the value here that the bulleted or numbered list text should be indented from the
left edge of the frame or column.
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Conditional Text tab

Here you determine which text usages are intended for this paragraph style.

The Conditional Text tab

Select one or more check boxes to specify the text usage for this paragraph style.
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HTML tab

Here you control the linking of this style with HTML tags and CSS for export as EPUB or HTML.

The HTML tab

Block element: Select the block element with which the exported text is to be tagged. 

CSS class: Enter the CSS class with which the exported text is to be tagged.

CSS Style: Enter here the CCS style with which the exported text should be tagged.
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Edit and create paragraph styles in layout

To use this function, first design a text with the necessary paragraph styles in the layout. To do this,
the style group to which paragraph styles are to be added or whose paragraph styles are to be
changed must be selected in the Styles palette. 

In the example, a new style sheet was created and a story was designed with three paragraph
styles.

Example text with three paragraph styles

Overwrite paragraph style

Place the text cursor in the paragraph whose style you want to be adopted and select the menu item
Overwrite paragraph style... in the Style menu.
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The menu item Overwrite paragraph style

The Properties - Paragraph window described above, Paragraph tab opens. All the settings you
made in the layout are already entered here and on the other tabs.

The Properties - Paragraph window. Since in this example the automatically generated paragraph style Body_text is to
be modified, all entries can be accepted.

Click the [OK] button to apply the style.

Overwrite text style

If, in addition to the paragraph properties, text properties have also been changed, these must still
be adopted in the text style. 
Place the text cursor in a text passage whose formatting you want to adopt and select the menu
item Overwrite text style... in the Style menu.
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The Menu item Overwrite text style...

The Properties - Font window, Font tab opens. All the settings you made in the layout are already
entered here and on the other tabs.

The Properties - Font window, Font tab

Click the [OK] button to apply the style.

Create paragraph style

Place the text cursor in the paragraph whose style you want to create and select New paragraph
style... from the Style menu.
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The Menu item New paragraph style...

The Properties - Paragraph window described above, Paragraph tab opens. All the settings you
made in the layout are already entered here and on the other tabs.However, since this is a new
style, you still need to specify the name and block assignment.

Click the [OK] button to create the style.

Create text style

To create a text style that differs from the standard font, for example "bold" or "italic", select a text
area and change the font to the desired variant. 
Place the text cursor in the area whose formatting you want to create and choose New text style...
from the Style menu.

The Menu item New text style...

The Properties - Font window described above, Font tab opens. Settings that you have made in
the layout are already entered here and on the other tabs. 
Since this is a new style, you still need to assign the name. 

Click the [OK] button to create the style.
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Transferring new or changed styles to the active or other libraries

How to do this is described in detail in the Transferring library contents section of this manual.
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Working with book files

On the next few pages, you will find information about using the book function in MarkStein Pub-
lisher Workgroup Edition.
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What is a book file?
If a publication consists of multiple files, these can be compiled in a “book.” That means that in our
view, a book is a collection of documents.

A book is a special file in MarkStein Publisher Workgroup Edition. The content of a book file con-
sists solely of references to the individual files in a catalog or book that are part of the overall docu-
ment.

A particularly practical feature of a book is the fact that you can print or export documents both indi-
vidually and as a whole, separate from the book file.

You assign the individual chapters (documents) to the book file and MarkStein Publisher Work-
group Edition takes care of all the technical aspects, such as continuous page numbering or creat-
ing a table of contents or a register.
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Creating a book file

Creating a new book file

1. To create a new book, click the New button on the home screen to switch to the window of the
same name.

2. Double-click the New Book icon.

3. The New Book window will then be shown.

4. Switch to the directory in which you want to save the book file and enter the name of the book in
the File Name box.

Double-clicking the New Book button opens the New Book window. The saving location and file name of the new book
are defined here.

5. To save the book file, click [Save].
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Saving the new book file in the selected directory.

6. After saving, the book file will be shown as a new tab in the working window. The tab is still
empty and contains the book name assigned as the tab name.

Empty book document
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Adding documents
1. To add a file to the book, click Add.

2. Switch to the directory that contains the files you want to add.

3. Select the file you want to add and click Open. You can also add multiple files to a book simul-
taneously.

Adding a file to the current book

4. Once added, the file will be shown in the list in the Book window.
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The file added is shown in the book list

5. You can add as many documents to a book as you like.
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Book file with multiple added files
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Synchronizing book documents
After adding or moving documents, click the Synchronize Book button to adjust the page number-
ing to the new order.
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Numbering (pages, chapters, sections)
This section deals with numbering document pages within a book. Numbering pages of individual
documents is described in the Options for Documents section.

When a document is added to a book, the Book function in MarkStein Publisher Workgroup Edition
takes control of numbering the pages in the book. The previous item First Page: in the Document
Properties is overwritten with the current value, which adapts to the position of the document in the
book.

Using the Properties button, you can define the start value with which you want the page number-
ing to start.

You can deactivate individual documents in the book using the checkbox in the Active column. De-
activated documents are not included in the pagination and the output.

Documents added to the book; the First Page item adapts automatically to the position in the book.
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Properties – Document “Chapter_3”, left opened via the Book function; right opened outside the Book function.

Hint: The pagination options selected under File > Document > Pagination are not overwritten by
the Book function. On these pages, you need to adjust the page numbering manually when you add
a file to a book or move it within a book.
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Creating a register
This function only exists in MarkStein Publisher Workgroup Edition.

The Book function also offers the option of creating a register, for example for keywords or names.
To do this, the terms to be added to the register must be marked with a register mark.

Entering register terms

To enter a term into the relevant register, highlight the word (or words), go to the Insert menu and
select Register...

The Insert Register window will open. The highlighted word appears automatically in the Term:
box. You can also make changes in this box which will be taken into account in the created register.

The Insert Register window with terms already added to the register.

Autotext: Register entries can also be generated dynamically from the text of a story. To do this,
highlight the text that you want to add as a register term and select the command Insert > Re-
gister.... In the Insert Register dialog window, select the Autotext option and click the [Add] but-
ton. The register entry will now be shown underlined in blue in the text, if you have activated the
Mark option in the View menu. The advantage of using this method is that the register entry
changes automatically when you edit the underlined text.

Page: Select this option if you want only the page on which the register term is located to be shown
after the register term in the register.

Area: Select this option if you want an abbreviation for subsequent pages to be shown after the
page number in the register. You can select the relevant abbreviation from the drop-down list.

Reference: Select this option if you want to enter a cross-reference to the selected register entry.

Clicking the [Add] button adds the term to the register. You can use the [Other...] button to add all
the places the term appears in the text link to the register.

When you click the [Add] button, the window closes automatically and the register entries are
marked with a purple flag. Register entries that have been given the “Autotext” attribute are also un-
derlined in purple.
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Depiction of register entries in the Layout view

Editing a register

To edit existing register entries, position the cursor in front of the first letter of the term and select
the command Edit > Edit Markers > Edit Register... or double-click the marker shown in the text.

The Edit Register window will open. The highlighted word appears automatically in the Term: box.

The Edit Register window.

Using the [Change] button, edited entries can be applied to the register in the Term: box. The but-
ton only becomes active after text has been entered.

The [Delete] button removes selected terms from the register.

Using [Find/Replace], you can make changes to a term in multiple locations simultaneously.

The [Go To] button takes you to the location of the term in the text link.

Creating a register

Once you have marked all the text that you want to include in the register, you can create the re-
gister. To create a register for a single document, select the command File > Create Register...

The Create Register window will open.
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The Create Register window

Target: Select whether the table of contents should be created as a text file or a story here. If you
choose story, you can assign a previously-defined paragraph format while creating the register. The
Cursor Position option is only available if the cursor is located in a text frame and inserts the re-
gister there.

Line Separator: Here you can select which separator should be inserted at the line end in the
entries.

Separator: Here you can select the separator that you want inserted between the text and the page
number.

Alphabet:

Create Alphabet: Selecting this option creates a title line for the entries, consisting of the first letters of
the entries.

Individual Paragraph Style for First Letter Entry: Selecting this option enables you to format the re-
gister as a story when creating a register. To do this, select the “Templates” library and the “Register
Style” style sheet when creating the story. This style sheet contains all the styles needed for a register.
You can also copy the style sheet from the “Templates” library and paste it in your preferred library.

Hierarchy: By selecting Create Hierarchy, you can define a hierarchy in the register, for example in
order to place city names below the country in a hierarchical way. To do this, when adding a place
name to a register, you must place the country name in front of it, separated with a vertical line
(Windows: <AltGr> + <, Mac: <Alt> + 7).
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The name of the country is placed in front of the city name in order to create a hierarchy.

This figure shows the result in the formatted story

Page Number:

First Page of Link: When you select this option, the first page of the link is stated as the page
number.

Exact Position of Register Term: The positions are stated with the page number.

Use Numbering: When this option is selected, the actual pagination of the page, e.g. a specially
created pagination in Roman numerals, will be used to show the page number in the register. You
can find a description of this here. If the option is not selected, the page numbers will be listed in
the register in serial Arabic numerals, starting from the first page of the book or document. You can
define the starting value for the page numbering in a book in the Book window, using the Properties
button, which can be found via File > Document > Properties.

Once you have defined the options, click [OK]. The Save dialog or the dialog window for creating a
story will open.
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The Export dialog when the File option is selected

The New Story dialog when the Story option is selected.

If you have exported as a file, you can now place the register on the desired page and edit it. If the
register was created as a story, this will open automatically and can be edited immediately. Placing
a story is described here.
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Creating a table of contents
This function only exists in MarkStein Publisher Workgroup Edition.

To be able to create a table of contents automatically, you first need to assign a structure level to
the style in the book content for which you want to use the table of contents. You can define this in
the Properties tab of the paragraph style or in the inspector Text > Styles.

Once you have assigned a structure level to all the text passages in the book documents that are to
be used for the table of contents, go to the Book window and click Table of Contents...

The Create Table of Contents window will open.

Window Create Table of Contents

Target: Here, select whether the table of contents should be created as a text file or a story. If you
choose story, you can assign a previously-defined paragraph format while creating the table of con-
tents.

Levels: Here you can select whether all outline levels should be included, or only a selection. If you
choose Selection, enter the outline levels you want, separated by commas.

Separator: Here you can select the separator that you want inserted between the text and the page
number.

Page Number on Front: If this box is checked, the page number will be at the start of the line; if
not, at the end.

Use Pagina: When this option is selected, the actual pagina of the page, e.g. a specially created
pagination in Roman numerals, will be used to show the page number in the table of contents. You
can find a description of this here. If the option is not selected, the page numbers will be listed in
the table of contents in serial Arabic numerals, starting from the first page of the book. You can
define the starting value for the page numbering in a book in the Book window, using the Properties
button.

Once you have defined the options, click [OK]. The Save dialog or the dialog window for creating a
story will open.
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The Export dialog when the File option is selected

New Story dialog when the Story option is selected

Following the export, you can place the table of contents on the desired page and edit it. If the table
of contents was created as a story, this will open automatically and can be edited immediately. Pla-
cing a story is described here.
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Printing and exporting

The next few pages provide information on printing and the options for exporting a document.

The File menu offers separate items for exporting in PDF and EPUB formats; you can select the
other image and exchange formats in the Export dialog window.

The Export dialog window, in which you can define the saving location and export format

Export formats

Print file: Adobe PDF

Image formats

.jpeg

.eps

.tiff

.png

.gif

.svg

When exporting a file as one of the image formats listed, you can choose whether you want to save
the sheet, the page or the current selection in the selected format.

You also have the option of defining the scaling and resolution of the object to be exported, as well
as the quality and/or color model in some formats.
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The Export dialog window for .jpeg and .tiff

Exchange formats

.mxs (Tango page element)

.idml (InDesign Markup Language)

When exporting a file in the InDesign Markup Language format IDML, a “Links” folder is created to
store the placed images in addition to the file.

.idms (InDesign Snippet)



Working methods   Printing and exportingMarkStein Publisher Manual

© 2022 MarkStein Software GmbH 260

Printing a document
On the next few pages, we provide you with an overview of the print functions in MarkStein Pub-
lisher.

Printing – General tab
In the General tab, you can define print parameters such as the page range and number of copies.

General tab in the Print dialog window

Here you can define the page range you want to print.

All: Use this option if you want to print all pages of the document.

From: / To: To print a specific page range of your document, select this option and then enter the
first and last page you want to print in the boxes.

Selection: If you select the Selection option, only objects that are selected at the time of printing
will be printed.

Resize Pages to Selection: If you have selected individual or multiple objects, only the frames se-
lected at the time of printing will be printed in a PostScript file. The size of the page will be cropped
to the size of the rectangle surrounding the frame if your select the option Resize Pages to Selec-
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tion. The Resize Pages to Selection option can only be selected if you have selected the printer
driver “PostScript file” and the option “Color (Composite)” as the print mode in the Color tab.

Margin: If you have selected the option Resize Pages to Selection, you can enter an additional
value in the Margin box by which the surrounding rectangle will be expanded.

Copies: If you want to print multiple copies, enter the number of copies you want in the box.

Collate: The Collate option becomes active as soon as you enter more than one copy in the Cop-
ies box. If this option is selected, the document will be printed multiple times as whole copies.

Options

Output - Original/Thumbnails: Select the Original option to output the pages in the original view.
Select the Thumbnails option if you want to print multiple pages shrunk onto a single page. You
can define the number of pages you want to output on a single page in the Thumbnails tab.

Sequence - All Pages/Even Pages/Odd Pages: To print all the pages in the selected range, se-
lect All Pages. If you select the Even Pages option, only the even-numbered (i.e. left-side) pages
will be printed; if you select Odd Pages, only the odd (right-side) pages will be printed.

Spreads: If you select Spreads, pages that are opposite one another will be output together.

Blank Pages: If you also want to output pages that do not contain any objects, select the Blank
Pages option. If this option is not selected, blank pages will be ignored in the output, even if they
are selected in the page range to be printed.

Tile Pages: If the output format is smaller than the document size, multiple page sections will be
output if you select the Tile Pages option. The individual page sections are output overlapping and
can then be assembled to form a whole page.

New Print Job: If you select the per Page option, each page is sent to the printer individually or an
individual file is created for each page entered. The file names are created automatically and com-
prise the document name and the page number (P1, P2 etc.). The option per Color Plate becomes
active when you start a separate output. If you select this option, a separate print output is created
for every single color plate.

Preflight: Select this option if you want the files to be checked before the printing process. This
check results in the appearance of the Preflight window, in which incorrect objects are listed. The
most recent settings made in the Check Prior to Printing window are used for the current check. If
you want to continue the print process, go to the Check Prior to Printing - Print window and click
[Print]. To cancel the print process, click [Cancel].
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Printing – Setup tab
In the Setup tab, you can define the paper size, output direction, scaling and position of the docu-
ment on the selected paper size.

Setup tab in the Print dialog window

Paper 

Size: Use the Paper Size drop-down list to select the paper size. It contains all the paper sizes that
are saved in the selected printer description file. To define a user-defined paper size, select the
user-defined option and enter the width and height of the paper size.

Width: Shows the selected paper width.

Height: Shows the selected paper height.

Portrait: Choose this option if you want to output the pages without rotation.

Landscape: Choose this option if you want to rotate the output direction by 90°.
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Options

Scale: Enter the scale factor by which you want to increase or decrease the size of the output here.

Scale to Fit: Select this option if you want to increase or decrease the page size automatically to fit
the selected paper size.

Page Position: You can use this selection to define the position of the pages to be output relative
to the selected paper size.

Top Left: Select the Top Left option if you want to position the pages in the top left corner of the paper
size.

Center Horizontally: This option positions the output pages at the top of the page and centered hori-
zontally on the selected paper size.

Center Vertically: This option positions the output pages on the left-side of the page and centered ver-
tically on the selected paper size.

Centered: To position the pages in the center of the selected paper size, select Centered.
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Printing – Bleed & Marks tab
If the document contains bleed objects, define the bleed area on the Bleed / Marks tab page. 

Here you select the printer marks to be printed and specify whether normally non-printing elements
are to be printed as well.

Bleed & Marks tab in the Print dialog window

Use document bleed settings: Activate this option to use the bleed defined in the document.

Bleed: To override the bleed values specified when setting up the document, deactivate the Use
bleed from document option and enter the required bleed value under Bleed top, bottom, inside
and outside (for double page documents) or top, bottom, right and left (for single page docu-
ments). The button with the lock makes it easier to enter the same values. Enter the desired value
with the padlock symbol open and click on the padlock symbol. The value is then automatically
transferred to the connected field. If the symbol shows the closed lock, you also only have to enter
the value once.

Print Info: Enable this option to add the page information, separation label, output date and output
time at the top of the page.
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Orientation Marks: This option adds crosshairs outside the document format. Crosshairs are es-
pecially needed for colored documents where the individual color separations are manually moun-
ted on top of each other.

Crop Marks: This option adds horizontal and vertical fine lines at the distance you define in the
Crop Offset field.

Offset: Enter the distance between the trim marks and the final format.

Print visible grids and guides: By activating the options Column Grid, Baseline Grid, Guides,
Table Grid and/or Table Rulers you can output the corresponding grid. The lines are given the
color defined in the document.

Printing – Images tab
Use the Images tab to control the print output of the images placed in the document.

Images tab in the Print dialog window

Images

Print: Enable this option to print the images in full resolution.

Ignore: If you enable this option, the images will be omitted from the output.
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Placeholder: Select this option to print gray halftones instead of images.

Print Preview: If you activate this option, the images will be printed in the preview resolution (96
dpi).

Images with missing files

Ignore: If you select this option, images that do not have the original data will be omitted from the
output.

Placeholder: Select this option to output gray raster areas instead of the images where the original
data does not exist.

Print Preview: If you activate this option, the images will be printed in the preview resolution (96
dpi) if the original data is not present.

Crop images

Use this option to control whether the image data outside the image frame is included in the file
when creating a PostScript file. 

Yes: Activate this option so that all image data outside the image frame is not included in the file.

No: Activate this option if you want to include all image data, even those that are not visible, in the
file.

Automatic: Enter a percentage value in the input field from which the invisible image data should
be trimmed to the size of the stretched image frame.
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Printing – Thumbnails tab
This tab only becomes active if you have selected Thumbnails in the Options > Output section of
the General tab. Use this tab to control the output of multiple scaled-down pages on a single page.

Thumbnails tab in the Print dialog window

Grid

You can specify how many double pages are to be printed per sheet using the specifications in the
Grid area. You use the input fields to specify how many lines with how many double pages the prin-
tout is to be divided into.

Contents

Status view: If you activate this option, only the object and text frames in the corresponding status
colors are printed instead of the original data.

Boxes and Rulers: If you have activated the Status View option, box frames (frames without text
and image content) and line elements will also be output if this option is activated.
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Texts

Print: Activate this option to print the text frames created in the document in Layout mode.

Ignore: Activate this option to suppress the output of the text frames in print mode.

Placeholder: Activate this option to print colored areas instead of text. The color of the areas is se-
lected in Preferences > Layout > Color.

Image Preview

Print: Activate the Print option to print the picture frames created in the document in Layout mode.
If you activate this option, the images are printed in the preview resolution (96 dpi).

Ignore: Enable this option to suppress the output of the defined picture frames in thumbnail output.

Placeholder: Enable this option to print colored halftone areas instead of images. The color of the
areas is selected in Preferences > Layout > Color.
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Printing – Colors tab
Use the Colors tab to set the color output for printing, the screen frequency, the spot color output,
the overprint properties for white and black, and the trapping settings.

The settings on this tab depend on whether you are creating a composite output or a separated out-
put. You cannot define trapping settings for a composite output. However, the overprint or knockout
properties of an object are applied to composite output.

Colors tab in the Print dialog window

Output: Use the selection list to define the output mode.

Color (Composite): Select this option to print the document as a composite.

Separations: Select this option to output the individual color separations.

N-up: Here you determine how often each separation is printed.

Screen Frequency: When printing on desktop laser printers and in particular on imagesetters, the
screen frequency must also be taken into account. This is the number of halftone cells per inch with
which grayscale images and color separations are printed. Enter the screen ruling in lpi (lines per inch).

Note: The default screen frequencies come from the printer driver. Normally you can ignore them.
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Color: All colors defined in the document are displayed in the list. No changes can be made to a
composite output. In the Separations output mode, you can select a color. The colors intended for
output are marked by a check mark.

Screen Angle: When printing halftones, the individual colors are transferred to the paper in a grid
pattern. Each color is screened at a different angle so that the individual halftone dots do not lie on
top of each other. The Screen Angles list shows the current angles of the individual colors. These
depend on the selected printer description file (PPD).

Automatic Amount: Here you enter the trapping width for a separated output. The automatic value
is used for trapping or underfilling whenever a foreground object is completely on a background. A
value between 0.05 and 0.08 mm is usually used as the trapping width.

Indeterminate Background: If a foreground object lies over several different backgrounds, the
trapping value defined here is used.

Ignore White Background: To prevent the color of the paper, which is normally white, from being
considered as its own color and to include this color in the under/over trapping calculation for a
foreground object, select the Ignore White Background option.

Overfill CMYK: If you activate this option, the superimposed objects will not be compared to each
other as a whole (in terms of color), but the individual color separations will be compared in terms
of their tonal values. Each trapping or underfill is made separately for each separation and is
trapped or underfilled with half the trapping value.

Overprint Black: This value applies to all objects defined with the color “Black”. If the tonal value of
the object color is higher than the threshold value entered here, the object will overprint. If the tonal
value is lower, the object is omitted, and if the output is separated, the object is overfilled or under-
filled with the defined trapping values.

Overprint White: By default, the color “White” is omitted on underlying objects. Activate this option
so that the color white is always overprinted.
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Printing – PostScript tab

Setup

In the PostScript - Setup tab, you define the PostScript options for printing and the settings for
generating PostScript files for PDF generation.

PostScript - Setup tab in the Print dialog window

PostScript

Binary Image Data: Meanwhile all operating systems are able to process binary data, so you
should activate this option. If you deactivate this option, the image data will be saved in ASCII
format in the PostScript file. Binary data is much more compact than data in ASCII format.

Embed fonts: Activate this option to embed the fonts used in the document in the PostScript file.

PDF from PostScript

Export to PDF with Joboptions: PostScript files are converted to PDF using the supplied Adobe
PDF Converter (only MarkStein Publisher Professional Edition andMarkStein Publisher Workgroup
Edition), which is largely identical to Adobe Acrobat Distiller. If you activate this option, MarkStein
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Publisher will automatically create a PDF from the PostScript data stream without the Adobe
Acrobat Distiller having to be installed on the workstation. To select the conversion settings, click
on the button with the three dots and select the desired job option file.

You can create your own Job Options files using the Adobe Acrobat Distiller (sold separately) and
select the Tools > Job Options... command. in the corresponding folder.

Print Trimbox: If you create a PostScript file for PDF creation using the Adobe Acrobat Distiller
app, activate this option so that the final format frame is transferred to the PDF file. The final format
frame is required to create PDF/X-compliant PDF documents and for further processing in prepress
if PDF documents are imposed digitally.

In Front: Activate this option to place the trimbox in front of the page objects.

In Back: Activate this option to place the trimbox behind the page objects.

Transfer Sticky Notes: Activate this option if you have created notes in the document that are to be
included in the PDF file.

Transfer Hyperlinks: Activate this option if you have created hyperlinks (cross-references) for nav-
igation in the document that are to be transferred to the PDF file.

Create Bookmarks: Activate this option if you want to bookmark paragraphs defined with an outline
level in the PDF file.

Create articles: Activate this option if you want the frames linked in MarkStein Publisher to be
transferred to the PDF as articles. The articles can be called up in Adobe Reader via the Articles
navigation window. The linked text frames form the article reading flow of the article.

Flatten Transparency

Since PDF version 1.4, native transparencies can be transferred to a PDF document and displayed
correctly during a PDF export.

Transparent objects are created, for example, by using soft edges and drop shadows or by chan-
ging the opacity of an object.

Unlike PDF, PostScript knows only opaque objects and no transparencies, which is why transpar-
encies must always be recalculated in PostScript output. During recalculation, transparency reduc-
tion, the transparency functions are removed with the aim of preserving the optical appearance of
the file. Transparency reduction means that the transparent areas of a page must be divided into
vector- and/or pixel-based objects when printing, which themselves are no longer transparent. Con-
version from transparent to non-transparent objects can be controlled in the Flatten transparency
area by specifying user-defined parameters.

Automatic/Off/Force: Use this selection to specify whether a transparency flattening is to be per-
formed on the output. If you select the Automatic option, the transparency flattening will only be ap-
plied to pages that contain transparent objects. If you select the Force option, transparency flatten-
ing will be applied to all pages, regardless of whether transparencies are present on the individual
pages or not. If you select Off, there is no transparency flattening and the transparencies are re-
moved for output and the objects are output as opaque objects.

Pixel Vector Balance: The specification in this input field determines how transparent objects are
to be converted for PostScript output. If you enter the value 0, all objects are converted to bitmap
objects, regardless of whether they contain transparencies or are overlapped by transparent ob-
jects. This conversion is independent of whether they were originally text, vector, or pixel objects.
The higher the set value is (you can enter values from 0 to 100), the more objects are retained or
converted as vector objects during transparency flattening and only very complex transparent areas
are rasterized.
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Resolution of Text/Line Art: In this input field you enter the resolution for text and vector objects
that are to be converted into pixel objects – i.e. images – during transparency flattening. As resolu-
tion you should set the value that you also use for the output of 1-bit bitmap images.

Gradient Resolution: The resolution for gradients that have to be flattened and converted into pixel
objects during conversion can be specified in that field. Select a value here that corresponds to the
resolution you use for outputting color or grayscale images.

The following applies to both resolution settings: The higher the selected resolution, the better the
quality, but the longer you need for the output or for the direct flattening of transparent objects.

Convert All Text To Outlines: If this option is activated, all text on a page – regardless of whether
it is transparent objects or affected objects – is converted to vectors. This only applies to pages that
contain at least one transparent object. Pages that do not contain transparent objects remain unaf-
fected by the transparency reduction.

Convert All Strokes To Outlines: If this option is activated, all strokes, i.e. all line objects – re-
gardless of whether they are transparent lines or not – are converted to paths. The conversion only
affects lines on pages that contain at least one transparent object.

Clip Complex Regions: When flattening, all transparent objects must be removed and individual
overlapping objects must be created from them. Each object is given its own color, which is created
using the color management settings. The aim is to keep the appearance of the objects true to the
original so that the font remains as font and the vector object as vector object. In some cases, how-
ever, fonts and vector objects may have to be rasterized. The Crop complex areas option controls
the way in which the individual transparent areas are converted into independent objects. Activate
this option to avoid visible transitions at points where vector graphics and pixel images adjoin each
other. If this option is not activated, visible transitions may occur if one part of an object is rasterized
and the other part remains a vector object.

Convert Colors To CMYK: This option specifies that after the transparency reduction all colors
are present in the Device CMYK color space, i.e. the file is decalibrated so that no ICC profiles are
contained in the resulting PDF document. This option should always be activated when creating
printable PDF documents.

Preserve Overprint: To retain the original overprint settings of the objects in the document, activ-
ate this option. If you disable this option, all objects originally set to Overprint will be set to Omit and
new objects will be created in the areas where the overprinting objects overlap, even if the objects
are not overlaid by transparent objects.

Left: If the option Keep overprint settings is activated, the original overprint settings and the number of objects in the
resulting PDF document are retained. Right: If this option is turned off, the appearance of the objects does not change.
However, a new object has been created where the overprinting objects overlap.
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Processing of placed PDF Files

Use the PostScript - Processing of Placed PDF Files tab to specify the processing of PDF files
placed in the document.

PostScript - Processing of Placed PDF Files tab in the Print dialog window

PostScript Level: Select the PostScript level for converting placed PDF files. Usually select the
value “3”.

Image Resolution: Enter the resolution for the conversion of line images here. As resolution you
should set the value that you also use for the output of 1-bit bitmap images.

Color Gradient Resolution: Enter the resolution for the conversion of color and grayscale images
here.

Binary Image Data: All operating systems are now able to process binary data, so you should ac-
tivate this option. If you deactivate this option, the image data will be saved in ASCII format in the
PostScript file. Binary data is much more compact than data in ASCII format.

Disable automatic decalibration of placed PDF files: During output, the ICC profiles contained in
a placed PDF file are ignored by default. Enable this option if you do not want to perform the decal-
ibration.
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Embed Fonts: Select the fonts to be embedded.

Convert True Type to Type1: If you activate this option, True Type fonts will be converted to
Type1 fonts (PostScript fonts).

Flatten Transparency

Selecting the layers for print or export
In a document with multiple layers, you can define which of the layers are to be included in a print or
export by hiding or showing them. 
Click on the eye icon in front of the name of the layer to show or hide it.
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Example of a document with multiple layers; the German text is shown for printing in the top image, the English text in
the bottom image.

Alternatively, in the Properties window for a layer, you can lock that layer or allow printing.
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Allow printing of a layer in the Properties dialog of the layer
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Setting up a print preset
If you frequently repeat print orders, you can set up and save a print preset.

Proceed as follows:

1. Go to the Extras menu and select the command Print Presets... 

2. To create a new print preset, click New.

3. Give the print preset you want to create a name.

4. Select the target printer from the menu that appears.

5. Define all the parameters you need for the print order.

6. Click [OK] to save the print preset.

The print preset will now be available in the Print dialog.



Working methods   Printing and exportingMarkStein Publisher Manual

© 2022 MarkStein Software GmbH 279

Editing a print preset
To modify an existing print preset, go to the Extras menu, select the command Print Presets..., se-
lect the print preset you want to edit and click [Edit].

Once you have made the changes, click [OK] to complete the process.
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Printing a book

Printing the whole book

Open a book file and, in the book window, click Print...

Overview window of the opened book file

Select a print preset or make the print settings manually. Start the print job by clicking [OK}.

Printing an individual file from a book

Open the file you want to print by double-clicking the file name and start the print job under File >
Print...
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Export as PDF
Using the integrated Adobe PDF Library, MarkStein Publisher Professional Edition and MarkStein
Publisher Workgroup Edition offer the possibility to export a document directly into the PDF format
(Portable Document Format). With PDF export, all hyperlinks, notes and display options defined in
the document can be transferred to the PDF document. (Not available in MarkStein Publisher
Standard Edition)

PDF Export Basics

Use the Export PDF command to create PDF documents that can be digitally redistributed or used
for the Internet. You can also use this function to create PDF documents suitable for prepress. 

When exporting PDF files, please note that you must select a job option file in the Images tab to
export EPS files. This job option file is used to convert the contained EPS images and/or convert
them to the RGB color space. You can create your own joboptions files using Adobe Acrobat Distil-
ler, which you can purchase separately.

Exporting documents into PDF format

Proceed as follows to export a MarkStein Publisher document as a PDF:

1. Select File > Export or File > Export PDF.

2. In the Export window, select the destination folder where you want to save the PDF.

3. Choose the option Adobe PDF (*.pdf). The default file name is the name of the MarkStein Pub-
lisher file, which you can change.

The Export window defines the destination folder, the file name and the file type to be exported.

4. Click the [Save] button. If you want to cancel the operation, click the Cancel button.

5. When you click the Save button, the PDF Export dialog box appears, divided into nine tabs:
Output, Acrobat, Security, Images, Multimedia, Transparency, Margin / Bleed, Water-
mark, and Color. Each of these tabs contains several parameters that affect the output pro-
cess.
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6. After you have made all the settings, click [OK] to create the PDF document. Click the [Cancel]
button to cancel the process.

7. If you have activated either the option Password to open the document or Restriction to edit
and print the document on the Security tab, the Confirm password dialog box appears after
you click [OK], in which you must re-enter the password to confirm it.

If a password has been defined in the Security tab, it must be entered again in the Confirm Password window.
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PDF Export Options Output Tab

Output tab of the PDF export options

Section

All: Select this option if you want to print all pages of the document.

Page(s) from / to: To output a specific page range of your document, enable this option. Then
enter the first and the last page to be output in the input fields.

Selection: If you activate this option, only selected elements are output. The page size of the PDF
corresponds to that of the MarkStein Publisher document.

Crop to selection: If you activate this option, the PDF page size will be cropped to the size of the rect-
angle surrounding the selected frame(s).

Margin: If you have activated the Crop to selection option, you can enter a value in the Border input
field to extend the surrounding rectangle.
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Options

PDF/X: Use the selection list to specify in which PDF/X standard the PDF is to be created. You can
choose between PDF/X-1a, PDF/X-3 and PDF/X-4.

If a standard is selected, it is mandatory to select an output profile (Output Intent); the compatibil-
ity is determined by the standard and cannot be edited. By selecting [None] you deactivate the
standardization and can freely select the compatibility.

Output Intent: Use the selection list to choose the desired output profile.

Compatibility: Use the selection list to select the PDF version that will be generated during output.
The generated PDF can be opened with all Acrobat versions that are equal to or higher than the se-
lected version.

ZIP compression (PDF 1.5 or higher): Use the drop-down list to select the PDF version that will
be generated during output. The generated PDF can be opened with any Acrobat version that is
equal to or higher than the selected version.

Scaling: To export the PDF document in its original size, leave the Scale option set to 100%. To
enlarge or reduce the PDF document, enter the desired value.

Sheets: If you activate this option, all pages of a sheet are printed together. Pages that are ar-
ranged horizontally next to each other in the page panel are printed contiguously on one page.

New file per page/sheet: If you activate this option, a new PDF file is automatically created for
each individual page or sheet during PDF export. The text (S) with consecutive numbering is added
to the specified file name at the end, for example filename(S1).pdf, filename(S2).pdf.

Output columns and margins: The margins and columns defined in the type area are output as
lines. The lines are given the color defined in the default settings for the document.

Output line grid: The line grid defined in the type area is also output as lines. The lines are given
the color defined in the default settings for the document.

Output reference lines: Reference lines contained in the document are also output. The lines are
given the color defined in the default settings for the document.

Output print info: Enable this option to add the page information, output date and time at the top of
the page.

Thumbnail

If you activate this option, you can simultaneously create a miniaturized image file for the selected
pages in the specified width, quality level, and file format in addition to the PDF.

First page: If you activate this option, only the first PDF page will create a miniaturized image file.

All pages: If you activate this option, a miniaturized image file will be created from all selected
pages.

Width (in pixels): Enter the width of the miniaturized image file to be created in pixels.

Quality: Use the selection list to select the JPEG quality level with which the miniaturized image
files are to be created.

File Format: Use the dropdown list to select the file format in which the miniaturized image files
should be saved.
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PDF Export Options Acrobat Tab 

Here you determine how the PDF document is displayed in Acrobat Reader.

PDF Export Options - Acrobat tab

User Interface

Here you can specify whether the menu bar, toolbar, and window controls are automatically dis-
played or hidden in Acrobat when the document is opened.

Page change view: If a page break is performed in Acrobat at the same time by executing a hyper-
link, the new page to be displayed is adapted to the Acrobat window if you activate the Adjust page
option. If you want to keep the currently selected ad size during a page break, select the Keep
scale option.

Full screen mode: This option is mainly used for presentations. If you select this option, the PDF
document will be displayed in Acrobat full-screen mode without the menu bar, toolbar, and status
bar. You can use the Page transition drop-down list to define an animation for a page change. The
Direction drop-down list allows you to specify how the selected page transition is to be executed,
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although not all types of transition offer this option. How fast the page transition is to be executed
can be determined using the Speed selection list. 

View PDF: If you activate this option, the PDF is automatically opened in an Acrobat viewer after
the successful export.

Open page: By default, a multi-page PDF document is always opened with the first page in an
Acrobat viewer. If a PDF document is to be opened with a specific page, enter the page with which
the PDF document is to be opened in the Open page: field.

Contents

Here you can create page notes, hyperlinks, text notes and cross-references. If you activate the cor-
responding options in the Contents area, these are transferred to the resulting PDF.

Transfer page notes: Activate this option to transfer page notes in the document as comments to
the PDF file. 

Transfer text notes: Activate this option to transfer text notes in the document as comments to the
PDF file.

Transfer hyperlinks: If you have created hyperlinks (jump addresses) for navigation in the docu-
ment or to websites, activate this option if you want them to be transferred to the PDF file.

Create cross-references: Activate this option if you have created cross-references in the docu-
ment and these are to be included in the PDF file.

Create items: Activate this option if you want the linked frames to be transferred to the PDF as art-
icles. The articles can be called up in Adobe Reader via the Articles navigation window. The order
of the text frames linked in MarkStein Publisher forms the article reading flow.

Create layers: If you have worked with several layers, the individual layers can be transferred to the
PDF if you activate this option. In Adobe Acrobat, the individual layers can be shown or hidden and
managed using the Layers navigation window. If this option is not active, all layers are reduced to
one. (Valid from Acrobat 6.0 [PDF 1.5].)

Expand links left to paragraph: If this option is enabled, the entire paragraph containing the link
becomes a hyperlink. 

Transfer hyperlinks from placed PDF documents: If this option is activated, hyperlinks contained
in placed PDFs are transferred to the PDF to be created.

Create Bookmarks: Activate this option if you want to transfer paragraphs that have been provided
with an outline layer as bookmarks to the PDF file. If you activate the Create bookmarks for visible
paragraphs only option, no bookmarks will be created for paragraphs that are on the mounting
surface.

Include all outline levels: If all outline levels are to be considered during PDF creation and trans-
ferred to the PDF document, activate the Include all outline levels option. If only certain structuring
levels are to be included in the resulting PDF, activate the Selection option and enter the desired
levels in the adjacent input field. If paragraphs have been set to invisible for the current output using
the Text usage function, activate the Create bookmarks for visible paragraphs only option so
that the hidden paragraphs are not taken into account when creating bookmarks.
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PDF Export Options Security Tab

The Security tab defines the security options of the PDF document.

PDF Export Options - Security tab

Compatibility

Select the Acrobat version from the Compatibility pop-up menu and specify the type of encryption.
If you have selected Acrobat 3.0 and higher as the compatibility option, the security settings are
encoded using 40-bit RC4 encryption. If you have selected Acrobat 5.0 and higher as the compat-
ibility option, the security settings will be encoded using 128-bit RC4 encryption. When Acrobat 9.0
and higher is selected, PDF documents are encoded using 256-bit AES encryption. In general,
256-bit encryption is more secure than 128-bit or 40-bit encryption, as it is currently difficult to
crack, but PDF documents encoded with 256-bit encryption can no longer be opened with older
Acrobat versions.
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Security

Password for opening the document: If a PDF document contains confidential information that is
not intended for all eyes, activate this option and enter the password in the appropriate input field.
The password is requested before the PDF document is opened. The document cannot be opened
without entering the correct password.

Permissions

Access password: To protect the PDF from changes by other users, enter a password here. For a
user to be able to change the security settings in Acrobat, the password must be entered there.

Printing permitted: By selecting the Printing permitted selection list, you determine whether the
PDF document may be printed and, if so, in what quality. If you have selected Acrobat 3.0 and
higher as the Compatibility option, you can choose between the Not Allowed and High Resolution
options. As of version Acrobat 5.0 and higher, Acrobat also offers the option of outputting the docu-
ment with a low resolution of 150 dpi. This means that PDF documents can be printed on a printer,
but cannot be printed in high resolution in prepress. If printing is prohibited, the saving of a PDF
document as a PostScript or EPS file is prevented at the same time.

Changes permitted: You use the selection list to select the options that determine which changes
can be made in a PDF document.

Not permitted: Select the option if the reader is not allowed to make any changes to the PDF docu-
ment. This also includes filling out form fields and signature fields.

Insert, delete and rotate pages: Select the option if the reader of the PDF document is allowed to in-
sert, delete and rotate pages. Pictograms and bookmarks can also be created and deleted.

Completing form fields and signing existing signature fields: If you select the option, forms can
be filled and signed, but it is not possible to create new form or signature fields. Existing fields cannot
be deleted.

Commenting, completion of form fields and signing existing signature fields: Select the option if
you want to prevent PDF documents from being edited using Acrobat's own tools or the tools of addi-
tional plug-ins. With this selection, however, the reader is able to fill out form fields, add comments, and
digitally sign the document. This option is particularly suitable for PDF documents used for correction
purposes.

All except removing pages: Select the option if all areas of a PDF document can be edited. This se-
lection only does not allow pages to be extracted. In addition, the extraction of content and printing can
be prohibited.

Allow copying of text, images and other content: To prevent text, image, and graphic objects
from being copied from the clipboard and pasted into other applications using the Text and Graph-
ics Selection tools, make sure this option is not selected.

Permit text access for screen readers for the visually impaired: Screenreader programs require
direct access to the contents of a PDF. Activate this option to enable access and thus barrier-free
PDF documents. In Acrobat, alternative document colors for the text and background of a page can
then be individually defined via the General Basic Settings.

Document components

Encrypt all document content: Select this option if you want to encrypt the PDF document and
the document metadata. If this option is enabled, search engines cannot access the document's
metadata.

Encrypt all document content except metadata: Select this option if you want to encrypt the con-
tents of a document. Unlike the previous option, this selection allows search engines to access the
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document's metadata. This option is only available if you have selected Acrobat 6.0 and higher
from the Compatibility pop-up menu.

Encrypt file attachments only: If you have selected Acrobat 7.0 and higher as the Compatibility
option, you can select this option. If enabled, attachments attached to a PDF document can only be
opened by entering a password. However, the PDF itself can be opened without a password.

PDF Export Options Images Tab

Use this tab to specify how images are to be handled in PDF.

PDF Export Options - Images tab

Color images and grayscale images

Recalculate bitmaps to: If you activate this option, color and grayscale images, with the exception
of EPS files, are recalculated to the entered resolution.

Job options for embedded EPS files: EPS and PostScript data placed in a document are conver-
ted to PDF format using the integrated Adobe Normalizer. This conversion is based on the job op-
tions known from Acrobat Distiller.
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 MarkStein Publisher uses by default the settings in the Standard.joboptions file for the conversion.
In the drop-down menu, you can select additional job options to specify the conversion.

You can place your special joboptions files into the folder MarkStein\Publisher\psconv\joboptions.

Convert placed PDF/AI documents to bitmap with XXX dpi: If activated, placed PDF and AI
(Adobe Illustrator) documents are converted to bitmap with the entered resolution.

Compression

Compression: Here you determine whether the images should be compressed in the output. With
the option None they are not compressed. The preferred standard compression is JPEG in high
quality. If you want to create PDF documents suitable for prepress and have used transparencies in
your document, you should activate the ZIP option, since this is lossless compression. If you want
to create documents that are to be passed on digitally, JPEG compression in medium quality is
usually sufficient.

Compress images from placed PDF documents: If you have placed one or more PDF docu-
ments in your document, the images they contain will also be compressed if you activate this op-
tion. If this option is not active, the images are transferred unchanged.

Images

Output: Select this option if you want to include images in the output.

No images: Select this option if you do not want to output images.

Output as area: If you select this option, the images will be output as a gray area. The name of the
image appears within this area.

Preview: This option ouputs the preview embedded in the document.

Images with missing original files

Do not output: Select this option if you do not want to output images with missing original files.

Output as area: If this option is clicked, the images of which the original file is missing will be prin-
ted as an area.

Output preview: The preview embedded in the document is printed if the original is missing.

Crop images

The Crop Images option allows you to control whether image data that is outside an image frame
and is therefore not displayed will be cropped during output. 

Yes: Activate this option so that all image parts that are outside the image frame are removed dur-
ing output.

No: Activate this option if you want to include all image data, even those that are not visible, in the
output.

Automatic: Enter a value from which the invisible image data should be trimmed to the size of the
image frame.
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PDF Export Options Multimedia Tab

Use this tab to specify how multimedia content contained in the document is to be played back in
the PDF document and whether the objects are to be embedded in the PDF file or saved in a sub-
folder.

PDF Export Options - Multimedia tab

Multimedia

Do not output: If you activate this option, the multimedia content placed in the document is not in-
cluded in the PDF.

Output all: If you select this option, all multimedia content placed in the document is transferred to
the PDF, regardless of which object settings have been defined for the individual objects.

Use object settings: In the Frame Properties dialog box, you can define settings for playing multi-
media content in the Interactive tab. If you activate the Use object settings option, the settings
stored for the respective frame are used.
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Media files

Embed into PDF file: If you enable this option, all multimedia content will be fully embedded in the
PDF, which may increase the file size.

Copy to a subfolder (<name>_mediafiles/): If you enable this option, multimedia content will only
be linked and must be included with the PDF. The multimedia files will be copied into a subfolder,
which will be named with the current filename and _mediafiles appended and created in the same
directory as the PDF.

Please note that it is not possible to output multimedia content when printing as PDF using the in-
tegrated Adobe PDF Converter or an external Adobe Acrobat Distiller.

PDF Export Options Transparency Tab

Since PDF version 1.4, native transparencies can be transferred to a PDF document and displayed
correctly during a PDF export.

Transparent objects are created, for example, by using soft edges and drop shadows or by chan-
ging the opacity of an object.

Unlike PDF, PostScript knows only opaque objects and no transparencies, which is why transpar-
encies must always be recalculated in PostScript output. During recalculation, transparency reduc-
tion, the transparency functions are removed with the aim of preserving the optical appearance of
the file. Transparency reduction means that the transparent areas of a page must be divided into
vector- and/or pixel-based objects when printing, which themselves are no longer transparent. Con-
version from transparent to non-transparent objects can be controlled in the Reduce transparency
area by specifying user-defined parameters.

If you create PDF documents that are intended for output and are to be saved as PDF 1.3, transpar-
encies must also be flattened using a PDF export, since PDF 1.3 does not support transparent ob-
jects.

The best way to handle transparencies is to use output systems that can process transparencies
themselves. Currently all Raster Image Processors (RIPs) working with Adobe-CPSI version 3015
or higher and Harlequin ScriptWorks 6 (Eclipse) can do this. This direct PDF processing capability
is not a fixed part of PostScript 3, but an optional module that may or may not be available depend-
ing on the RIP solution. This means that the simple fact that your system works with Adobe CPSI
version 3015 or higher does not guarantee smooth processing of PDF data with transparency. In
addition, this feature must of course be enabled in the software.

The latest workflows work with the PDF Print Engine, which can process PDF documents natively.
This means that transparencies no longer need to be reduced during output, as they are no longer
converted to PostScript.

For a stable, reliable workflow, however, it is not only necessary that not only the RIPs in front of
CTP systems meet this requirement. If the upstream workflow system is not able to process such
PDFs, the Preflight Checker recognizes a PDF version 1.4 or the presence of transparency as an
error, or if RIPs of other systems (plotters, color printers, proofers) are not able to process transpar-
ency, problems arise in advance.

Many prepress companies require PDF/X files from their customers. The most common PDF/X
standards are PDF/X-1a:2003 (ISO 15930-4:2003), PDF/X-3:2003 (ISO 15930-6:2003) and PDF/X-
2 (ISO 15930-5:2003). These PDF/X standards are all based on PDF version 1.4, but transparency
is not allowed because the different transparency reduction methods available on the market are
very different and provide unpredictable results.
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Only with the introduction of the PDF/X standard PDF/X-4 (ISO 15930-7), which is based on PDF
version 1.6, are transparencies and layers as well as JPEG2000, 16-bit image data and OpenType
fonts permitted.

If you want to create PDF documents that require transparency reduction, activate the Reduce
transparency option and then make the desired settings.

If you want to create PDF documents with native transparencies, deselect the Reduce transpar-
ency option.

PDF Export Options - Transparency tab

Pixel-vector balance: The specification in this input field determines how transparent objects are
to be converted for PostScript output. If you enter the value 0, all objects are converted to bitmap
objects, regardless of whether they contain transparencies or are overlapped by transparent ob-
jects. This conversion is independent of whether they were originally text, vector, or pixel objects.
The higher the set value is (you can enter values from 0 to 100), the more objects are retained or
converted as vector objects during transparency reduction and only very complex transparent areas
are rasterized.

Resolution of text/line graphics: In this input field you enter the resolution for text and vector ob-
jects that are to be converted into pixel objects - i.e. images - during transparency reduction. As
resolution you should set the value that you also use for the output of 1-bit bitmap images.
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Resolution of gradients: The resolution for gradients that have to be flattened and converted into
pixel objects during conversion can be specified in the Resolution gradients field. Select a value
here that corresponds to the resolution you use for outputting color or grayscale images.

The following applies to both resolution settings: The higher the selected resolution, the better the
quality, but the longer you need for the output or for the direct flattening of transparent objects.

Convert text to paths: If this option is activated, all text on a page – regardless of whether it is
transparent objects or affected objects – is converted to vectors. This only applies to pages that
contain at least one transparent object. Pages that do not contain transparent objects remain unaf-
fected by the transparency reduction.

Convert contours to paths: If this option is activated, all contours, i.e. all line objects – regardless
of whether they are transparent lines or not – are converted to paths. The conversion only affects
lines on pages that contain at least one transparent object.

Crop complex areas: When flattening, all transparent objects must be removed and individual
overlapping objects must be created from them. Each object is given its own color, which is created
using the color management settings. The aim is to keep the appearance of the objects true to the
original so that the font remains as font and the vector object as vector object. In some cases, how-
ever, fonts and vector objects may have to be rasterized. The Crop complex areas option controls
the way in which the individual transparent areas are converted into independent objects. Activate
this option to avoid visible transitions at points where vector graphics and pixel images adjoin each
other. If this option is not activated, visible transitions may occur if one part of an object is rasterized
and the other part remains a vector object.

Convert colors to CMYK: This option specifies that after the transparency reduction all colors are
present in the Device CMYK color space, i.e. the file is decalibrated so that no ICC profiles are con-
tained in the resulting PDF document. This option should always be activated when creating print-
able PDF documents.

Keep settings for overprinting: To retain the original overprint settings of the objects in the docu-
ment, activate this option. If you disable this option, all objects originally set to Overprint will be set
to Omit and new objects will be created in the areas where the overprinting objects overlap, even if
the objects are not overlaid by transparent objects.

Left: If the option Keep overprint settings is activated, the original overprint settings and the number of objects in the
resulting PDF document are retained. Right: If this option is turned off, the appearance of the objects does not change.
However, a new object has been created where the overprinting objects overlap.
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PDF Export Options Margin / Bleed Tab

In this tab you can enter a margin for top, bottom, left and/or right, which is to be added to the paper
format of the PDF document.

PDF Export Options - Margin / Bleed tab

Adopt bleed from document: Activate this option to use the bleed defined in the document.

Margin allowance: This option only affects the output of single pages. Activate this option so that
the bleed area is also output in a double page layout if the pages are output as single pages. This is
especially important for panorama pages or if the page contains a color background. If this option is
not activated, the bleed in the page border is cut off at the final format of the page.

Bleed: To override the bleed values specified when setting up the document, deactivate the Use
bleed from document option and enter the required bleed value under Bleed top, bottom, inside and
outside (for double page documents) or top, bottom, right and left (for single page documents). The
button with the lock makes it easier to enter the same values. Enter the desired value with the pad-
lock symbol open and click on the padlock symbol. The value is then automatically transferred to
the connected field. If the symbol shows the closed lock, you also only have to enter the value once.
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Output pages in strips: With this function you can divide the PDF into horizontal stripes at the
entered height.

PDF Export Options Watermark Tab

Recurring elements such as watermarks or banners can be automatically added to the PDF docu-
ment to be created during export. The watermark must first be created as a PDF document.

If you want to add a watermark to the PDF document, activate the Watermark option.

PDF Export Options - Watermark tab

Watermark

Source file: Select the PDF file that contains the watermark by clicking the three dots next to the
option.

Page: If the loaded document contains multiple pages, you can select the page to use here.

Zoom: The value allows you to increase or decrease the watermark size by a percentage.
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Opacity: To change the transparency of the inserted object, enter the desired percentage value in
the input field.

Rotation: To rotate the watermark, enter the desired angle.

Display only in print output: Use this option to control where the watermark is output. If this op-
tion is activated, the watermark will be printed but not displayed on the monitor. If this option is dis-
abled, the watermark is displayed on the monitor and printed.

Position

Vertical offset ... from: The vertical position of the watermark on the page is determined by the set
value and by selecting the adjacent drop-down list. The Top, Center and Bottom options are avail-
able for selection via the drop-down list.

Horizontal offset ... from: The horizontal position of the watermark on the page is determined by
the set value and the selection of the adjacent drop-down list. The Left, Center and Right options
are available in the drop-down list.

Arrangement

above page content: Activate this option to add the added watermark before the actual page con-
tent.

below page content: Activate this option if you want to add the watermark after the actual page
content.

Page range in PDF

All pages: Activate this option if you want the selected watermark to be added to all pages to be
output.

Pages from ... to: If you only want to add the watermark on certain pages, enter the corresponding
page range here.
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PDF Export Options Color Tab

For PDF export, you can optionally activate color management. Depending on the settings you
make, the color information of the document can be transferred unchanged to the PDF file or over-
written with the settings on the Color tab page.

PDF Export Options - Color tab

Color management guidelines

Target: Here you specify whether a color conversion is to be performed or whether the colors are to
be transferred unchanged to the PDF file.

Do not change: Select the color option if you do not want to activate color management and want to
transfer the colors unchanged to the PDF file.

Convert all colors to sRGB: Select the option to convert all page elements to the sRGB color space. 

Convert all color profiles to RGB: Select the option if you want to perform a color conversion to an
RGB color space other than sRGB. Then select the target profile in the working color spaces area using
the RGB pop-up menu.
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Convert all color profiles to CMYK: Select the option if you want to perform a color conversion to the
CMYK color space. Then select the target profile in the working color spaces area via the CMYK pop-up
menu. This converts all page elements, regardless of their original color space, to the CMYK color
space.

Rendering intent: This pop-up menu determines the rendering intent (color conversion method)
for the conversion. You can choose between the options Keep, Perception (Images), Saturation
(Graphics), Relative colorimetric and Absolute colorimetric.

Working color spaces

RGB: If you have selected the Convert all color profiles to RGB option as the destination, select
the destination RGB profile from the pop-up menu.

CMYK: If you selected the Convert all color profiles to CMYK option as destination, select the
destination CMYK profile from the pop-up menu.
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Export as e-book
Digital books are presenting new challenges in all areas of desktop publishing. Not only must new
sales channels be explored and new reading devices tested; new file formats have also been de-
veloped. Despite this, the EPUB file format has now gained widespread acceptance on the market.
It is based on open standards that are accessible to everyone.

In the past, books were always tied to a fixed page layout. The new EPUB format gets rid of this
dogma and enables the device on which it is read to re-wrap the text. The readers can now decide
on the font and font size in which they want to read the text. This new text environment has to be
taken into account from the design stage.

A few fundamental questions therefore need to be answered here:

· What does the abbreviation EPUB mean?

· What options does the new file format offer? 

· What are the limitations?

 

The Export as EPUB section then looks at the practical questions:

· How do I prepare an MarkStein Publisher document for EPUB?

· How does it become an EPUB? 

· How do I add information about the author, publishing house, cover etc.? 

· How is a bookmark bar formed?

· How do I insert images, hyperlinks and cross references?

General introduction

Basics of EPUB

The EPUB data format

EPUB is an abbreviation for electronic publication. The EPUB data format is what is known as an
open standard. It was developed by the International Digital Publishing Forum (IDPF) on the basis

of XML and XHTML. The specification is freely available on the IDPF website http://idpf.org. In
short, the following applies to EPUB files:

An EPUB file is a renamed ZIP file that must contain the following files as a minimum:

· A mimetype file withthe content application/epub+zip in the root directory as the first file in the
archive.

· A META-INF directory with the container.xml file, which refers to the master file of the publica-
tion. 

· A master file in line with the Open Packaging Format (OPF), which provides the meta data, lists
all the files in the publication and links to a content file.

· A table of contents for navigating through the publication (an XML file in NCX format).

· At least one content file that must be structured as an XHTML file in line with the Open Publication
Structure (OPS) 2.0.

http://idpf.org/
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Structure of an EPUB file

 MarkStein Publisher automatically ensures compliance with these technical guidelines for you.
However, it is important that you can influence the content of the files in various points in MarkStein
Publisher:

· You specify the information for the title, author, publisher etc.

· The table of contents is generated from paragraphs with structure levels. 

· The content files in the EPUB correspond to your chains or stories. In MarkStein Publisher, you can
define how the text content of your stories is converted into XHTML.

What does it mean when your articles are converted into XHTML? The text in an EPUB is saved in
a device-neutral format – it is wrapped differently on each device on which it is shown. Each new
wrap is tailored to the relevant device. This is very different from the PDF format, which has proven
extremely useful for distributing page-related documents that need to look the same on different
platforms. The strength of the PDF format is that a complex design is displayed identically on any
device. But this can also be a disadvantage, as the text wrap is fixed. If the PDF is viewed on the
small screen of a smartphone, for example, the user has to do a lot of scrolling and zooming. You
should therefore always use the EPUB format when you need a text to be easy to read on different
devices. The EPUB reader then chooses the font and font size.

EPUB link list

A good starting point is the description of the EPUB format on Wikipedia. The data format and the

technologies behind it are described in detail at idpf.org. However, the most important source is the
EPUB Format Construction Guide which describes the creation of an EPUB file using text editors
and a ZIP program in step-by-step instructions.

Reading EPUB books

Various programs are available for displaying EPUB files.

· The most mature solution for reading EPUB files is currently the iBooks program from Apple. You
need iTunes to load your EPUB files into the iBooks program.

· To read EPUB files on a desktop computer, we recommend Adobe Digital Editions. The program
requires the Adobe Air, runtime environment which is installed at the same time.

· The Calibre open source program runs on the operating systems macOS, Windows and Linux.
Open source software usually has short release cycles, so always make sure you are using the
latest version.

· Those using the Firefox browser can install the EPUBReader add-on, which enables you to view
EPUB files directly in the browser.

· Most e-book readers support the EPUB format.
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EPUB reader software

· EPUBReader add-on for Firefox: https://addons.mozilla.org/de/firefox/addon/epubreader

· Adobe Digital Editions: http://www.adobe.com/de/solutions/ebook/digital-editions.html

· Calibre: http://calibre-ebook.com

Example: Display of an EPUB file in the program “Adobe Digital Editions”

https://addons.mozilla.org/de/firefox/addon/epubreader
http://www.adobe.com/de/solutions/ebook/digital-editions.html
http://calibre-ebook.com
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Basics of HTML

In MarkStein Publisher, you can define how the texts are converted into HTML. It is therefore import-
ant that you are familiar with a few basic HTML terms.

A simple paragraph of text in HTML would look like this:

<p>Hello world.</p>

A heading comes from:

<h1>Heading</h1>

Markups on sections of text give the text its structure. These markups usually take the form of
HTML tags that represent different elements. Tags always come in pairs: A start tag begins with the
character “<”. This is followed by the element name (e.g. “p” for a paragraph or “h1” for a first-level
heading). The start tag is closed with “>”. An end tag consists of the character “</”, the element
name and the closing “>”.

HTML distinguishes between block elements and inline elements. Block elements are comparable
with paragraph styles. They always apply to a whole paragraph. Inline elements behave like text
styles. They define how sections of text within paragraphs (i.e. within block elements) look.

<p>This text contains a <em>highlighted</em> word.</p>

In MarkStein Publisher, in the Properties–Paragraph dialog window, you can select the following
block elements for your paragraphs in the HTML tab:

· blockquote: Quote

· h1: First-level heading 

· h2: Second-level heading

· h3: Third-level heading

· h4: Fourth-level heading

· h5: Fifth-level heading

· h6: Sixth-level heading

· hr: Horizontal ruler

· ol: Ordered list (numbered)

· p: Paragraph

· pre: Preformatted text (monospaced font)

· ul: Unordered list (using bullet points)

Using the Properties–Font dialog window, text passages in the HTML tab can be marked up with
these inline elements:

· abbr: Abbreviation

· b: Bold

· cite: Citation (source of the quote)

· code: Source code

· dfn: Definition

· em: Emphasized

· i: Italic

· samp: Sample output (example)

· small: Smaller than usual

· span: General inline element
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· strong: Strongly emphasized

· sub: Subscript

· sup: Superscript 

Example of the source code of an HTML file

If no inline element is selected, the text will be treated as “normal” text. You can also combine mul-
tiple inline elements, e.g. b (bold) and i (italic).

These elements allow you to structure your text. They do not contain any typographical instructions.
The EPUB reader uses the text structure to recognize when a heading, normal text or italicized text
is coming. The specific typography, i.e. which font is used and in which size, is defined by the
EPUB reader on a case-by-case basis. Users can generally define the font and size themselves on
most EPUB readers.

HTML link list

An overview on the Hypertext Markup Language (HTML) can be found in the article on Wikipedia. A
good article on Cascading Style Sheets and how they are linked to HTML is also available on Wiki-
pedia. However, the best and most up-to-date source of information on HTML and CSS is de.self-
html.org.

http://de.selfhtml.org
http://de.selfhtml.org
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Introduction to CSS

Structuring text using HTML elements will be sufficient and useful for most EPUB applications.
However, if you want to make specific typographical markups, this can be done using Cascading
Style Sheets (CSS).

In Cascading Style Sheets (CSS), lists of typographical instructions are grouped together in what
are known as classes. For example, if sections of text are to be colored blue, CSS will contain the
following instruction:

.blue{color:#0099ff;}

The CSS class is assigned to the text section in HTML:

<p>A <spanclass=“blue”>blue</span> word in the middle of the text.</p>

In various places in MarkStein Publisher, you can save CSS class names and/or CSS styles, which
are used as format instructions for the typographical markup of your EPUB file during an EPUB ex-
port. For example, in the Properties – Style Sheet screen in the General tab, and in the Para-
graph Styles and Font Formats screens in the HTML tab. The CSS file itself is created using a
text editor, such as notepad++ (Windows) or Textwrangler (Macintosh). The CSS file is integrated
into the EPUB file when exporting the EPUB.

CSS class: You can enter a CSS class name for a style sheet, which will be written into the HTML
file. This enables you to control how info boxes, images, tables etc. are to be displayed in the EPUB
file. The following structure is created in HTML:

<divclass=“Info box“>
<h3>Info box</h3>
<p>[…]</p>
</div>
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Defining a CSS class in the Properties – Style Sheet dialog

CSS Style: In the box for the CSS Style option, you can enter a direct CSS format instruction that
will then be written directly into the HTML file during the EPUB export. This results in the following
structure in HTML:

<divstyle=“border-top-width:0.5em; border-top-style:solid; border-top-
color:#708090;
background-color:#e0e0e0; padding-left:1em; padding-right:1em; padding-
top:0.5em;
padding-bottom:0.5em; font-family: Helvetica, sans-serif; font-
size:0.85em;”>
<h3>Info box</h3>
<p>[…]</p>
</div>
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Direct entry of a CSS style in the Properties – Style Sheet dialog

The MarkStein Publisher ensures adherence to the precise syntax for you. Very important:
Wherever you define block or inline elements in MarkStein Publisher, you can also save a CSS
class name. The CSS file will then be integrated into the EPUB file during export. In MarkStein Pub-
lisher, you can use exactly one CSS file per EPUB.

Meta data

An EPUB file can contain additional information. The EPUB reader uses this to classify the EPUB in
the reader’s library.

· Title

· Author 

· Language

· Publishing house

· Description

You define this meta data when exporting the EPUB file from MarkStein Publisher.
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The bookmark bar

An EPUB can contain a hierarchical bookmark bar. The hierarchical structure results from the
structure levels that you assign to your paragraphs in MarkStein Publisher.

In many EPUB readers, the bookmark bar can be shown on the left as a tree structure. In some
EPUB readers, it is called a “table of contents” and is automatically inserted at the start of the book.

Digital Rights Management

The EPUB data format supports the mechanisms of Digital Rights Management, or DRM. EPUB
files originating from MarkStein Publisher are generally DRM-free. You can copy these files as often
as you like and read them on any reader that supports EPUB. Of course, you can add DRM to the
files later.

Which content is suitable for e-books

E-books in the EPUB format serve to save texts in a structured way without defined breaks. You can
embed images, but these often exceed the small file sizes needed for mobile devices. It is even
possible to integrate video and audio, although this makes the files many times larger.

But one thing is absolutely impossible in EPUB: Unlike in a print layout, you cannot affix the info box
in the bottom right and the teaser image in the top left. EPUB recognizes only a single stream of
text, in which images can be integrated at certain points.

Within the EPUB text flow, the only limits are those set by HTML. However, please note that not all
EPUB readers can reproduce all HTML tags. Some EPUB readers do not even display images in
the text.

Therefore:

· Use the EPUB format only for content with a lot of text.

· Use images sparingly. A cover image and a photo of the author are usually enough.

· Try to use flat text hierarchies wherever possible. A reference book with more than three structure
levels quickly becomes confusing in the EPUB format.

Its highly-structured layout makes a newspaper difficult to render in the EPUB format. Specialist lit-
erature and novels are best suited.
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Creating e-books in the EPUB format

1. Defining HTML block elements

In MarkStein Publisher, the HTML block elements for the various paragraph styles are defined first.

Assign the block element h1 to the paragraph style “Title” in the Properties > Paragraph dialog
window in the HTML tab.

For the heading, the block element h1 is assigned using the Properties–Paragraph dialog window.

Assign the block element h2 for the “Subhead” paragraph style and the block element p to the para-
graph style “Body Text”, for example.
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2. Defining HTML inline elements

If you want text markups such as bold and italic to be applied in the EPUB format, assign the inline
element you want to the individual text styles.

Assign the inline element b to the text style “Bold ”in the Properties > Text dialog window in the
HTML tab. For italic text, select the inline element i.

To make text bold, the inline element b is assigned in the Properties>Font dialog window.
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3. Creating bookmarks from structure levels

The EPUB data format provides the option of integrating a table of contents in the form of hierarch-
ical bookmarks.

Designing a publication often requires a large number of paragraph styles. To determine which of
these styles could be used for a directory/bookmark, assign a structure level higher than 0 to these
styles.

The structure levels reflect the hierarchical structure of your texts, thus defining which paragraph
styles and paragraphs should be included in a directory. Paragraphs with structure level 0 are not
included; those with a structure level higher than 0 can be selected all together or individually during
the export to EPUB format.

As this is also a paragraph attribute, assign the structure level to the appropriate paragraph style.

Assign structure level 1 to the paragraph style “Title” in the Paragraph tab in the Properties >
Paragraph dialog window.

For the heading, structure level 1 is assigned using the Properties > Paragraph dialog window.
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4. Integrating inline images

By default, placed images are always applied at the end of a story in the EPUB format if the images
are linked with the story. If the images in a document are not linked with the respective story, they
are always placed at the end of the document in EPUB.

Inline images are needed to allow images to be integrated into the text flow and thus displayed in a
specific position in EPUB.

1. Draw an image frame and assign an image to it.

2. Place the cursor at the start of the paragraph before which you want to insert the image in the
text flow.

The cursor is positioned at the start of the paragraph before which the image will later be shown in EPUB.

3. Select Insert > Hyperlink from the menu.

4. In the Hyperlink / Link dialog window, switch to the Link tab.This shows all the available link
targets, including the image frame with the image you have inserted. Select the image from the
list.
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The Link tab in the Hyperlink / Link dialog window; the intended inline image is selected.

5. Do not enter any text in the Text box, otherwise additional text will be inserted in the cursor pos-
ition.

6. Click [OK] to confirm the hyperlink.

7. All hyperlinks on the page are marked with a red flag. To show or hide the flags, select the
command View > Markers.
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Hyperlinks that refer to a link are marked with a red flag in the text.

5. Correctly applying images with image captions

The simplest way is to write the image captions at the point in the text in which you want them to
appear in the e-book.

However, it is more elegant to work with a link consisting of the image and image caption:

1. In your Style Sheet, create a paragraph style “Caption” for the image caption.

A separate paragraph style is created for image captions
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2. In the Properties > Paragraph dialog window, set the block type Caption for this format and
define the block type p in the HTML tab.

In the Properties > Paragraph dialog window, the block type Caption is assigned in the Paragraph tab and the HTML
block element p in the HTML tab.

3. Draw a new text frame and, in the Properties > Frame dialog window, assign it the block type
Caption.
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The block type Caption is assigned to the text frame in which the image caption is to be entered.

4. Enter an image caption in the text frame and format it with the paragraph style “Caption”.
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The text will be formatted with the paragraph style “Caption”.

5. Link the image and image caption.
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The image and the associated image frame are linked together.

6. The link of image and image caption is inserted in the same way as described in Sections 4.1
to 4.7. Simply select the text of the image caption linked to the image in the Link tab of the
Hyperlink / Link dialog window.

The Link tab in the Hyperlink / Link dialog window; the intended link is selected.
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Export as EPUB

Exporting documents in the EPUB format

When you export a document as an EPUB,the Properties – EPUB window appears. It is divided
into four tabs: General, Conditional text, Structure and Images. Each of these tabs contains a
group of options that influence the export process and thus the result.

Proceed as follows to export a document as an EPUB:

1. Open the document or a template and select the command File > Export.

2. In the Export window, select the target folder in which you want to save the EPUB document.

3. Assign a name to the file and, from the File Type list, select the export format EPUB (*.epub).
The name of the file is entered as the file name by default, however, you can change this at any
time.

In the Export window, you can define the target folder, the file name and the export format.

4. Click Save.

5. In the EPUB – Structure window that opens automatically, select the stories you want to in-
clude in the EPUB.
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In the EPUB – Structure window, the stories that are to be included in the EPUB are selected.

6. By simply dragging and dropping the stories, you can define the order in which they appear in
the EPUB. If a story contains a link to another chain, this chain is placed lower than the story in
the hierarchy in the EPUB Selection dialog window. It does not matter whether the chain con-
tains text, images or both – the chain is dissolved in EPUB and the referenced content is integ-
rated into the story.

7. Click [OK]. The Properties – EPUB dialog window will open.

8. In the Export Options, in the General tab, enter the Title, the Author, the Language, the Pub-
lishing House and a Description of the electronic book. If you select the option View E-Book,
the electronic book exported will be shown automatically after the export, as long as an appro-
priate program is installed on the workstation.

9. If you want to add a cover image, click on the three dots next to the Cover from Image File op-
tion and select the image you want, which must be available in JPEG or PNG format. The im-
age will be copied to the EPUB in its original size. You can define the precise dimensions in
your image editing program.
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 General tab in the EPUB Export options

10. Switch to the Conditional text tab. Here you can define whether only paragraphs with a spe-
cific condition should be included in the EPUB. If you select the default setting Show All Text
Renditions, all texts will be included in the EPUB – otherwise, only those with the relevant at-
tribute.



Working methods   Printing and exportingMarkStein Publisher Manual

© 2022 MarkStein Software GmbH 322

Conditional text tab in the EPUB Export options

11. Switch to the Structure tab. Here you can define whether you want a bookmark list to be gen-
erated automatically with your EPUB. The bookmarks are created based on outline layers. You
can choose whether to include all outline layers or only to select certain outline layers.

Choose the option Include Page Numbers of the Printed Version in the EPUB File to place
the page numbers of the printed book in the text flow. This makes it possible to quote from your
e-book. As an option, you can also choose to enter a prefix and/or suffix for the page number.
CSS Class allows you to access a style. Enter the ISBN of the printed version so that it can be
included in the metadata.



Working methods   Printing and exportingMarkStein Publisher Manual

© 2022 MarkStein Software GmbH 323

Structure tab in the EPUB Export options

12. Switch to the Images tab.In this tab, you can define the maximum width of images in landscape
format and the maximum height of images in portrait format. The image size is entered in the
HTML of the EPUB file. You can decide whether the image files should be scaled to the display
size or embedded in their original size. The setting Image Captions in Block is used to assign
images to image captions. In most cases, Caption is the right choice here.
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Images tab in the e-book Export options

13. Switch to the Styles tab. Here you have the option of selecting a CSS file that you want to use
for formatting your e-book. The CSS is normally integrated as a separate file. However, it is
also possible to embed the CSS directly into the HTML files. The MarkStein Publisher can also
generate a CSS automatically from the style settings of your paragraph and text styles. This
function is only used for research purposes and is not suitable for productive use. Footnotes
are usually shown and linked at the end of each chapter. The EPUB 3 standard also includes
“pop-up footnotes” that can be opened by gesture commands. Only Apple’s iBooks currently
supports this feature.
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Formatting tab in the e-book Export options

14. Once you have made all the settings, click [OK] to create the EPUB document. To cancel the
export process, click [Cancel].

Embedding fonts

The fonts entered in the style sheets are embedded in the EPUB. MarkStein Publisher creates
HTML style sheets in which the font size, line spacing and font of the paragraph and text styles are
recorded. Whether the EPUB is actually displayed with the embedded fonts depends on the EPUB
reader being used to show the electronic book.

Links on the topic of EPUB

www.idpf.org

de.wikipedia.org/wiki/EPUB

http://www.idpf.org
http://de.wikipedia.org/wiki/EPUB
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Export as e-paper and app
This is a function of MarkStein Publisher Workgroup Edition.

On the next few pages, we will tell you how you can export your publication or individual stories as
an e-paper or in an app using the PressMatrix interface.

Introduction
The PressMatrix interface enables you to output your publications as ePapers and as an app using
the PressMatrix solution. PressMatrix is a commercial enterprise specialized in digital publishing of
journalistic content. You need to sign a contract with PressMatrix in order to use the ePaper func-
tion of MarkStein Publisher Workgroup Edition.

Requirements for export as an ePaper include the fee-based PressMatrix account and a FTP server
provided by you.

Using the File > Export PressMatrix... command causes MarkStein Publisher Workgroup Edition
to generate the required data and transfer it to the FTP server you provided. Simultaneously, a
ticket, which triggers the download and processing of the data, is generated and sent to the
PressMatrix interface. The generated documents can then be edited further in the PressMatrix
backend, supplemented and published on iTunes, Amazon or Google Play. There, you can also set
the sales prices, provided the buyers are not subscribers.

https://www.pressmatrix.com
https://www.pressmatrix.com/
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The PressMatrix backend in which meta data can be inserted and sales prices can be set for the stores.
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Entering connection data

The Access Data - PressMatrix window; the access data for PressMatrix at the top, the access data for your FTP server
at the bottom.

PressMatrix

User: Enter your PressMatrix user name here.

Password: Enter your PressMatrix password here.

Show password: When this box is checked, the password will be shown in normal text.

URL: Enter the path to your interface on PressMatrix here.

Data URL: The address of the FTP server from which PressMatrix downloads the data for pro-
cessing.

Encrypted Transfer (scp/sftp)

User: Enter your FTP user name here.

Password: Enter your FTP password here.

Show password: When this box is checked, the password will be shown in normal text.

Domain: Enter the domain name here within which the FTP server is operated.

Path: Enter the path to the FTP directory here.
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Output to WordPress
This is a function of MarkStein Publisher Professional Edition and MarkStein Publisher Workgroup
Edition.

On the next few pages, we will tell you how you can transmit content straight from the program into
the CMS (content management system) of WordPress and which conditions have to be met to do
this.

Introduction
WordPress is a free CMS that was originally developed for establishing and maintaining a weblog
(blog). It is free software licensed under the GNU General Public License (GPLv2).

There is now a large number of freely-available and commercial themes designed for a huge range
of different uses. Almost all of them have a blog function, on which posts can be published and, if
the settings allow, commented on.

With MarkStein Publisher Workgroup Edition you can publish, edit and delete text and images dir-
ectly from MarkStein Publisher on your blog. Once you have entered the connection data and con-
figured the transmission options, publishing stories on your website is easy.

Entering access data

Access data

To enter the access data for WordPress, select Extras > Access Data > WordPress...

The Access Data - WordPress window.

https://en.wikipedia.org/wiki/Content_management_system
https://en.wordpress.com/
https://de.wikipedia.org/wiki/Blog
https://de.wikipedia.org/wiki/GNU_General_Public_License
https://de.wordpress.org/themes/
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User: Enter your WordPress user name here.

Password: Enter your WordPress password here.

Show Password: When this box is checked, the password will be shown in normal text.

URL: Enter the endpoint of your WordPress interface here.

Port: By default, port 80 is used for HTTP transfers, port 443 for HTTPS transfers. Contact your
website administrator for more information.

URL-Aut.: If REST is used, enter the URL for authentication with the REST interface here.

CMS: At this point you can switch between two different interfaces. You can choose between the
(outdated) MetaWeblog interface and the modern REST interface.

Please note: Beginning with the major release 8.0 – Spring 2022 – the MetaWeblog interface will be
 no longer supported.

Transmission options

Title from: Enter the name of the paragraph style you want to use as the heading in the online story
here. You can enter multiple styles, for example “Kicker” and “Title”, separated by commas.

Separator: If more than one paragraph style is used for the title, you can define here which glyphs
should be used to separate the paragraphs from one another.

Kicker and Title in the document have been selected for the title in WordPress; a colon followed by a space is used as
the separator.
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The result in the blog

Teaser from: Enter the paragraph style you want to use as teaser on your website here. This para-
graph is separated from the online story and can be placed as a teaser in a different location on
your website, for example on the homepage.

The paragraph that you define as a teaser will be treated as such in WordPress and can be placed in a different position
on the website.

Change image size during transfer: This function is used to reduce images during transmission
to the pixel size set here at a resolution of 72 dpi. Images smaller than the selected setting will not
be enlarged.

Landscape: XXX px: Landscape images are scaled horizontally to the selected width, the height is de-
termined by the proportion of the original image.

Portrait XXX px: Portrait images are scaled horizontally to the selected width, the height results from
the proportion of the original image.

Square: XXX px: Square images are scaled proportionally to the selected pixel size.

Transfer Web images (JPG, JPEG, PNG, GIF, SVG) unchanged: Images linked with the text,
whose file type is not suitable for display in browsers, are automatically converted into JPG format
during the transfer. If this function is activated, image formats that can be displayed in the browser
are excluded from conversion and resizing.

Convert PDF images to JPG: This option converts placed PDF images or documents into JPG
format.
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Publishing

Publishing the text online

Select the text frame or an element in the link and select the command File > Online > Create. In
the access data options, Show all text renditions must be selected as the rendering condition.

Layout page with the story that is now to be transferred to the website.
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The text is uploaded to your website with the Draft status, but not yet published. Using the com-
mand File > Online > Publish, you can publish the story immediately or edit it in WordPress before
publishing.

The story in the WordPress CMS. Here you can make more changes or publish immediately.
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The published story

The text in your MarkStein Publisher document is now linked to the article on your website. You can
see this in the previously-inactive commands in the File > Online menu, which are now active.

The File > Online menu after an online story has been created

Show: Opens the default browser and connects to your website.

Change: Changes in the text are transmitted to the website.

Publish: Publishes new or modified articles.

Draft: Returns a published article to the Draft status. The text remains in WordPress but is no
longer online.

Delete: Deletes the text from WordPress.
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Disconnect Text: Undoes the connection between the MarkStein Publisher document and the art-
icle in WordPress. Changes can now only be made in WordPress.

Publishing parts of the text online

How you can select texts to be placed online using the Conditional Text function and create altern-
ative text versions is described here.

Transferring Images

Image files contained in the link are transferred with the settings specified in the Access Data win-
dow and placed at the end of the text.

The image was placed at the end of the post
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If you want to place the image anywhere in the text stream, you must place a hyperlink to the image
file at the desired position in the text stream. To do this, proceed as follows:

1. Place the cursor at the beginning of the paragraph in front of which the image is to be displayed
and select the command Insert > Hyperlink ...

2. Switch to the Visited URL tab and click the [File] button. In the following dialog, select the im-
age to be linked in your file system and confirm your selection with [Open]. 

The hyperlink to the file is is entered in the URL: field.

The hyperlink mark was inserted at the selected text passage

Now you can transfer and publish the article as described before, the image now stands in front of
the paragraph in which you have inserted the hyperlink to the file.
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The published story containing an image



Working methods   Printing and exportingMarkStein Publisher Manual

© 2022 MarkStein Software GmbH 338

Social networks
This is a function of MarkStein Publisher Professional Edition and MarkStein Publisher Workgroup
Edition.

With MarkStein Publisher, you have the option of publishing selected content of your publication dir-
ectly on social networks such as Facebook and Twitter.

In this section, we tell you about the requirements and procedures needed to use this function.

Twitter
Twitter is a microblogging service provided by the company Twitter Inc. On it, registered users can
publish short messages, like telegrams. These messages are called “tweets” and can contain text,
images and videos.

On the next few pages, we will tell you the conditions that have to be met in order to publish tweets
with MarkStein Publisher and how you can tweet directly from the program.

Account

In order to tweet from MarkStein Publisher, you need a Twitter account and a Twitter developer ac-
count.

Creating a developer account

To get a developer account, go to https://developer.twitter.com/ and click [Apply].

https://twitter.com/
https://developer.twitter.com/
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The homepage

On this page, click the button [Apply for a developer account].
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This starts the registration process for a developer account.

Sign in with your access data or register using Sign Up. If you sign up as a new user, you will need
to start from the first step again once your Twitter account has been enabled.
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The registration form with the option of creating a new account.

On the next page, you need to answer a series of questions in order to apply for a developer ac-
count. Follow the instructions on the website.

After sending your application, you will receive an email telling you that your application for a de-
veloper account is being processed.

Once the application has been approved, you will receive an email with the hyperlink http://de-
veloper.twitter.com/en/account/get-started. Click the link and sign in with your user data.
The steps that follow are described in the App section.

App

Creating an app

Use your access data to sign in at http://developer.twitter.com/en/account/get-started.

To access your Twitter account via MarkStein Publisher, you need to create an app that enables
use of the API (application programming interface). To do this, click Create an App.

http://developer.twitter.com/en/account/get-started
http://developer.twitter.com/en/account/get-started
http://developer.twitter.com/en/account/get-started
https://de.wikipedia.org/wiki/Programmierschnittstelle
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The Twitter developer page after the first sign in

On the next page, you need to answer a series of questions. Follow the instructions on the website.
Once you have entered all the information required, create the app by clicking [Create].

The app is created and shown in the next window that appears. There, switch to the Keys and
Tokens tab. Some of the required keys – the consumer API keys – have already been created auto-
matically.
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The app you created, Keys and Tokens tab. API key and API secret key have already been created automatically.

Now you need to create the keys for authentication. To do this, go to Access token & access
token secret and click [Create].
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Access token and Access token secret have been created.

You now have all the data you need to tweet from MarkStein Publisher. All you need to do now is
enter this data in MarkStein Publisher. You can find a description of this under Access data.

Access data

To enter the access data in MarkStein Publisher, select the command Extras > Access Data >
Twitter...
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The Access Data – Twitter window

Here you need the keys that you created for your app as described in the App section above.

The keys and tokens for your app. The name of each data set is written in gray on the right.

Transfer the keys for your app into the respective boxes in the Access Data – Twitter window. The
easiest way to do this is to copy & paste.
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The Access Data – Twitter window with the keys and tokens entered.

Twitter API Key: Enter the key you created in your app (API key).

Twitter API Secret: Enter the key you created in your app (API secret key).

OAuth Access Token Key: Enter the key you created in your app (access token).

OAuth Access Token Secret: Enter the key you created in your app (access token secret).

Confirm with [OK]. You can now tweet from MarkStein Publisher. The Posting section describes
how.

Posting

Selecting text for tweets

Select the text you want to publish on Twitter.

In the Layout view, select File > Social Media...

https://en.wikipedia.org/wiki/OAuth
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The text section to be published in Twitter is selected in the Layout view

The Social Media/Twitter window will open.

The selected text that can still be edited before posting is shown in the top section. 
Underneath you can see how many of the 280 possible characters have been used so far. If the
maximum number of characters is exceeded, the post cannot be sent.

The bottom section of the window shows the images from the link that contains the selected text.
Check the box under one of the images to add it to the post.
You can only attach one image per tweet. The image formats .gif, .jpg/jpeg, .png and .tif/tiff are
available. (Twitter does not support tiff images at all, but MarkStein Publisher converts them into a
Twitter-compatible format during the sending process. This does not change the placed original
file.)
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The Social Media/Twitter window

The Social Media/Twitter window; a line break has been added to the text and an image selected.
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Clicking the [Post] button publishes the tweet. For technical reasons, it is not possible to receive
confirmation of a successful post.

The tweet has been posted

Selecting text using paragraph style

If a certain section of the text, such as the heading here, is to be posted on Twitter regularly, you
can create a special paragraph style for your tweets.

Position the cursor in the heading. Select the command Style > New Paragraph Style...
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The properties of the new paragraph style

All definitions of the paragraph have already been applied. Change the text in the Name: box to
“Twitter” and confirm with [OK].

Select the heading and format it with the new style.

Now all you need to do is to select part of the link using the selection tool in order to post the text
formatted with the “Twitter” style.
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Here, the heading formatted with the Twitter style has automatically been selected for posting.

Creating and posting alternative text

MarkStein Publisher offers the option of composing and managing alternative text versions for dif-
ferent output channels in a text.

To do this, you must use different text usages in your documents.

Select the command File > Document > Conditional Text and define Condition 1 for the docu-
ment.

Text usage for the document
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In the styles panel, right-click on the paragraph style “Twitter” and select the command Proper-
ties... In the Conditional text tab, define Condition 2.

In the View toolbar, switch to the Galley view and select the command Show All Text Renditions
in the View menu.

Format the heading that was formatted with the “Twitter” style in the previous example with its ori-
ginal heading style again.

Now you can enter an alternative heading. Place the cursor at the end of the heading and create a
new paragraph, which you then format with the “Twitter” style. 
Enter the alternative text. It will be underlined with red dots.

Galley view of the story with the alternative text underlined in red dots

Close the Galley view using the menu command File > Close or by clicking the X icon after the
name “Internal Document”.

In the Layout view, a red angle will now be shown under the heading to show the position of the hid-
den alternative text.
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Layout view showing the alternative text

If you now select the command File > Social Media..., the alternative text will be automatically se-
lected for posting.

Here, the alternative heading formatted with the “Twitter” paragraph style has automatically been selected for posting.
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Facebook
Facebook enables the creation of private profiles to present an individual, of company pages for
commercial purposes, and of groups for the private discussion of shared interests.

The profiles can be connected to one another through the use of friend requests. Although the num-
ber of fans is unlimited, the number of directly-linked friends is limited to 5,000. Facebook also of-
fers a messenger function and a development platform for creating apps.

Due to a change in Facebook's interface (API), it has unfortunately no longer been possible to
simply post from other programs since mid-2018. The API is unfortunately currently only made
available to larger organizations after extensive testing and is no longer available to end users.

For Facebook, use the Copy (<Ctrl> + C) and Paste (<Ctrl> + V) functions to create a post.
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Working with paths

In the following sections you will find information about the possibilities that MarkStein Publisher of-
fers for working with paths and Bézier shapes.
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Bézier paths

Basics

With the Draw Bézier Line tool, you can freely design lines and shapes and use them as design
elements, text paths or as text or picture frames. Examples are given at the end of this section.

The construction of Bézier objects

Anchor points form the skeleton of a Bézier object, with which the shape of the segments is con-
trolled. Marked anchor points are displayed as a filled square, unmarked anchor points as an un-
filled square.

The connecting lines between two anchor points are called segments. They can be both straight
line segments and curves.

The handle line connects the anchor point with the handle point. The length of the handle line de-
termines the strength of the curvature of a curve, the angle the direction of the curvature.
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Types of anchor points

Polygon point

A polygon point has no handles and connects straight segments.

Transition point

A transition point can have one or two handles that can be moved independently of each other in
length and direction. They allow the transition from a straight line to a curve or vice versa.

    

The upper anchor point (1) was converted into a transition point (2). The left handle was deleted and the right handle line
was extended horizontally to the x-position of the lower right anchor point.

Curve point

This type of point connects curve segments and has handles on both sides, the length of which can
be adjusted independently. Thus, the strength of the curvature before and after the anchor point can
be adjusted independently. However, they always form a straight line intersecting the anchor point,
so that when the angle is changed, both the curve before the anchor point and the curve after the
anchor point are affected.
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The upper anchor point (1) was converted to a curve point (2). The right handle line was extended horizontally to the x-
position of the lower right anchor point. The left segment remains unchanged (3).

Symmetrical curve point

This type of point connects curve segments and has handles on both sides whose length is always
the same. By changing the length, the strength of the curve before and after the anchor point is
changed equally. However, they always form a straight line intersecting the anchor point, so that
when the angle is changed, both the curve before the anchor point and the curve after the anchor
point are affected.

    

The upper anchor point (1) was converted into a symmetrical curve point (2). The right handle line was extended hori-
zontally to the x-position of the lower right anchor point. The left segment remains symmetrical to the right segment (3).

Drawing

When drawing with the Draw Bézier Line tool, guides, column lines and row grids are magnetic, if
you have specified this. Anchor points are thus attracted within the defined snap radius. Pressing
the <Alt> key turns off magnetism as long as the key is held down. Switching to View > Original
also switches the function off. 

While drawing, either polygon points or curve points are created; transition points and symmetrical
curve points are created by transformation using the Edit Bézier Line tool or via the context menu
for anchor points using the Draw Bézier Line tool.

To move an anchor point while drawing, click on the anchor point while holding down the <Ctrl> or
<Cmd> key. While holding down the key, this calls the Edit Bézier Line tool, which you can use to
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move the anchor point, transform it or edit the handles. After releasing the key, select the last cre-
ated anchor point to continue working with the Draw Bézier Line tool.

You close a path by clicking on the starting point of the Bézier line.

Drawing straight line segments

To draw a straight line, select the Draw Bézier Line tool and click where you want the line to begin.
This sets the first anchor point.

When setting points, press the <Shift> key to restrict movement in 45° steps to create exactly hori-
zontal, vertical or 45° segments.

Each time you click on the work area, another anchor point is set and the segment is created. 

Creating a Bézier line from straight line segments

To end the path, click on a free area while holding down the <Ctrl> or <Cmd> key or select another
tool.

By holding down the <Ctrl> or <Cmd> key, anchor points can be moved without changing the tool.

Drawing curves

A curve is created by pulling out the handle lines with the mouse button pressed down when setting
the anchor point. 
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Set the first anchor point as polygon point (1), create the curve point by clicking and dragging (2), by clicking without
dragging the next point was set here (3), the curve was continued symmetrically to the curve before the second point.

Closing a shape

To create a closed shape, click on the first created anchor point of the drawing. A small circle ap-
pears next to the tool symbol.

  

When moving the tool symbol to the first created anchor point, a small circle is displayed, clicking closes the shape.

Editing

Select

Not only can you edit Bézier shapes you have created yourself, objects created with the various
frame tools can also be edited afterwards, as can text wrap paths created using the Create Path
function.

Select one of the Bézier tools and click on the object to be edited. 
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Using the Draw Bézier Line tool

When you move the tool icon over a segment, a plus sign appears next to it. Clicking inserts an anchor point at this posi-
tion.

A minus sign is displayed above an anchor point, clicking deletes the anchor point.
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Context menus

The context menu when right clicking on a segment.

You can use the context menu to transform the anchor points adjacent to the segment into other
point types, insert an anchor point at the tool position or delete the segment.

Segment to Vector converts a curve segment into a straight line.

Segment to spline converts a straight segment into a curve.

Open spline inserts two exactly superimposed, unconnected anchor points at the tool position.

The context menu when right-clicking on an anchor point .
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Using the Edit Bézier Line tool

This tool allows you to move anchor points and segments and to edit the length and angle of the
handles. 

The coordinates of a selected anchor point or handle are displayed in the control panel and can be
edited there.

The context menus for anchor points and segments are the same as for the Draw Bézier Line tool,
but you can delete a handle point by right-clicking on it.

The context menu for a handle point.

Examples

A simple form of a Bézier object: a line on which text has been placed.
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The line was extended to a closed form.

Star as text frame.
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Text fitted in a shape
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Pathfinder
MarkStein Publisher offers the possibility to combine frames to create new shapes. You will find the
commands in the Object > Pathfinder menu. Objects created with this function adopt the stroke
and fill attributes of the frame at the bottom of the Z-order.

Select two or more overlapping objects and select one of the following commands:

The Menu Object > Pathfinder
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Add 

    

Subtract

    

Intersect
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Exclude overlap

    

Shapes created with this function can be further edited with the Edit Bézier Line tool.

The Add function can also be used to link non-overlapping frames, for example to combine several
small picture frames into one large frame.
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Here, the individual frames were linked together using the Add function.
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Convert Text to Outlines
The MarkStein Publisher offers the possibility to convert font to outlines (paths).

This can be done both by selecting a text frame with the Selection tool for the entire contents of a
text frame, and by selecting a text passage with the Text content tool.

The path objects created in this way can be edited using the Draw Bézier Line and Edit Bézier
Line tools and, like any path object, can be filled with color or gradient, given an outline, or used as
an image or text frame.

For both possibilities you will find the menu items Copy as Outlines and Create Outlines in the
Edit menu.

Edit menu
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Copy as Outline

The content of the selected frame or the selected text passage remains unchanged, a copy conver-
ted to paths is in the clipboard after selecting the menu item and can be inserted anywhere in the
document or in another document.

Selection of a text passage with the text content tool. 

The selected text passage was pasted after selecting the Copy as outlines menu item and then adding contour and fill.

Create Outlines

The content of the selected frame or the selected text passage is converted into paths and replaces
the source objects. 
Previously selected text is inserted into the text stream as an anchored frame. 

Selecting a text passage with the text content tool

After selecting the Create outline menu item, the selected text passage was automatically integrated into the text as an
anchored frame and then provided with an contour and fill.
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Selecting the entire text frame

The content of the selected frame has been contoured and filled after selecting the Create outline menu item.
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Further path operations

Outline Stroke

This function allows you to convert the stroke of an object into an outline stroke in order to assign
for example a color gradient to the stroke of a circle, as shown here as an example.

Draw an ellipse frame while holding down the <Shift> key and assign a stroke to it. 

Circle with 6 mm stroke

Select the circle and convert the stroke to an outline stroke using the Object > Outline Stroke com-
mand.

Object after conversion to outline stroke

Assign a Gradient to the object in the Object Properties inspector.
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Object after the assignment of the gradient

If desired, you can now assign a stroke to this object again.

Object after the assignment of a stroke

Simplify Path

Under certain circumstances, gaps may occur in closely spaced lines when they are converted into
an outline stroke. This function removes these gaps.
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The line before conversion (1), after conversion to outline stroke (2), after using the Object > Simplify Path command
(3).

Reduce Points

This function recalculates an outline stroke and reduces the number of anchor points.

The outline stroke after using the Object > Reduce Points command

Create Path

You can use this function to create a path that controls text flow around an image motif that has a
single color background.

Place the image at the desired position in the text.
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Layout page with placed image

Select the image frame and choose Image > Create Path... from the context menu or Content >
Image > Create Path... from the menu.
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Selection of the command Create Path...
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The Create Path dialog box

In the selection menu Method: Choose Non-white Areas.

Tolerance: This value controls the distinction between motif and background color. For a white
background, a lower tolerance value is sufficient; the darker the background, the higher the toler-
ance value must be set.

If the difference between background and motif is too small, this function can no longer distinguish
between the tonal values, in which case a path or alpha mask must be created in an image editing
program.

Margin: Here you define the distance between the subject and the path to be created. 

Text Spacing: Here you define the distance between the path and the text. You can edit this value
later in the Layout > Text Wrap inspector.

You can use the [Preview] button to display the precalculated result before clicking the [OK] button
to complete the command.
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The generated path after selecting the Draw Bézier Line tool

Select the image and switch to the Edit Bezier Line tool. This allows you to click on individual
points and move them with the mouse button pressed down to adjust the text flow around the path if
necessary.
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Working with tables

Basic information on creating tables

MarkStein Publisher has a powerful table tool with which even complex tables can be created.

You can design tables completely in MarkStein Publisher and enter the text directly into the table or
import tables from Microsoft® Excel as well as documents in CSV format and format them auto-
matically using the table wizard.

When importing via the menu item Place... only the formats .xslx and .csv are supported, Excel files
in the format .xls cannot be placed. However, data from documents that cannot be placed can be in-
serted into a table or text frame by copy & paste. 

To give the text formatting within the table a uniform appearance, the required paragraph formats
and text formats have to be built before the table is created.

To standardize the visual appearance of tables, table style sheets are then created with individual
cell styles. The individual cell styles are assigned the previously built paragraph and text formats.

For tables that run over several pages, the table header and footer can be repeated automatically.

The descriptions and examples in this section show how to select commands using the context
menus. All these commands can of course also be selected via the Table menu item in the menu
bar.

https://en.wikipedia.org/wiki/Comma-separated_values
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Structure of a table
The following examples show possible structures of tables, as well as the possibilities of continu-
ation in linked frames. 

A table in which all possible cell types are applied

A row-wise oriented table without header and footer column, and continuation in a linked frame. Header and footer row
are automatically repeated. The annotation is automatically moved to the last frame of the chain.
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A column-wise oriented table without header and footer row and continuation in a linked frame. Header and footer
columns are automatically repeated. 



Working methods   Working with tablesMarkStein Publisher Manual

© 2022 MarkStein Software GmbH 383

Set up a table style sheet

Basics

You create new table style sheets in the Table Styles panel. The properties of the table style sheet
determine the general appearance of the outline, row and column rules of a table. However, these
properties are only transferred if no cell styles have been created or assigned. Assigned cell
formats overwrite these attributes.

Here you also create cell styles and assign paragraph and text styles to them.

Panel Table Styles:  New Table Style Sheet,  New Cell Style,  Edit,  Copy to Clipboard,  Delete, 
 Switch to edit mode.

After creating a table style sheet, you can use the context menu of the pop-up menu to display the
properties of the new style sheet and edit them.
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Basic options tab

On the Basic Options tab, you define the orientation of the table.

Defining the basic settings of a table style sheet

Name: Enter the name of the table style sheet in the input field.

Orientation: Here you determine whether the table is horizontal or vertical oriented.

Row-Wise: When continuing in a linked frame, header and footer rows can be repeated automatically.

Column-Wise: When continuing in a linked frame, header and footer columns can be repeated auto-
matically.

Row/Column Strokes in front: If you have defined overlapping lines with different colors, tonal val-
ues or opacity, you can define which line lies in front in the overlap area by activating one of these
switches.

CSS class: Enter the CSS class with which the exported table should be marked.

CSS style: Enter the CCS style with which the exported table should be marked.
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Left/Top Strokes tab

In the Left/Top Strokes tab, you define whether the table should have an additional left and/or up-
per stroke.

Defining the left/top stroke properties of a table style sheet

Top Stroke

Style: Select one of the predefined line styles from the drop-down list.

Weight: Enter the line weight or click on the arrows.

Color: Use the drop-down list to select the line color.

Tint: Enter the desired tint or click the arrows to increase or decrease the current value. Values
between 0.1% and 100% are allowed.

Opacity: Enter the desired opacity or click the arrows to increase or decrease the current value.
Values between 0.1% and 100% are possible.

Left Stroke

Style: Select one of the predefined line styles from the drop-down list.

Weight: Enter the line weight or click on the arrows.

Color: Use the drop-down list to select the line color.

Tint: Enter the desired tint or click the arrows to increase or decrease the current value. Values
between 0.1% and 100% are allowed.

Opacity: Enter the desired opacity or click the arrows to increase or decrease the current value.
Values between 0.1% and 100% are possible.

In Front: This determines which of the lines are at the front in the overlap area.
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Stroke tab

In the Stroke tab, you define the stroke for the entire table.

Defining the stroke properties of a table style sheet

Weight: Enter the line weight or click on the arrows.

Style: Select one of the predefined line styles from the drop-down list.

Position: Here you define how the stroke should be built up starting from the table border. The fol-
lowing options are available: centered, outside and inside.

Color: Use the drop-down list to select the line color.

Tint: Enter the desired tint or click the arrows to increase or decrease the current value. Values
between 0.1% and 100% are allowed.

Opacity: Enter the desired opacity or click the arrows to increase or decrease the current value.
Values between 0.1% and 100% are possible.
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Rows tab

In the Rows tab, you specify whether the table rows should be separated by a horizontal rule.

Defining the row properties of a table style sheet

Row Rule Style: Select one of the predefined line styles from the drop-down list.

Weight: Enter the line weight or click on the arrows.

Color: Use the drop-down list to select the line color.

Tint: Enter the desired tint or click the arrows to increase or decrease the current value. Values
between 0.1% and 100% are allowed.

Opacity: Enter the desired opacity or click the arrows to increase or decrease the current value.
Values between 0.1% and 100% are possible.

CSS class: Enter the CSS class with which the exported rows should be marked.

CSS style: Enter the CCS style with which the exported rows should be marked.
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Columns tab

On the Columns tab, you specify whether the table columns should be separated by a vertical rule.

Defining the column properties of a table style sheet

Column Rule Style: Select one of the predefined line styles from the drop-down list.

Weight: Enter the line weight or click on the arrows.

Color: Use the drop-down list to select the line color.

Tint: Enter the desired tint or click the arrows to increase or decrease the current value. Values
between 0.1% and 100% are allowed.

Opacity: Enter the desired opacity or click the arrows to increase or decrease the current value.
Values between 0.1% and 100% are possible.

CSS class: Enter the CSS class with which the exported columns should be marked.

CSS style: Enter the CCS style with which the exported columns should be marked.
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Setting up cell styles
Each new table style sheet automatically contains the cell format Default. In this cell style, you spe-
cify cell properties such as margins, text spacing, column and row lines, outline stroke, background
color, horizontal and vertical text alignment, paragraph and text styles. 

To display or edit this cell style, right-click the name and choose Properties... from the context
menu. Alternatively, first click the cell style name and then click the button with the pencil icon
(Edit). 

A selected cell style of the table style sheet with context menu

The Properties - Cell Style dialog box opens on the Stroke/Background tab.
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Stroke/Background tab

The cell properties are defined in the Stroke/Background tab.

Margin: 

Enter the desired margin weight in the individual input fields or click the arrow keys. The entered
margins move from the cell border inwards and do not displace text contained in the cell. To obtain
even margins with only one entry, click the lock icon to close it.

Color: Use the drop-down list to select the line color.

Tint: Enter the desired tint or click the arrows to increase or decrease the current value. Values
between 0.1% and 100% are allowed.

Opacity: Enter the desired opacity or click the arrows to increase or decrease the current value.
Values between 0.1% and 100% are possible.

Stroke: 

Style: Select one of the predefined line styles from the drop-down list.

Weight: Enter the line weight or click on the arrows.

Color: Use the drop-down list to select the line color.

Tint: Enter the desired tint or click the arrows to increase or decrease the current value. Values
between 0.1% and 100% are allowed.

Opacity: Enter the desired opacity or click the arrows to increase or decrease the current value.
Values between 0.1% and 100% are possible.
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Background: 

Color: Use the drop-down list to select the line color.

Tint: Enter the desired tint or click the arrows to increase or decrease the current value. Values
between 0.1% and 100% are allowed.

Opacity: Enter the desired opacity or click the arrows to increase or decrease the current value.
Values between 0.1% and 100% are possible.

CSS Class: For the definition of stroke/background you can enter a CSS class name which will be
written into the HTML file. This allows you to control how they are displayed in an EPUB file. 

CSS Style: In the input field of the option CSS Style you can enter a direct CSS style instruction,
which is then written directly into the HTML file during the EPUB export.

Text tab

On the Text tab, you define the properties of the text within the cell.

The Text tab is used to set the text properties within cells.

Inset: Here you define the distance of the text from the cell borders. Enter the desired distances in
the individual input fields or click the arrow keys. To obtain the same distances with only one input,
click the lock symbol to close it.

Vertical justification: Here you determine how text in an incompletely filled cell should be aligned. 

Align Top aligns text to the top edge of the cell. 

Justify paragraphs with Vertical Alignment Option distributes the available space evenly between
paragraphs that have a vertical alignment option assigned in the paragraph properties or in the Style
menu. 
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Justify All Paragraphs distributes the available space evenly between all paragraphs. 

Justify All Lines distributes the available space evenly between all lines. 

Align Center distributes the available space evenly above and below the text. 

Align Bottom aligns the text to the bottom edge of the cell. 

Horizontal alignment: Here you define how text and numbers within the cell should be aligned ho-
rizontally.

[None]: The alignment is based on the properties of the assigned paragraph style.

Decimal: Aligns numbers with decimal places to the decimal character assigned in the Align On: input
field. The numbers are initially left-aligned. Only when you enter a shift value in the Position: input field
that is greater than the maximum width of the characters in front of the decimal character can the align-
ment become effective.

Left: Aligns text or numbers to the left edge of the cell. A left indent defined in the paragraph properties
is ignored.

Align Center: Aligns text or numbers to the center. Indents defined in the paragraph properties are ig-
nored.

Right: Aligns text or numbers to the right cell edge. A right indent defined in the paragraph properties is
ignored.

Decimal Center: Aligns the decimal character assigned in the Align On: input field to the center. 

Decimal Right: Aligns numbers with decimal places to the right of the decimal character assigned in
the Align On: input field. The numbers are first right-aligned. Only when a shift value is entered in the
Position: input field that is greater than the maximum width of the characters after the decimal character
is the alignment effective. 

Paragraph style: Enter the name of the paragraph style intended for the cell here. 

Text style: Enter the name of the text style to be used for the cell.

Angle (Rotation/Shearing): By entering an angle, you can create toppled table rows. Enter the
angle, the direction can be set using the Direction: drop-down list. The options vertical and hori-
zontal are available.

Columns: By default, each cell is created with only one text column. Enter the number of columns
here if the cell is to be divided into several columns of equal width. 
The individual columns are linked so that the text automatically flows from one column to the next.

Gutter: If a cell has been divided into several columns, enter the column spacing in this input field.

Examples:

Here the rows in the header were rotated by 45° in horizontal direction (shear). 
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Example of a column where the digits are aligned to the comma

Rows tab

In the Rows tab, you define the properties of the rows.

Y Position: When creating the cell style, this input field has no function. When editing a created
table later, you can assign a fixed Y-position to a selected row. If the row is moved up as a result,
the displacement value is subtracted from the height of the row above. If the row is moved down,
the displacement value is added to the height of the row above.

Height: In this input field, you define the height of the row when the table is created. If overset oc-
curs, you can increase the height of the row manually using the table tool.

Fit Height to Text: If you activate this option, this row is automatically adjusted to the amount of
text entered or imported.

Locked: Activate this option if the height of the row should always be the same, regardless of the
amount of text. Rows with this attribute cannot be enlarged manually with the table tool.
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Row lines: Here you specify whether a line is to be added to rows with this cell style. The row lines
are positioned centered on the bottom edge of the rows.

Style: Select one of the predefined line styles from the drop-down list. The selection buttons next to it
can be used to define the line ends; Butt Cap, Projecting Cap and Rounded Cap are available.

Weight: Enter the line weight or click on the arrows.

Color: Use the drop-down list to select the line color.

Tint: Enter the desired tint or click the arrows to increase or decrease the current value. Values
between 0.1% and 100% are allowed.

Opacity: Enter the desired opacity or click the arrows to increase or decrease the current value. Values
between 0.1% and 100% are possible.

In Front: If you have defined overlapping lines with different colors, tonal values or opacity, you can ac-
tivate this switch to specify that the row line should be at the front in the overlap area.

CSS Class: Enter the CSS class here with which exported rows should be marked.

CSS Style: Enter the CCS style with which exported rows should be marked.

Columns tab

The Columns tab is used to define the properties of the columns.

X Position: When creating the cell style, this input field has no function; when editing a created
table later, you can assign a fixed X position to a selected column. If the column is moved to the left,
the shift value is subtracted from the width of the column to the left; if the column is moved to the
right, the shift value is added to the column to the left.

Width: In this input field, you determine the width of the column when the table is created. If neces-
sary, you can increase the column width manually using the table tool.
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Fixed: Activate this option if you want the width of the column to always be the same regardless of
the amount of text. Columns with this attribute cannot be enlarged manually with the table tool.

Column lines: Here you specify whether a line is to be added to columns with this cell style. The
column lines are positioned centered on the right edge of the columns.

Style: Select one of the predefined line styles from the drop-down list. The selection buttons next to it
can be used to define the line ends; Butt Cap, Projecting Cap and Rounded Cap are available.

Weight: Enter the line weight or click on the arrows.

Color: Use the drop-down list to select the line color.

Tint: Enter the desired tint or click the arrows to increase or decrease the current value. Values
between 0.1% and 100% are allowed.

Opacity: Enter the desired opacity or click the arrows to increase or decrease the current value. Values
between 0.1% and 100% are possible.

In Front: If you have defined overlapping lines with different colors, tonal values or opacity, you can ac-
tivate this switch to specify that the row line should be at the front in the overlap area.

CSS Class: Enter the CSS class here with which exported columns should be marked.

CSS Style: Enter the CCS style with which exported columns should be marked.
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Table Wizard
The Table Wizard is a tool integrated into MarkStein Publisher that allows you to quickly and easily
create tables with defined structure and formatting. It opens automatically when you select the
Table > Create Table command or when you select the Table tool in the toolbar. An empty marked
text frame is required.

When placing an Excel file in .xlsx format or a CSV file, the wizard will also open automatically. The
number of rows and columns is determined by the structure of the placed document and cannot be
edited.

The first page Define Table of the Table Wizard

Style Sheet Text: Use this selection list to select the style sheet with which the text is to be format-
ted.

Style Sheet Table: Use this selection list to select the table style sheet with which the table and
cells are to be formatted.

Orientation: Here you define how the table should be oriented. 

Row-wise: The continuation in a linked text frame is in vertical direction, Header Rows and Footer
Rows can be automatically repeated in each linked frame.

Column-wise: The continuation in a linked text frame is in horizontal direction, Header Columns and
Footer Columns can be repeated automatically in each linked frame.

Rows: Here you define the total number of rows. 
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Height: By selecting one of these options, you define the properties of the row height. The following
options are available:

Value: Choose this option to enter a fixed row height. If selected, the Value field below the option then
becomes active, in which you enter the required value.

Text: If you select this option, the row height is automatically adjusted to the amount of text. 

Adjust: Select this option if you want the previously defined number of rows to completely fill the drawn
frame.

Columns: Enter the number of table columns here.

Width: By selecting one of these options, you define the properties of the column width. The follow-
ing options are available:

Value: Choose this option if you want to enter a fixed column width. If selected, the Value field below
the option becomes active, in which you enter the required value.

Adjust: Choose this option if you want the previously defined number of columns to completely fill the
drawn frame.

Cell Style 1/Cell Style 2: Use the dropdown lists to select cell styles for the table body.

Alternate Every: If the cell styles of the table body are to alternate column by column or row by row,
enter the value in the Alternate Every input field according to which the cell style is to be changed.
Use the adjacent selection list to determine whether the change is to be made row by row or
column by column.

Buttons

[Next]: Clicking this button takes you to the second page of the Table Wizard.

[Finish]: Clicking this button completes the table and closes the Table Wizard.

[Cancel]: Click this button to cancel the process.
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The second page Define Table Structure of the Table Wizard

In this window you enter the number of rows to be created for the Title, Lead Text, Header, Footer
and Annotation. The rows for Title, Lead Text and Annotation are not divided by the columns, but
extend across the entire width of the table.

You define the cell styles in the corresponding Style dropdown menus. 

Buttons

[Back]: Clicking this button takes you to the first page of the Table Wizard.

[Finish]: Clicking this button completes the table and closes the Table Wizard.

[Cancel]: Click this button to cancel the process.
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Editing the table
After completion, you have extensive options for editing the table later on. By selecting a part or the
entire table, all editing functions are available via the menu bar, the context menus and the table in-
spectors.

Table

Editing text

With the Text tool selected, click on the text you want to edit. If the table tool is selected, double-
click (or depending on the personal setting with the <Alt> key held down) to access text editing.

Select table

By clicking the table tool in the intersection area of the row and column bar, the entire table is se-
lected.

 

Select table body

Select the Table tool, right-click in the intersection area of the row and column bar and select the
Select Table Body command.

Cells

Select cell

With the table tool selected, click on the cell you want to select.

Swap cell contents

Select two cells with the Table tool while holding down the <Ctrl> (Win) or <Cmd> (Mac) key, right-
click one of the cells and select Swap Cell Content from the context menu. 
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Merging cells

Use the Table tool with the <Ctrl> (Win) or <Cmd> (Mac) key pressed to select two or more hori-
zontally or vertically adjacent cells, right-click the selected cells and choose Merge Cells from the
shortcut menu. The connected cell adopts the attributes of the cell on the left or on top.

Cells connected in this way can be disconnected using the Unmerge Cells command.

Insert image into cell

Right-click in the cell for the image and select Image > Assign ... from the shortcut menu. By right-
clicking on the placed image, you can access the commands Image > Align, Fit and Flip from the
context menu. To freely scale and move the image, use the input fields in the Inspector > Image.
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Rows

Select row

With the table tool selected, click on the row bar of the row you want to select.

Change row height

Manually: With the table tool selected, move the mouse pointer to the bottom edge of the row
whose height you want to change and, keeping the left mouse button pressed, drag the bottom
edge of the row to the desired position.
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Via Input: As described above, select the row whose height you want to change and enter the de-
sired height in the input field Height in the Inspector Table > Rows.

Note: Changing the row height is only possible if the check box Fit Height to Text is deactivated in
the Inspector Table > Rows.

Insert or delete rows

Insert one row: Select the line after which you want to insert a row and choose Insert Row from
the context menu.

Insert multiple rows: Select the row before or after which you want to insert rows and choose the
Insert Rows command in the context menu. 
In the following dialog box, you specify the number and position of the rows to be inserted. Click on
the [OK] button to complete the process.

Delete row(s): Select the row(s) that you want to delete and choose Delete Rows from the context
menu.

Move Rows

Manually: Select the row(s) you want to move and, keeping the left mouse button pressed, drag the
row(s) vertically until a thick black line appears at the desired position.
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Via input: Select the row(s) that you want to move and choose the Move Rows... command from
the context menu. In the following dialog box, you define the new position of the selected rows. Click
on the [OK] button to complete the process.

Swap rows

With the table tool, select the rows that are to be swapped with each other by holding down the
<Ctrl> or <Cmd> key and select the command Swap Rows from the context menu. This swaps the
complete rows with all attributes, such as background colors. 

Swap Row Content

With the table tool, select the rows that are to be swapped with each other by holding down the
<Ctrl> or <Cmd> key and select the command Swap Row Content. Only the content is swapped,
all attributes remain in their original positions.

Fit Rows to Frame

With this command you can adjust the height of one or more rows so that the text frame containing
the table is completely filled. To do this, select one or more rows whose height you want to change
by holding down the <Ctrl> or <Cmd> key and select the Fit Rows to Frame command from the
context menu. The available space is distributed evenly over the selected rows.

Note: This function is only available if the check box Fit Height to Text is deactivated in the In-
spector Table > Rows.

Fit Rows to Text

You can use this function to adjust one or more rows that contain overset text or underset text to the
amount of text they contain. Using the table tool, select one or more rows with the <Ctrl> or <Cmd>
key pressed and choose the command Fit Rows to Text from the context menu. The calculation is
based on the height of the text row(s) plus the top and bottom insets defined in the cell style.

Hide Rows

Use the table tool to select one or more rows to be hidden by holding down the <Ctrl> or <Cmd>
key and choose Hide Rows from the context menu. The data of the hidden rows is retained and
can be displayed again by right-clicking on the row bar and selecting the Show All command.

Lock Rows

With the Lock Rows > Upward/Downward command, a row area of the table can be partially pro-
tected against changes. Rows cannot be moved, deleted or inserted in the locked area. Text and at-
tributes can still be edited.

To do this, right-click in the row bar of the line from which you want to fix and select the context
menu command Lock Rows > Upward or Downward. The locked rows are indicated by red hatch-
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ing in the row bar. To remove the lock, right-click in the row bar of the locked area and choose
Lock Rows > Unlock All from the context menu.

Go to next Frame

With this command you move the selected and all following rows to the next linked frame. To do
this, right-click in the row bar of the row from which you want to move and choose Go to next
Frame from the context menu.

Columns

Select column

With the table tool selected, click on the column bar of the column to be selected.

Change column width

Manually: With the table tool selected, move the mouse pointer to the right edge of the column
whose width you want to change and, keeping the left mouse button pressed, drag the right edge of
the column to the desired position. 

Via Input: As described above, select the column whose width you want to change and enter the
desired width in the input field Width in the Inspector Table > Columns.

Insert or delete columns

Select the column before or after which columns are to be inserted and choose the command In-
sert Columns... from the context menu. 
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In the following dialog box, you specify the number and position of the columns to be inserted. Click
on the [OK] button to complete the process.

To delete one or more columns, select the column(s) to be removed and choose Delete Columns
from the context menu.

Move columns

Manually: Select the column(s) you want to move and, keeping the left mouse button pressed, drag
the column(s) horizontally until a thick black line appears at the desired position.

 

Via Input: Select the column(s) you want to move and choose the Move Columns... command
from the context menu. In the following dialog box, you specify the new position of the selected
columns. Click on the [OK] button to complete the process.

Swap columns

Using the table tool, select the columns that are to be swapped with one another by holding down
the <Ctrl> or <Cmd> key and select the command Swap Columns from the context menu. This
swaps the complete columns with all attributes, such as background colors. 



Working methods   Working with tablesMarkStein Publisher Manual

© 2022 MarkStein Software GmbH 406

Swap column content

With the Table tool, select the columns whose contents are to be swapped with each other by hold-
ing down the <Ctrl> or <Cmd> key and select the command Swap Column Contents from the con-
text menu. Only the content is swapped, all attributes remain in their original place.

Fit columns to frames

With this command you can adjust the width of one or more columns so that the text frame contain-
ing the table is completely filled. To do this, select one or more columns whose width you want to
change by holding down the <Ctrl>> or <Cmd> key and select the Fit Columns to Frame com-
mand from the context menu. The available space is distributed evenly over the selected columns.

Hide columns

Use the table tool to select one or more columns that you want to hide by holding down the <Ctrl>
or <Cmd> key and choose Hide Columns from the context menu. The data of the hidden columns
is retained and can be shown again by right-clicking on the column bar and selecting the Show All
command.

Lock columns

With the Lock Columns > To the Right/Left command, a column area of the table can be partially
protected from change. Columns cannot be moved or deleted in the fixed area, nor can columns be
inserted. Text and attributes can still be edited.

To do this, right-click in the column bar of the column from which you want to lock and select Lock
Columns > To the Right or Left from the shortcut menu. The locked columns are indicated by red
hatching in the column bar. To remove the lock, right-click in the column bar of the locked area and
choose Lock Columns > Unlock All from the shortcut menu.
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Table example
Below are instructions for the pre-work and the creation of a table.

Create table style sheet
In this example, we will create and set up a table style sheet, limiting ourselves to the most neces-
sary steps. For further information, please refer to the inserted links to the respective topics.

Before you create a table style sheet, you should already have set up a style sheet with the required
paragraph and text styles that can be assigned to the respective cell formats. For a simple table,
this should have the formats

· Title

· Head

· Body text

· Annotation

with the text styles required for your purposes.

Use the Panels toolbar to open the Panel Table Styles and click on the left icon with the + sign.

The Table Styles panel

The Properties - Table Style Sheet window opens.



Working methods   Working with tablesMarkStein Publisher Manual

© 2022 MarkStein Software GmbH 408

The window Properties - Table Style Sheet

On the Basic Options tab page, assign a name for the new table style sheet. The Left/Top
Strokes, Stroke, Rows and Columns tab pages are analogous to the Inspectors Table described
in detail. 

Confirm your entries with [OK].

In the Table Styles panel, use the drop-down menu to select the newly created table style sheet.

A cell style “Default” was automatically created. Right-click the cell style and choose Properties...
on the shortcut menu.

We use this cell format here for the title row. Enter “Title” in the Name: field.

Switch to the Text tab. In the Inset Top and Inset Bottom fields, enter the value that you want the
text to be spaced from the top and bottom edges of the cell. In the Vertical Justification dropdown
menu, specify the justification within the cell, in this example “Align Center”.
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In the Paragraph Style and Text Style input fields, enter the names of the previously created para-
graph and text styles.

Switch to the Rows tab and activate the Fit Height to Text check box to allow the row to automatic-
ally adjust to the amount of text entered.

To visually separate the title row from the rest of the table, define a solid line 0.25 mm weight in
black. 
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Confirm the entries with [OK]. Then right-click in the Table Styles panel and choose New Cell
Style... on the context menu.

This cell format in our example should be for the table header. Assign the name “Header” in the
Stroke/Background tab. 

Switch to the Text tab and enter 2 mm each for the top and bottom inset and 1 mm for the left.

Choose “Align Centered” in the Vertical Justification dropdown menu. In the Paragraph Style and
Text Style input fields, enter the names of the previously created paragraph and text styles.

Switch to the Rows tab and activate the Fit Height to Text check box to allow the row to automatic-
ally adjust to the amount of text entered. Confirm the entries with [OK].

Since in our example the cell styles for the table body are not fundamentally different from those for
the header row, we can work with copy & paste here.

Right-click on the cell format “Header” in the panel and select the Copy command. Then right-click
in the free area of the list and choose the Paste command. 

Right-click on the newly created cell style “Header (2)” and select the Properties entry. 

Enter “Body” in the Name field on the Stroke/Background tab. In the Background drop-down
menu, select a color and reduce the Tint value to 25%.

Switch to the Text tab and enter the names of the previously created paragraph and text styles in
the Paragraph style and Text style input fields. Confirm your entries with [OK].

For our example, we still need a style for the table body with an alternative background. To do this,
copy and paste the “Body” style as described above and choose Properties from the context menu.
On the Stroke/Background tab, reduce the Tint value of the background color to 10%. Confirm the
entries with [OK].
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In the last step we create the cell style for the annotation. To do this, make a copy of the cell style
“Title” and change the name of the copy to “Annotation”. (The “Title” style was chosen to give the
table a horizontal line at the end.) On the Text tab, reduce the top and bottom inset to 1 mm.
Change the vertical justification to Align Bottom and the horizontal justification to Right. Enter the
names of the previously created paragraph and text styles in the Paragraph style and Text style
input fields. Confirm your entries with [OK].

The table style sheet now contains all cell styles required for a simple table. Additional cell styles
can be added or unnecessary ones deleted at any time.

The completed table style sheet Example Table

Create tables

Creating a table without data

To create an empty table, first a text frame is drawn up or an existing text frame or text concatena-
tion is selected. The frame is converted into a table by selecting the table tool from the toolbar or
by selecting the Create Table command from the Table menu.

The Table Wizard, which opens automatically after selecting the command or the table tool, is
used to define the table geometry (number of rows, columns, headers, footers, annotation, etc.) and
the visual appearance of the table by selecting the appropriate table and cell style sheet.

To create an empty table now, first use the Text Frame tool to draw a text frame and immediately
switch to the Table tool, which opens the Table Wizard.



Working methods   Working with tablesMarkStein Publisher Manual

© 2022 MarkStein Software GmbH 412

First page of the Table Wizard

On the first page of the Table Wizard, you specify the style sheets for text and table, and the num-
ber of rows and columns in the table. 
You define the settings for automatic change of cell styles and the rhythm of the change in the se-
lection menus Cell style 1 and 2 and the input field Alternate every: X rows/columns.
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Second page of the Table Wizard

On the second page of the Table Wizard, you determine the structure of the table, i.e. the number
of title, header and footer rows or columns and the annotation.

Enter the required number of rows in the respective input fields and select the cell style from the
Style drop-down menus.
Headers and footers can be repeated automatically if the table runs over several linked frames. To
do this, activate the Repeat check box.
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The empty table created according to the information in the table wizard

The same table with inserted sample text

The table can now be edited in layout or galley view, checked out for further processing at another
workstation and saved as a layout or story template.

Create table by placing an Excel or CSV file

Drag a text frame to the desired size.

Select the File > Place ... command.

Select the file to be placed and confirm the dialog by clicking the [Open] button.

https://en.wikipedia.org/wiki/Comma-separated_values
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After selecting the Open command, the mouse pointer displays the loaded file.

Click with the “loaded” mouse pointer in the text frame provided.

Make all the necessary settings in the Table Wizard and confirm the entry by clicking the [Finish]
button.

The table is completed and can be processed further.

Note: When placing an Excel spreadsheet or a CSV file, the document to be placed is analyzed and
the number of rows and columns is already set in the Table Wizard and cannot be edited. 
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Working with fonts

Before you start building the publication, you should import the required fonts at all the stations in-
volved. The easiest way to do this is to use the Font Management program on Windows or the Font
Collection program on Apple macOS.

Note: If you have imported new fonts via the operating system, you must restart the program after-
wards. Otherwise, the new fonts will not be displayed in MarkStein Publisher.

Usable fonts

In MarkStein Publisher you can use the following font formats:

· Opentype PostScript (highly recommended)

· Opentype TrueType

· TrueType from version 2

The fonts must be available in the appropriate version for the respective platform. Only Opentype
fonts are platform-independent and can be used under both Microsoft Windows and Apple macOS.
Also they can be used for web applications.

We highly recommend using Opentype fonts in the PostScript variant, as they represent the
most modern font format and offer the most design possibilities (extended character sets, typo-
graphic variants).

PostScript Type 1 fonts, known since 1984, are operating system-specific and cannot be used
across operating systems. Adobe has announced end of support for this format on December 31,
2022. MarkStein Publisher ends support for this font format with version 8 of the software.  

We do not recommend using TrueType fonts or Opentype fonts of the TrueType variant, since
MarkStein Publisher has been optimized for working with PostScript fonts and printing is done using
a separate PostScript driver. TrueType fonts may also cause problems in connection with PDF gen-
eration.

Please note: Old TrueType fonts of version 1 and PostScript Type 1 fonts cannot be used. These
are not displayed in the font selection list! Truetype Collections (*.tcc) are also not supported by
MarkStein Publisher.

Fonts under Microsoft Windows

All generally usable fonts are located in the C:\Windows\Fonts folder of the operating system. To in-
stall new fonts, double-click the font file in any folder.

Fonts under Apple macOS

macOS knows the following folders for storing fonts:

· System/Library/Fonts (system fonts)

· Library/Fonts (main font collection, for all users)

· Users/[Name]/Library/Fonts (Private fonts, only for the respective user)

The local folder /Library/Fonts is the appropriate place for fonts that should be made available to all
users. Use the Font Collection application provided by the Apple macOS operating system to copy
the fonts to this folder. Drag-and-drop and double-click installation are not suitable for this purpose.
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Using fonts exclusively in MarkStein Publisher

You can also use fonts in MarkStein Publisher without permanently installing them on the computer.
To do this, copy the font files to the internal fonts folder, which you can access via Extras > Fonts...
This opens an explorer window in the fonts folder. Or you can use the command Extras > Add
Fonts... to copy fonts from another folder. The fonts located in the program's fonts folder are
loaded when the program starts and are used only within the program. They are not visible to other
applications on your computer. Note, however, that if you have a large number of fonts, the loading
time of the program may increase.

Note: If you have imported new fonts into the internal folder, you must restart the program after-
wards. Otherwise, the new fonts will not be displayed.
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OpenType features

Introduction

In OpenType fonts, special glyphs can be integrated into a font, such as ligatures, or even complete
character sets, such as small caps or a Cyrillic character set. Likewise, a font can contain multiple
character shapes for individual characters. All this is realized via the so-called OpenType features.

MarkStein Publisher offers the possibility to use these feature via a text style included in the para-
graph style or individually for single words or text sections via the context menu.

The possibilities offered depend entirely on the font chosen; a font from a renowned manufacturer
offers far more variation than a free font from an Internet portal, even if it is available as OpenType.

  

On the left, a free font with only 233 characters; on the right, a font from Adobe that contains over 2,500 characters.

To get an overview of the characters contained in a font and their variants, open the Glyphs panel
and click the Show drop-down list.

After you select an entry from the drop-down list, only the glyphs that match the selected criterion
are displayed.
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On the left, the drop-down list for selecting variants; on the right, all ligatures contained in the font are displayed.

Apply OpenType features via style

To assign the desired OpenType features to a style, right-click the name of the text style subordin-
ate to a paragraph style and choose Properties from the context menu.
Switch to the OpenType tab.

Properties Font, OpenType tab.

Select the desired options and confirm with [OK].
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Apply OpenType features via context menu

To assign the desired OpenType features to a word or a text section or to deactivate them for the
passage in question, select the text passage in question and choose one of the options on or off in
the OpenType menu item.

The OpenType context menu

Examples

Digit variants

Proportional lining figures: Digits of different thickness (width), according to the character in
question.

Tabular lining figures: Digits of the same thickness, regardless of the actual width of the digit.

Lining figures: Digits in the versal height of the respective font.

Oldstyle figures: Digits with ascenders and descenders.

Different types of figures

Proportional figures result in a balanced typeface, while in tabular figures in right alignment the fig-
ures as well as the number separators are placed one below the other.

The proportional oldstyle figures integrate particularly well into the continuous text.
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Small Caps

Small caps are uppercase letters at the same height as lowercase letters. They can be created
electronically by scaling the uppercase letters, or they can exist as a separate font or be integrated
in an OpenType font.

The disadvantage of electronically generated small caps is the difference in stroke width between
the reduced lowercase and the unchanged uppercase letters caused by the reduction in size.

Examples for Small Caps

Ligatures

Ligatures are multiple glyphs that have been combined into one glyph for aesthetic, typographic, or
orthographic reasons. 

Examples of typographic ligatures are compounds of ff, fi, ffi, fl, for orthographic ligatures æ, Æ, œ,
Œ.

Examples for Ligatures
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Package

To share a document with all images placed and fonts used, the menu item Package... is available
in the File menu. 
This function is suitable for exchanging with service providers and customers or for archiving.

The menu item Package... in the File main menu

After selecting the menu item, the Package dialog box opens.

The dialog box Package
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Path: Use the button with the three dots to select a location for the package to be created.
At the selected location in the file system, a folder with the name of the document to be packaged is
automatically created at the beginning of the process.

Copy fonts: Check this box if fonts used in the document should be included in the package.

Copy linked images and graphics: Select this check box if images and graphics placed in the
document are to be included in the package.

Click the [OK] button to start the process.

The progress is displayed in the following window. Via the button   you can copy the log to the
clipboard.

Packing progress info

Clicking the [Close] button completes the process. 

The folder created at the beginning now contains a copy of the Publisher document, the Links
folder with all the images and graphics placed in the document, and the Fonts folder containing the
fonts used in the document.
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 View of the target folder containing the elements of the package
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Collaboration
This is a function of MarkStein Publisher Workgroup Edition.

In this section, you will learn more about the functions and approaches that enable you to work to-
gether in a group of writers and graphic designers.
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Introduction

General

MarkStein Publisher Workgroup Edition is intended for working groups in which multiple employees
work together, possibly from different locations. This is the case when copywriters and graphic de-
signers are to work on a single object from different locations. A fixed workflow can thus be applied
to the creation of brochures, magazines and books. The work steps (and their completion) can be
defined using status, which are visible to all those involved in the project. Three predefined status
can be used for texts and images.

Collaboration takes place using shared folders on cloud-based services such as Dropbox or
Google Drive.

By using story templates, a frame geometry, the shape and size, a style sheet, and paragraph and
text styles can be assigned to an article during its creation. Both copywriters (editorial office) and
graphic designers (layout) can create a new story using a story template. Once it has been edited
by the copywriter, this story can be placed in any position in the document and edited again if ne-
cessary. This working method is useful for stories that are published regularly and have a fixed
structure, such as editorials or comment pieces.

In the case of stories with a less defined structure, however, the graphic designer would first com-
plete the design and then provide it to the copywriter using the check out function.

Collaboration via the Cloud

The program MarkStein Publisher Workgroup Edition is designed to work in the following manner
when collaborating via cloud: The graphic designer creates a layout document (.mxd), tags each in-
dividual contribution as an article (.mxt), and shares each article with an editor. Each layout docu-
ment is always edited by one graphics designer. Since the locking mechanisms of files are not ef-
fective via cloud storage such as Dropbox due to the asynchronous mode of operation, it must be
ensured in the workflow that each file is only edited by a single person. Note: It is not intended that
a layout file (.mxd) is edited by more than one person at a time.

Collaboration in the internal company network

The situation is different if the files are located on an internal network (a server with direct access of
the workstations). Here the layout file (.mxd) is reported as locked if a second person tries to ac-
cess it. In this case, all computers (Windows/Mac) must be connected to the server via a direct net-
work connection and must access the server via an SMB file share. In this case, multiple people
can work on a layout file (.mxd), but of course only one person at a time.

The SMB file share ensures that the document is only available for editing to exactly one person at
one workstation at a time. This means that access attempts from other workstations are rejected
with the message: “Access not possible. Document is currently being edited.”.
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Editing stories externally

On the next few pages, you will find information on working with stories and status in MarkStein
Publisher Workgroup Edition. Stories are texts that are either composed without formatting or are
already linked to a style sheet or even a geometry (story template).
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What is a story?
In its simplest form, a story is merely a text file without formatting, for example when neither the
scope nor the use has been decided when the text is composed. In this case, MarkStein Publisher
acts as a word processor for authors delivering texts.

Stories without formatting for composing text as raw text

However, MarkStein Publisher also offers the option of allocating a style sheet to a story to be cre-
ated, in order to define the right text structure for composing the text.
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Here, a style sheet has been allocated to the story: The text is already divided into “Title”, “Copy” and “Caption”.

These versions are ideal for the Text and image before layout approach.

If the scope and additional elements like images and charts have already been decided for a story,
you can assign a story template to the story even before composing the text. This enables the story
to be edited with the precise number of lines. This method is suitable for the Layout before text and
image approach.
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In this version, the writer sees the text as a banner in the planned set width in the left-hand window. Block changes, line
and column breaks, overset and underset are displayed. 
At the same time, the layout view is shown in the right-hand window. Editing can take place in both windows.
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Creating a new story
In the Start > New menu, click the New Story icon.

The Start menu

The New Story dialog window will open.

The New Story dialog window

Name: Give the new story a file name here.
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Path: Clicking on the three dots at the end of the line shows your file system, where you can define
where to save the file.

Library: In this drop-down menu, you can define which of your libraries to use for the story.

Style Sheet: Select the story template or style sheet for the story here.

When you click [OK], the story will open for editing.
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Placing stories on the page
Note: Before you place a story in your document, you should ensure that there are enough pages for
the story in the document.
If you place a multi-page story with geometry in a document, text and image frames for which no
more empty pages are available will be discarded.
However, the entire story text remains as overset in the text frame that was placed most recently.

Placing a story

Select the command File > Place..., select the story in the file system and confirm with [Open].

The cursor will now show the name of the story file you have opened and the outline of the link.

Preview of the story

Move the preview to the desired position in the document and place the story by left-clicking.

You can also drag the story file from the file system and drop it in the MarkStein Publisher work win-
dow.
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Check out
The Check Out function is used to provide a story for (external) editing. It creates an MarkStein
Publisher file that can be opened and edited in a shared directory for word processing. This has the
file extension .mxt.

Proceed as follows:

Use the selection tool to select an element in the story link and then use the menu command Con-
tent > Text > Check Out or right-click on an element and use the context menu Text > Check Out.

The dialog window Text > Check Out will open, in which you can define the file location and com-
plete the process by clicking [Save].

In the Text > Check Out dialog window, the first 16 characters of the story are automatically entered as the file name.

Once the story has been checked out, the text is automatically locked in the layout document; this is
shown by a red arrow in the text frame.

If you attempt to edit the text, a message informing you that it is locked will be shown.

Checked out, locked story
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Editing stories
To edit a story that has been checked out using MarkStein Publisher Workgroup Edition, go to the
Start window, click [Open] and navigate to where the story is saved in the file system. Select the
story you want to edit and click [Open].

The story document is opened from a shared directory

The story is opened in galley view by default. In this view, the text is displayed in the column width
defined in the layout.
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The story has been opened in the galley view and can now be edited.

The serial line numbering, separately for each paragraph style, and the name of each paragraph
style are shown in the line ruler to the left of the story text. You can hide or show the line ruler in the
View menu.

Within the story text, column changes are displayed with a dashed gray line, block changes with a
continuous gray line.

The color in which the numbering of the body text is shown changes depending on how “full” the
size of the text frame or link defined in the layout is.

Black = underset: The text frame or link is not quite full.

Green = full: The text fits perfectly into the text frame or link.

Red = overset: One or more characters do not fit into the text frame or link.

The exact number of lines is shown in the status bar at the bottom of the window, including the
number of missing or excess lines.
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View types

You can define the view type in the View menu or in the View toolbar. The options are:

Script: The text runs across the entire width of the window; only the paragraph styles are shown;
there are no line numbers; overset and underset are not displayed. Suitable for composing text us-
ing the Text/image before layout approach.

Galley: See description above.

Tile Horizontally: Simultaneously shows the galley and page views in a divided window.

Page View: Layout view with images.

Text can be edited in all view types.

Once you have finished editing the story, save and close the story so that it can be checked in to the
layout again.
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Check in
To check in a story – which has been previously checked out – back into the layout document, use
the selection tool to select an element in the story link and then select the menu command Content
> Text > Check In or right-click on an element and use the context menu Text > Check In.

This command applies the text from the story document and deletes the document. If the story doc-
ument is still open on a workstation, the story cannot be checked in.

In addition to the Check in command, the menu and toolbar also offer further options:

Detach: This command suspends the connection between the layout and story document without
deleting the story document. Changes made in the meantime will not be applied to the layout docu-
ment.

Synchronize: This loads the latest version of the story into the layout document without suspend-
ing the connection or deleting the story document.
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Working with status
With MarkStein Publisher Workgroup Edition, you have the option of making your workflow trans-
parent by assigning status. Images, texts and pages can each carry their own status.

The following are available:

· Draft – marked in blue,

· Working – marked in yellow,

· Ready – marked in green.

Newly created objects are automatically given the status “Draft”.

Show Status

To show the status for individual objects in the layout, go to the View menu and select one or more
of the items Show Page Status, Show Image Status or Show Text Status. This causes text and
image frames to be marked with a dot in the status color. In the “Draft” and “Working” status, a
frame in the relevant color is placed around the page. The “Ready” status is marked with a green X
across the page.
You can also find out the page status from the page panel; it is shown by the colored markings in
the preview and in the text in the list view.

Layout view showing the status for pages, image and text

To show the status of all elements for the entire document, select the command View > Status
View. The program also switches to the status view if you do not meet the value for the view size
defined in Preferences > View > View > Original View from

https://de.wikipedia.org/wiki/Arbeitsablauf
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The same pages in the status view

Changing the image status

Select the image frame using the selection tool and select an entry from the menu Content >
Image > Status. Alternatively, right-click on the frame and select an item from the Image > Status
context menu.

Changing the text status

Select the text frame or a frame in the link using the selection tool and select an entry from the
Content > Text > Status menu. Alternatively, right-click on the text frame or a frame in the link and
select an item from the Image > Status context menu.

In word processing mode, select the command File > Status and select an entry.

Changing the page status

To change the status of the current page, select an item in the Page > Status menu. Alternatively,
right-click on an empty area on the page or on the relevant page in the pages panel. Then use the
Status context menu to select the desired status.
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Personalization
In the Extras > Preferences or MarkStein Publisher > Settings menu, you can adapt MarkStein
Publisher to your preferences and the way you work. You can find instructions for doing this here.

The settings you choose apply to the program. This means, for example, that a document created
with different settings for the display colors of page margins, line grids etc. will be adapted to the
settings you have chosen.

In the Extras > Keyboard > Edit Keyboard Shortcuts... menu, you can change existing keyboard
shortcuts or create new ones. You can find instructions for doing this here.
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Preferences for program

Using the menu item Extras > Preferences (Windows) or MarkStein Publisher > Settings (Mac),
you can set preferences for document display, word processing, standard settings for text and im-
age frames, import settings for text and images, and the measurement units to be used. Settings
made apply to the program. Documents created at a different workplace with different settings will
open with their own settings.

The window is divided into themed sub-points, in which you can make the relevant settings.

You can reset the preferences to the basic settings used when the program was installed by click-
ing the [Default] button.

Layout

Layout preference window

Color

Lines: Select the color of the line grid from the drop-down menu.

Margin: Select the color of the grid reference lines from the drop-down menu.
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Page: Select the color in which the page reference lines are displayed from the drop-down menu.

Columns: Select the color of the column lines from the drop-down menu.

Bleed: Select the color in which the bleed around the document page is displayed from the drop-
down menu.

Current Page: The page margins on the current page are marked in color. Select a color for the
marking from the drop-down menu. Frame edges and user-defined reference lines are always
shown in the color of the respective level.

Text Frame: Use the drop-down menu to select the color in which the areas of text frames are to
be displayed in the status view.

Advert Frame: Use the drop-down menu to select the color in which the areas of advert frames are
to be displayed in the status view.

Image Frame: Use the drop-down menu to select the color in which the areas of image frames are
to be displayed in the status view.

Image Position: Use the drop-down menu to select the color in which the border of the image con-
tent is displayed.

Snap Radius

Using the settings View > Line Grid > Magnetic and View > Reference Lines > Magnetic, you
can align objects precisely to reference lines. When you draw, move or resize objects, the object
edges are aligned to the nearest grid or reference line. The distance at which an object is attracted
by reference lines is known as the snap radius; you can set its size here.

Grid: Enter the distance from which you want objects to be attracted by the line grid shown.

Reference Lines: Enter the distance from which you want objects to be attracted by the reference
lines shown.

Snap to Whole Units: If you choose this option, new frames can only be created and moved in
whole increments of the measuring unit selected (for example whole millimeter or point incre-
ments).

To disable these functions temporarily, hold down the <Alt> key while completing an action.

Insert / Duplicate

In this section, you can enter an offset value that will be used when copying, inserting and duplicat-
ing objects.

Offset X: Enter the horizontal offset value here.

Offset Y: Enter the vertical offset value here.
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Size Change for Multiple Activation

The preference for size change for multiple activation determines the method used when the size of
multiple selected frames is changed simultaneously.

Proportional: If you select the Proportional option, the positions of the selected frames change in
proportion to the size change.

Linear – all: If you select the Linear – all option, the positions of the frame remain unchanged and
the size change is only executed in the desired direction.

Linear – adjacent: If you choose the Linear – adjacent option, the change only applies to objects
adjacent to the edge being moved.

When you change the size by dragging, holding down the <Shift> key at the same time will cause
the change to be executed proportionately.

AutoScroll acceleration

The choice you make here defines how fast the image section scrolls when you move or resize an
object beyond the edges of the image section.

direct: Choose this option if you want to scroll without delay.

delayed: Choose this option to delay scrolling.

Select Panel

Select by Hovering over For XXX msec If you choose this option, the panel will open after the
time set when you hover the cursor over the icon in the Panels toolbar. Enter a value between 1 and
1,000 milliseconds or click on the arrow.

Select by Mouse-Click: If you choose this option, the panel will open when you click on the icon in
the Panels toolbar.

In both options, the panel automatically closes as soon as the cursor is moved out of the panel, un-
less you drag the panel to a different position on the screen by clicking and dragging the caption
area.

Mode

Edit Text by Pressing Alt and Mouse Button. Select Link by Double-Clicking: If you select this
option, you will enter word processing mode when you click in a text frame while holding down the
<Alt> key. Double-clicking selects the entire link.

Edit Text by Double-Clicking. Select Link by Pressing Alt and Mouse Button: If you select this
option, you will enter word processing mode when you double-click. You can select the entire link
by clicking on a frame that belongs to the link while holding down the <Alt> key.
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Text

Text preference window

Edit

Entries replace selected sections: This option is selected by default. Selected text is replaced as
soon as a new character is entered. If you deactivate the option, the selection is removed and the
new text entered in front of the selected text. The text behind the selection is pushed back.

Edit Text Using Drag & Drop: If you select this option, you can move and drop selected text by
holding down the mouse button and dragging. The program behaves in the same way as when us-
ing the Cut and Paste functions.

If you hold down the <Ctrl> or <Cmd> key at the same time, the text will be copied instead of
moved. The program behaves in the same way as when using the Copy and Paste functions.

The following options are possible for text:

· Dragging and dropping within a story

· Dragging and dropping between different stories

· Dragging and dropping from an external program

· Dragging and dropping into an external program
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Table areas selected in text mode can also be moved or copied when the mouse button is held
down:

· Dragging and dropping within a table

· Dragging and dropping between different tables

· Dragging and dropping from Microsoft Excel

· Dragging and dropping into Microsoft Excel

Insert Text Without Style When Using Drag & Drop: If you select this option, texts that are
moved in MarkStein Publisher automatically adopt the style of the target paragraph.

Overwrite Mode at Program Start: MarkStein Publisher works in insert mode by default – new text
is inserted in the cursor position. When this option is selected, a character is deleted to the right of
the cursor positions for each character entered.

No Processing of Next Styles: Next styles can be specified in the paragraph properties. The next
style is applied after the end of a paragraph. Choose this option to prevent the defined next styles
from being applied.

Warning When Deleting Text Sections Including Markers: If a text contains markers, such as re-
gister entries, bookmarks etc., by default these are deleted without notice when a text section is de-
leted. Select this option if you want to receive a warning about the type and number of markers to
be deleted.

Insert using Drag & Drop

Insert as hyperlink: If you select this option, images inserted in the text by drag & drop are not dis-
played, but a hyperlink to the image file is inserted. 

As frame anchored in text: If you have selected this option, the inserted image is anchored to the
text at the cursor position where you release the mouse button.

As frame anchored in paragraph: If you select this option, the inserted image will be anchored to
the beginning of the paragraph, regardless of where you release the mouse button.

Color

Block marking: Select the color for text marking from the drop-down menu.

Colored Text as of a Brightness Of: This setting only takes effect during word processing as a
script or proof. Colored text in a bright color or a low tonal value that has a dark background in the
layout that makes it easy to read in Layout view is difficult to read in proof or script mode, as the
background there is white. Enter a percentage from which you want colored text to be shown in the
selected color.

View:

When editing text, it can be useful to display non-printable characters, such as spaces, tabs etc.
Here you can select the non-printable characters that you want to be displayed when the View >
Non-printable characters command is selected.

Page View for Stories and Tables That Are Not Assigned

Select the page size in which a newly created or exported story should be shown in the page view.

End of Line

Select the keyboard shortcut with which a line end can be inserted without starting a new para-
graph.
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Text Frame

Text Frame preference window

Border

Here you can define default settings for line weight, style, position, color and tint, corner radius and
the baseline grid for new text frames. In the Gutter section, enter the column spacing that should
be used by default when a text frame is to contain multiple columns of text.

Background Transparent While Drawing: Select this option if you want to create new text frames
without area fill, i.e. with the color “None”. If the option is not selected, new text frames will be cre-
ated with the background color “White”.

Text wrap is activated for each new text frame by default. To deactivate text wrap for new frames,
deactivate the Text Wrap Active option.

Style

Even if no style groups with paragraph and text properties have been created, you can enter text in a
text frame. In the Style section, you can define the paragraph and text formatting for texts without
style groups. Click the [Paragraph] button to define default settings for paragraph styles. Use the
[Text] button to define default settings for text styles.
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Import

Import preference window

Text

Delete empty lines: Select this option if you want empty lines to be deleted automatically when text
is imported.

Convert Tabs to Spaces: Select this option if you want tabs to be converted into spaces when text
is imported.

Dashes: You can use the drop-down list to define how you want dashes to be converted when text
is imported.

If you select the No Conversion option, they will not be converted. If you select the EN Dash Width
option, dashes will be converted to EN dashes. The EM Dash Width option converts them to EM
dashes.

Font Type: You can use this option to define how the fonts should be loaded when an RTF text is
imported.

Do Not Apply: The text is imported in line with your preferences, which you have defined in the Text
Frame section. The fonts used in the original document are not applied.

Only Apply Font Style: The text is imported in line with your preferences, which you have defined in
the Text Frame section. If mark ups such as italic, bold etc. were defined in the original document, the
relevant fonts are applied when the text is imported.

Fully Apply: If different fonts and styles were used in the original document, these are applied when
the text is imported.
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Apply Special Fonts: Select this option if you want fonts used in the original document (such as
special characters in fonts such as Zapf Dingbats) to be applied when a text is imported.

Footnotes

If a document to be imported contains footnotes, you can use the drop-down menu to define
whether the footnotes should be imported as real end notes or as normal paragraphs.

Apply Footnotes During RTF Import: If an RTF document to be imported contains footnotes, you
can use these options to define whether they should be applied when the text is imported.

Apply Footnotes from Clipboard: If you have copied a text that contains footnotes from Microsoft
Word or an RTF document to the clipboard and this option is selected, the footnotes will be applied
as end notes when the text is pasted.

Enumerations

Apply Bullet Points During DOCX Import: If a DOCX document to be imported contains bullet
points, these will be applied if this option is selected. In the drop-down menu, you can choose
between the options As Text and As An Actual Enumeration.

Apply Bullet Points During RTF Import: If an RTF document to be imported contains bullet
points, these will be applied if this option is selected.

Apply Bullet Points From Clipboard: If you have copied a text that contains bullet points from Mi-
crosoft Word or an RTF document to the clipboard, selecting this option means that the bullet
points will be applied when the text is pasted.

Comments

Apply Comments as Notes During DOCX import: If a Word document contains comments, these
will be applied as notes if you select this option.
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Image Frame / Image

Preferences window Image Frame / Image

Assign / Place

Fit to Frame: You can use this option to define how images should be adjusted to the frame when
assigned.

Minimum Size: If this option is selected, the image content will be adjusted so that the entire image
content is always visible and no content is cropped out. This may mean that the image frame is not en-
tirely full either horizontally or vertically.

Maximum Size: If this option is selected, the image content will be adjusted to fill the entire frame.
Parts of the image will not be visible either vertically or horizontally.

Keep Original Size: Select this option if you want images to be loaded in their original size, rather
than adjusted to the frame size, when they are assigned to an image frame.

Scale to Specified Effective Resolution: Select this option if you want images to be scaled to the
resolution specified in the entry field when they are placed.

Center: Select this option if you want the image content to be centered in the frame when an image
is assigned.

Keep Position and Scale When Replacing: Select this option if, in an image frame that contains
an image, you want a newly assigned image to retain the position and scaling of the loaded image.
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If the option is not selected, the image will be repositioned in the image frame in line with your pref-
erences.

Change Image Size: If you choose the option Keep Aspect Ratio When Changing Size, the size
of the image content will always be increased or decreased proportionately when you change the
image size by dragging with the content tool. If this option is not selected, the size of images is in-
creased or decreased disproportionately, unless you hold down the <Shift> button while dragging.

Fit

Using the command Content > Image > Fit > Keep Aspect Ratio, you can adjust the assigned im-
age proportionately to the image frame.

Minimum Size: Select this option if you want the image content to be adjusted so that the entire
image content is always visible and no content is cropped out.

Maximum Size: Select this option if you want the image content to be adjusted so that the entire
image frame is filled.

PDF (Positioning only possible in MarkStein Publisher Professional Edition and MarkStein Pub-
lisher Workgroup Edition)

Extract Text from PDF/AI: When this option is selected, the text from a PDF or AI file is extracted
during loading and displayed in the Content > Image > PDF/AI Properties... dialog window in the
Text Content tab. The text can be copied from there for further use.

Stroke

Here you can define default settings for line weight, style, ends, position, color and tint, as well as
the corner radius for new image frames.

Background Transparent While Drawing: Select this option if you want to create new image
frames without area fill, i.e. with the color “None”. If the option is not selected, new image frames
will be created with the background color “White”.

Text Wrap Active: Text wrap is activated for each new image frame by default. To deactivate text
wrap for new frames, uncheck the Text Wrap Active option.
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Line

Line preference window

Default Values

Here you can define the line weight, style, start, end, color, tint and opacity for new lines.

Frames & Objects

Frames & Objects preference window

Apply Layout Template

Fit Frames to Text: If this option is selected, the text frame of the layout template automatically ad-
justs to the existing text.

Apply Images From Existing Frame Chain: If this option is selected, the images from the existing
link are applied when a layout template is assigned.

Remove Empty Image Frames/Remove Corresponding Photo Credit Frames: Select this op-
tion to remove empty image and caption frames when a layout template is assigned.
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Import Snippets

Here you can define how an object previously exported as a snippet (.mxs) should be placed. Ori-
ginal Position places the object in the position it held during export; the Cursor Position option al-
lows you to choose where to position the object.

Values / Units

Preferences window Values / Units

Units

Horizontal: Select the horizontal measurement unit for the ruler and objects.

Vertical: Select the vertical measurement unit for the ruler and objects.

Font: Select the measurement unit for font sizes.

Show Actual Units: Select this option if you want entries with units that differ from this preference
to be displayed. Otherwise, these entries will be converted into the preset unit.

You can choose between Millimeter, Point and Didot Point.

The following conversions apply:

DTP Point (pt) to mm: 1 pt = 0.352777 mm
Didot point (P) to mm: 1 P = 0.376 mm

Proof/Script

Leading: Here you can define the spacing between the lines and different blocks in the galley proof
and script views.
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Script: The leading currently set in the selected style sheet is not used in the proof and script view.
The leading of the screen lines can be increased or decreased in script and proof mode. Values
between 25% and 400% are permissible. 200% means twice the leading compared to the print.

Block Change: In the case of a block change, the spacing stated is entered in order to highlight the
block change.

Column Change: In the galley proof view, text is always shown continuously. In the case of a
column change, the spacing stated is entered.

Show Block and Column Separators: Selecting this option results in block and column changes
being highlighted in the proof by horizontal lines.

Script Width

Adjust Automatically: If you select this option, the width of the text will be automatically adjusted to
the width of the working window in script mode. The writing width is around 80% of the window
width. Deactivating the option allows you to define the width of the text. If you want to print in manu-
script mode, you need to select a fixed width at which the text is displayed and printed.

Document

Document preference window

Layout

Original: If you select this option, documents will be opened in the original view. All elements that
are not to be printed are hidden. You can select the menu command View > Original or use the
keyboard shortcut <Ctrl> + <Alt> + <Shift> + O (Win) or <Cmd> + <Alt> + <Shift> + O (Mac), to
switch between layout and original views at any time.
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Show Line Grid/View Columns: Select these options to show the line grid and/or column refer-
ence lines automatically when a document is opened.

Line Grid / Columns in Front: Select this option if you want the line grid and the column reference
lines to be shown in front of the objects. If this option is not selected, the line grid and the column
reference lines will be shown behind the objects.

Magnetic Lines / Columns: Select this option if you want objects to be attracted automatically to
line grid and column reference lines.

Invisible Line / Column Grid Magnetic: If this option is selected, the line and column grids are
magnetic even in original view.

Show Guides: Select this option to show the user-defined reference lines when a document is
opened.

Guides in Front: Select this option if you want the user-defined reference lines to be shown in front
of the objects. If this option is not selected, user-defined reference lines will be shown behind the
objects.

Magnetic Guides: Select this option if you want objects to be attracted automatically to user-
defined reference lines.

Invisible Guides Magnetic: If this option is selected, the reference lines are magnetic even in ori-
ginal view.

Show Rulers: Select this option to display the horizontal and vertical rulers when a document is
opened.

Adjust

You can use the command View > Fit Page to Window or the keyboard shortcut <Ctrl> + 0 (zero)
(Win) or <Cmd> + 0 (zero) (Mac) to adjust the page view to the window size.

According to Page Size: Choose this option if you want to use the Fit Page to Window command
to adjust the current single page to the window size.

According to Sheet Size: Choose this option if you want to use the Fit Page to Window com-
mand to adjust entire sheets or double pages to the window size.

Text

Show Non-Printable Characters: Select this option if you want non-printable characters to be
shown when the document is opened.

Show Markers: Select this option if you want markers such as notes, registers or text variables to
be shown automatically when a document is opened.

Show Style / Line Ruler: If you select this option, the paragraph formatting used will be shown in
the style column in script and proof mode, as well as the line ruler in proof mode.

Table

Table Grid Behind Lines / Column Lines Select this option if you want the table grid to be behind
the defined lines/column lines. If this option is not selected, the table grid will be displayed in front
of the defined lines/column lines.
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View

View preference window

View

Original View from: Define a value from which documents should be shown in original view. If the
value is not met, the status view is shown.

Zoom

Increment of magnifying glass (+/-): Define the factor by which, when the Magnifying Glass is ac-
tivated, a mouse click increases (left click) or decreases (right click) the size.

Export

Export preference window

Define whether the structure and/or properties of the e-book to be exported should be shown prior
to the EPUB export.

You can find basic information on exporting as an EPUB in the Output as e-book section of this
manual.



Personalization   Preferences for programMarkStein Publisher Manual

© 2022 MarkStein Software GmbH 459

Design

Design preference window

Colors

Toolbar: The background color of the toolbar, the control panel and the title bars of panels and in-
spectors. To change it, click on the color box and choose a color from the dialog that appears.

Borders: The color of the border between window and scroll bar in panels. To change it, click on
the color box and choose a color from the dialog that appears.

Background: The background color of panels and inspectors. To change it, click on the color box
and choose a color from the dialog that appears.

Highlight: The marking color of active windows. To change it, click on the color box and choose a
color from the dialog that appears.

Invert Text and Icons: Texts and icons are shown inverted.

[Light]: The default light setting is selected.

[Dark]: The default dark setting is selected.

[Preview]: Clicking this button displays a preview of the planned changes.

Menu

Show inactive items: All menu items are shown by default. Deselecting this option means that
menu items that have no function for a specific object will be hidden.
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Preferences for keyboard

Using this preference, you can edit or remove existing keyboard shortcuts or assign your own.

Open the Preferences window using the menu command Extras > Keyboard > Edit Keyboard
Shortcuts...

The preference window Edit Shortcuts

Filter: Enter one or more terms to limit the display in the overview. Example: If you enter “new”, only
commands that contain this term will be displayed.

New Shortcut: Click in the entry field beside it and use the keyboard to enter the shortcut you want.
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Defining a new shortcut

Currently Assigned To: This box shows whether the shortcut you have entered is already as-
signed to another command or is still free.

Current Shortcuts: The shortcut currently defined for the selected menu item is shown here.

[Assign]: Clicking this button assigns the shortcut to the menu command.

[Remove]: Clicking this button removes the assignment of a shortcut.

Click [OK] to complete the process.
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Other presets

Here you will find information about the Spelling and Autocorrection, Color management, and Pre-
flight settings.
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Spelling and Autocorrection

Spell check during typing

In all versions of MarkStein Publisher the Duden Proof Factory spellchecker is integrated. 

If the menu Extras > Dynamic spelling and Show Errors is activated, your input is immediately
checked for correct spelling. Incorrectly written and unknown words are underlined with a red zig-
zag line. 

Menu Extras > Spelling Defaults

Check spelling

If you want to check the spelling of texts that you have already written or are imported, there are two
additional options to choose from. To do this, place the cursor in the text and select one of the two
commands

Spell Check...: Checks the entire text from the position of the cursor.

Check Word...: Checks a marked word or the word in which the cursor is placed.

The Extras > Spelling menu for selected text

https://www.epc.de/unsere-loesungen/duden-proof-factory
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The Spell Check dialog

Not in dictionary: In the upper area, the word recognized as incorrect or unknown is displayed in
red and underlined in the context of the corresponding sentence. 

Ignore:/Ignore All: You can ignore this word once or ignore all occurrences of this word in the text.
If the highlighted word was spelled correctly but is not included in the dictionary, for example be-
cause it is a proper name, an artificial word or a foreign word, you can add this word to your private
dictionary by clicking the [Copy to Dictionary] button. This will no longer mark the word as an error
or unknown in the future. 

Change to: In this field, correct the misspelled word.

Change: Click this button to change the word in the text according to the correction word. The cor-
rection word is not entered in the user dictionary.

Change All: Click this button to change all occurrences in the text according to the correction word.
The correction word is not entered in the user dictionary.

Copy to dictionary: Click this button to add the correction word to the user dictionary and change
the word in the text at the same time.

If a suggested correction is already saved in the dictionary, it will be displayed in the Suggested
Correction: list. Select the appropriate word to transfer it to the Change to: field and click the
[Change] button to make the correction in the text.

To end the spell check, click the [Cancel] button.
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All pages: If you want the spell checker to run not only in the current frame or frame chain, but
throughout the entire document, enable this option. To restrict the spell checker to the active frame
or frame chain, deselect this option.

User dictionaries

The user dictionaries are stored in XML format and can be edited with a text editor such as Note-
pad. They can be found in the personal folder C:\Users\[username]\AppData\Roam-
ing\MarkStein\Dpf (Windows) or /Users/[username]/Library/Preferences/MarkStein (Macintosh).

Please note: Under Windows, "Show hidden files, folders and drives" must be activated in the Ex-
plorer settings under View / Options / View. On the Macintosh, this folder is only displayed if "Show
Library" is activated in the display options of the Finder.

Autocorrection

You can already work with autocorrection and text replacement during text input. With the Autocor-
rection... command, you can detect common typing errors and incorrectly capitalized letters and
have them automatically corrected.

To enable or disable the autocorrect options, select Extras > Autocorrect. The Autocorrection dia-
log box will appear, allowing you to specify the options that should take effect when entering text.

The Autocorrection window
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Options

Correct TWo initial CApitals: Activate this option if you want to automatically correct two capital
letters at the beginning of a word when entering text. If this option is enabled, the second letter of a
word is automatically converted to a lowercase letter if you have entered a second uppercase letter.

Capitalize first letter of sentence: If this option is enabled, the text is automatically converted after
a . (period), ? (question mark) or a ! (exclamation mark), followed by a space, the next letter is cap-
italized.

Quotation marks: Select the quotes to be used that are to be applied when entering using the key-
board with the <Shift>> + ' key or when loading a text. 

Replace text as you type: Activate this option if you want the words entered in the list to be correc-
ted automatically when entered.

Replace: Enter the character string to be replaced automatically when writing.

With: Enter the replacement text.

Click the [Add] button to add the entry to the list.

Special characters: If, for example, “cc” is to be converted into the “©” character during input, enter
“cc” in the Replace: field. Then switch to the With: field and click on the Special Characters button.
In the Glyphs panel, select the desired replacement character (in the example “Copyright”) and click
on the [Add] button.

Delete: To remove a replacement from the list, select it from the list and click the [Delete] button.

Once you have confirmed the entries with [OK], they are immediately taken into account when the
text is entered.
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Language for spell checking and hyphenation

Spell checking

MarkStein Publisher has English and foreign-language dictionaries in all editions, which are used
for spell checking and hyphenation. The assignment takes place down to the paragraph level using
the formats.

To assign the language setting to a style, right-click the name of the text style and select Properties
... from the context menu.

The context menu of a text style

Switch to the Language tab and select the desired foreign language for Spell Check and Hyphena-
tion from the Language drop-down menus. 
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Properties - Font, Language tab

If you want to change the language setting for only one text section without creating or changing a
text style, select the foreign-language text, right-click on it and select the entry Font... in the context
menu.
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The context menu of a selected text

The Properties - Font window described above opens, in whose Language tab you can make the
desired settings.

You can choose between the following languages:

Spelling

German, German (Austria), German (Switzerland), English (GB), English (USA), French, Italian,
Spanish

Hyphenation

German, English (GB), English (USA), French, Italian, Spanish
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Hyphenation

Setting the quality levels for hyphenation

Language: Use this selection list to enable hyphenation for the selected language. To disable hy-
phenation, select “None”.

Minimum Before: Enter the minimum number of letters that should precede a hyphenation.

Minimum After: Enter the minimum number of letters to be separated.

Quality: (German language only) MarkStein Publisher uses Dieckmann DIHYPH hyphenation with
a selection of five quality levels.

· Highest Quality (quality grade 1)

· Better quality (quality grade 2)

· Good quality (quality grade 3)

· Default (quality grade 4)

· None (quality grade 5)

http://www.ub-dieck.com/SilbentrennungE.html
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Color management

Introduction to color management

Color management is used to create consistent colors. From the scanned image to the final output
in print, colors should be displayed the same on all output devices.

Output devices such as displays and printers each have a specific color space and can only display
colors that lie within this color space. Displays and scanners work in RGB mode, the final output
takes place in CMYK mode when printing.

The RGB and CMYK color spaces can display different color spectra, whereby the RGB color
space has a larger spectrum than the CMYK color space. When converting from RGB to CMYK, the
colors therefore change.

It can also happen that some RGB colors cannot be displayed in CMYK because they lie outside
the CMYK color range.

The color management ensures that the color range of an image is transferred to the color range of
the output device during the conversion to another color space. This also includes calibrating and
creating a color profile for the display so that colors are shown as accurately as possible, as well as
creating profiles for the output devices used, such as printers, proofing systems and presses. At the
same time, the substrate must be taken into account when converting the inks for printing, as the
inks are reproduced differently on art paper than on uncoated paper.

Color management systems (CMS) translate colors from the color gamut of one device into the
color gamut of another. Within a color management system, a reference color space is used to de-
scribe the colors for the different devices. The reference color space is the so-called Lab color
space, which has the largest color spectrum and can therefore display most colors.

The different color spaces: A: Lab color space, B: RGB color space, C: CMYK color space

Color management transfers the colors that lie outside the color space of the target device to the
displayable color space during color conversion.

ICC profiles

ICC profiles contain a description of the color space. The ICC profiles are used to calibrate the
color reproduction of the various input and output devices. ICC profiles describe the color spaces of

https://en.wikipedia.org/wiki/Color_management
https://en.wikipedia.org/wiki/RGB_color_model
https://en.wikipedia.org/wiki/CMYK_color_model
https://en.wikipedia.org/wiki/CIELAB_color_space
https://en.wikipedia.org/wiki/ICC_profile
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these devices using a device-independent color model (Lab). The color management software
compares the ICC profile of the original device (source profile) with the profile of the target device
(target profile) in order to obtain consistent color results across different devices.

When converting the colors, it is therefore a matter of converting a larger source color space into a
smaller target color space or vice versa. Colors that lie outside the target color space must be reas-
signed. For this purpose, different conversion methods can be used. The rendering intent describes
how the individual objects are transferred into the target color space.

Color management with Microsoft Windows

In Windows, color management with ICC and ICM profiles is supported. The ICM (Image Color
Management) used under Windows guarantees an exact and reliable color representation on all
devices used for playback. Usually, color reproduction varies for different reasons, depending on
whether it is done via scanners, monitors, printers, or applications. Without a standard color man-
agement system, the results would vary greatly depending on the program and hardware used.
Each program would have to provide color profiles not only for the software, but also for different
types of devices. As a result, color consistency was often achieved in different ways.

Images and graphics that may contain an embedded color profile come from the outside. If this is
not the case, the standard profiles are used, which are selected in the Color Management via the
selection list Working Color Space: for the color spaces CMYK and RGB. These default profiles
are also used to convert the colors for the screen display. The conversion leads to the device-inde-
pendent color space of the Profile Connection Space (PCS). From this space, the output to the
screen or printer takes place using the profile of the respective output device. If an output device
does not have an ICC profile, no color management takes place.

With the help of the Windows color management (Control Panel > Color Management > Ad-
vanced), you have the possibility to create a profile adapted to your display with the Calibrate com-
mand. You can then use this as a working color space for RGB and as a display profile.

Storage location of the color profiles (Windows)

By default the color profiles are installed under Windows in the folder (C:)\Windows\Sys-
tem32\Spool\Drivers\Color.

Color management under macOS

Under macOS, the ColorSync utility performs these tasks. You can create a customized display pro-
file via System preferences > Displays > Colors > Calibrate.

Location of the Color Profiles

· For all users: Drive Name > Library > ColorSync > Profiles.

· For individual users: Drive Name > Users > User Name > Library > ColorSync > Profiles.

Storage location of the monitor profiles

· For all users: Drive Name > Library > ColorSync > Profiles > Displays.

· For individual users: Drive Name > Users > User Name > Library > ColorSync > Profiles > Dis-
plays. 
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Color Management Settings

To make the color management settings, select Extras > Color Management.

The basic settings for color management are made in the Color Management window

If you want to work without color management, disable the CMYK Images and Colors option and
the RGB Images and Colors option.

If color management is enabled, select the appropriate working color space in the CMYK Colors
and Images and RGB Colors and Images sections. This selection determines which CMYK and
RGB working color space you work with.

By selecting the Images: option, you specify the behavior when placing files or opening documents
that use files with different color profiles.

Selection of color management guidelines
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Convert Profile to Working Color Space
Images or graphics that have been assigned a different profile are converted to the profile selected
in the Working Color Space drop-down list. 

Keep Profile: The profile saved with images or graphics is applied. 

No Color Management: There is no color management.

Device: Here you select the profile of your display. 

Options

Select the desired conversion method from the Rendering Intent: drop-down list (see ICC Pro-
files).

You have the choice between the options Perception (Images), Saturation (Graphics), Relative
Colorimetric and Absolute Colorimetric.

The conversion method used to convert the source color space to the target color space is determined via the selection
list Rendering Intent.

Perception (Images): This method is based on the range of colors perceived by the human eye
and attempts to maintain the color tones and their relationship to one another. The source range is
scaled proportionally to the target range, so that the gray balance is maintained. Although the colors
may shift slightly, this method preserves the overall visual impression. This option is the default set-
ting.

Saturation (Graphics): This method is especially suitable for diagrams and tables. It produces
vivid colors, but the accuracy of the colors is secondary. Instead of the hue, the relative saturation is
maintained. With this method, the hues may shift during conversion.

Relative Colorimetric: This compares the white point of the source color space with that of the tar-
get color space and moves all colors accordingly. This method is characterized by the least loss of
quality and is the default setting in common image editing programs today.

Absolute Colorimetric: Here the colors are moved directly from one color space to another, the
colors that are within both color spaces are not changed. The white point is not adjusted. This
method is mainly used to create digital proofs and offset printing plates.
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Preflight
Before you send a document to a service bureau for further processing or output the document by
yourself, you can check it for missing fonts, incorrect color spaces, low-resolution images and many
other settings using the File > Preflight command.

This check helps to detect and correct errors that can occur during the further processing of faulty
documents.

To call the function, select the command File > Preflight ...

The Check Prior to Printing > Issues tab lists all issues encountered in the document

Set page range to check

Selection: This selection list allows you to choose between the Active Page and All Pages op-
tions. Select the Active Pages option if you only want to check the active page when several pages
are open. Select All Pages if you want to check all open pages.

Include Master Pages: Objects placed over the page template are checked.
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Valid Color Spaces: Activate the valid color modes that are allowed in the document. For example,
if you disable the RGB option, images or objects loaded or created in RGB mode will appear in the
problem list.

Issues Tab

Image Resolution: Enter the minimum resolution of the images required for subsequent pro-
cessing. Images with a lower resolution are displayed in the Issues list. In the Color: field, enter the
minimum resolution for color images. In the Black and White: field, enter the minimum resolution
for grayscale images.

Tolerance: Here you enter a percentage value by which the respective image resolution may differ.

Allow higher resolution: To prevent images whose resolution is higher than the entered value
plus the defined tolerance from being included in the list of issues, activate the Allow higher resol-
ution option.

Image position in frame: If this option is enabled, you will receive an error message if an image
does not completely fill the image frame.

Tolerance: Enter here the tolerance value in mm by which a picture frame does not have to be
completely filled by a picture. If you enter the value 0, all picture frames that are not completely filled
will be reported.

Missing image files: Activate this option to display missing images in the list.

Color Settings: If you select this option, colors used that are not marked as allowed will be listed
as a problem. 
In addition, you will receive information about the color mode in which the color was created and the
pages on which the color was used.

Print colors: If this option is enabled, all images that are not in the CMYK color space are listed.

Transparency: If you activate this option, transparent objects will be listed.

Bleed-Edge Objects: If this option is enabled, frames or frame contents that protrude beyond the
trimmed page area will be listed.

Elements outside of page: If this option is enabled, objects that are completely outside the
trimmed page area will be listed. 
(Objects that are completely outside the trimmed page area will not be included in the output.)

Fonts: If this option is enabled, missing fonts will be listed.

Overset: Activate this option to receive a message if the text content in a frame or frame chain is
longer than the planned length.

Underset: Activate this option to receive a message if the text content in a frame or a frame chain
is shorter than the planned length.

Text variables: Activate this option to check whether a valid value has been set for all text vari-
ables.

Result display

The display is divided into five columns: Object, Source, Type, Page and Issue.

Object: Lists the fonts used in the document, loaded images, text elements.

Source: Shows whether it is a template object.

Type: Indicates whether the object is a font, an image, or an article.
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Page: Specifies the page on which the object was placed or the font used.

Issue: Objects that caused an error message are listed in the Issue column with the corresponding
message. Overset is evaluated for articles, tables, and text elements.

Details: If you select a message in the list, the Details field displays a detailed description of the
problem and suggestions for resolving it.

Displaying Objects with Errors

If you activate an entry in the list, you can jump to the incorrect object. Click on the [Show] button,
the faulty object is centered and highlighted on the screen.

Overwiew tab

The Overview tab lists all fonts, text and image objects used on the open pages, regardless of
whether they caused an error/warning message.

All objects are listed on the Overview tab
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Check Prior to Printing

If the Preflight option is enabled in the Print dialog (General tab), the program automatically checks
the pages to be printed. If errors are detected during the check, the Check Prior to Printing dialog
appears. If no errors are detected, the print job is started without further message.

The Preflight option can also be defined in the print preset.
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Basic Options     383

Basics PDF export     281

Bézier     355

Bézier shape     54, 356

Bézier shapes     355

Bleed & Marks (print)     264

Block elements     309

Blogging     329

Body Text block     17

Book     248

Book (definition)     15

Book document     13

Book file     241, 242, 243

Book function     15

Book window     244

Bookmark     309

Bookmark bar     300

Bookmark list     319

Bookmarks     174, 319

Box frame     64

Brochures     143

Bullets & Numbering     110

- C -
Caption     17

Cell     120

Cell style     16, 383

Cell Style 1     396

Cell Style 2     396

Cell styles     94, 389

Cell types     381

Change     463

Change All     463

Change column width     399

Change frame type     64

Change row height     399

Change to     463

Check for output     475

Check in     84

Check in (stories)     439

Check on text input     463

Check out     84

Check out (stories)     435

Check spelling     463

Checking in stories     439

Checking out stories     435

Classes     305

Clipping path     102

CMYK     471

Collaboration     426, 427

Collaboration toolbar     84

Collaborative working     426

Collecting documents     242

Collection     14, 242

Color     200

Color management     281, 471
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Color separation     269

Colors     189, 195

Colors (print)     269

Colors panel     91

Colorspaces     195

Columns     27, 110, 135

Columns tab     383

Column-Wise     383

Combining documents (book)     241

Company register     251

Components     180

Composite (print)     269

Conditional text     102, 137, 139, 319

Connection data e-paper     328

Content type     64

Contents of a library     193

Contour     110, 155

Control panel     85

Convert Text to Outlines     370

Convert to colorspace     471

Copy as Outline     370

Copy fonts     422

Copy linked images and graphics     422

Copywriter     427

Corner point (Bézier)     356

Corners     102

Cover from image file     319

Cover image     319

Cover image (e-book)     319

Create a table without data     411

Create image frame     54

Create Outlines     370

Create paragraph style     223

Create path     373

Create table     396

Create table by placing an Excel or CSV file     411

Create table style sheet     407

Create tables     411

Create template     38

Create text frame     54

Create text style     223

Creating a book file     241

Creating a library     191

Creating a new book     26, 38

Creating a new color     200

Creating a new document     26, 27, 130

Creating a new gradient     200

Creating a new grid     200

Creating a new master page     200

Creating a new story     26, 29

Creating a new style sheet     200

Creating a new table     26, 32

Creating a new tint     200

Creating a story     186, 432

Creating a table     16

Creating a table style sheet     200

Creating a WordPress story     332

Creating an e-book     300, 309

Creating new documents     129

Creating styles     223

Creating tables     380

Crop     149

Crop images (print)     265

Cropping individual pages like facing pages     134

Crosshairs (print)     264

CSS     300, 305

CSS class     319

CSV     396

CSV format     380

Curve (Bézier)     356

Curve point (Bézier)     356

- D -
Data backup     128

Default settings     462

Default toolbar     82

Define table     396

Defining the bleed area     134

Defining the page size     134

Delete template     38

Detach     84

Dieckmann hyphenation     467

Different page sizes     143, 145

DIHYPH     467

Directory     309

Document grouping     15

Document properties     137

Document structure     145

Document Template     133

Document templates     132, 180, 181, 189

Document types     13

Draw Bézier line     54, 356

Draw line     54

Draw line orthogonal     54

Drop Cap     102

Dropbox     21

- E -
E-book cover image     300

E-book introduction     300

Edit and create paragraph styles     223

Edit and create text styles     223
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Editing a grid     200

Editing a master page     200

Editing a print preset     279

Editing a style sheet     218

Editing stories     436

Editing text     399

Editorial office     427

Embedding fonts     319

Emptying the eyedropper     67

Endnotes     169

E-paper     326

EPUB     300, 309

EPUB (*.epub)     319

EPUB 3 standard     319

EPUB reader     319

Excel     396

Exchange content (Document)     213

Exchange formats     258

Exclude overlap (Frame)     366

Expanding a book     245

Export e-book     300

Export formats     258

Export into PDF format     281

Exporting     258

Exporting an e-book     300

External libraries     189

External staff     427

External story editing     428

Eyedropper     54, 67

- F -
Facebook     354

Facing Pages     132, 133

File formats     13

File system     128

Filling the eyedropper     67

Find     172

First page left     132

First steps     47, 127

Fit     149

Fit columns to frames     399

Fit rows to frame     399

Fit rows to text     399

Flatten transparency     271

Flyer     143

Folder structure     128

Font folders     416

Fonts     416

Footer column     381

Footer row     381

Footers     16

Footnote (format)     221

Footnote (text block)     17

Footnote count     169

Footnote options     169

Footnote text     169

Footnotes     169, 174

Format group     186

Frame     75

Frame properties     64

Frame types     64

Functions of the program     6

- G -
Galley view     155

General document settings     132

Geometry     186

Glyphs panel     95

Go to next frame     399

Google Drive     21

Graphics     97, 149

Grid     27, 135, 189, 200

Grids     195

Grouping     64

Grouping of documents     15

Gutter     27, 135

- H -
Handle line (Bézier)     356

Header     381

Header column     381

Header row     381

Headers     16

Headline block     17

Help     48

Hide     81

Hide columns     399

Hide rows     399

Home screen     25

Home window     25

Horizontal alignment     389

HTML     102, 300, 309

HTML style sheets     319

Hybrid texts     137

Hyperlink     309

Hyperlinks     174, 220

Hyphenation     467

- I -
iBooks     319

Icons     95
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Ignore All     463

Image     102

Image captions in block     319

Image content     54

Image content tool     149

Image formats     149

Image frame     64

Image frames     149

Images     97, 149

Images (print)     265

Importing fonts     416

InDesign snippet     187

Index     256

Inline element     309

Inline images     309

Insert image into cell     399

Insert or delete columns     399

Insert or delete rows     399

Inserting a marker     174

Inset     389

Inspector     102

Inspectors     52, 99

Installing fonts     416

Interface     24

Intersect frame     366

Introduction     4

Issues (preflight)     475

- K -
Kerning     103

Kerning table     103

Keyboard profiles     460

Keyword     17

Keyword register     251

Kindle     300

- L -
Language     467

Language setting     467

Layer panel     89

Layers (export)     275

Layers (print)     275

Layout / Image     112

Layout Inspector     110

Layout palette     52

Layout prior to text     21

Layout program     5

Layout software     5

Layout templates     180, 183, 189

Left     220

Left/Top Strokes     383

Letterhead     142

Libraries     20, 46

Library     132, 189, 209

Library content     193

Library document     13

Library elements     195

Ligatures     418

Line     120

Line count     155

Line grid     64, 71, 135

Lining figures     418

Link     54

linked     97

Linking frames     69

Linking of frames     69

Linking order     69

Load text     155

Location of Color Profiles     471

Lock columns     399

Lock rows     399

- M -
Magnify     54

Margin     64, 110, 389

Marginalia     162

MarkStein Publishing     49

Master pages     132, 189, 195, 200

Merging cells     399

Meta data     300

Microsoft® Excel     380

Mobipocket format     300

Move     54

Move columns     399

Move rows     399

Multi-page documents     140

- N -
Name register     251

Navigation within text     155

New book     243

New document     130

New document based on a template     26

New from a template     38

New style sheet     218

Newsfeed     354

No color management     471

Non-white areas     373

Notes panel     96

Number of characters     346
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Numbering     138

Numbering chapters     249

Numbering pages     249

Numbering sections     249

- O -
OAuth access token key     344

OAuth access token secret     344

Object properties     110

Oldstyle figures     418

Online help     48

Online publishing     332

Open book     44

Open document     44

Open file     44

Open IDML file     44

Open InDesign file     44

OpenType     418

OpenType features     418

Opentype fonts     416

Order     319

Orientation     383

Orientation marks (print)     264

Original view     458

Outline stroke     373

Outlines from font     370

Output as e-book     300

Output as e-paper     326

Output channels     346

Output to WordPress     329

Outputting text to WordPress     329

Overfill (print)     269

Overprint black/white     269

Overset     17, 155, 475

Overwrite paragraph style     223

Overwrite text style     223

- P -
Package     422

Page area     475

Page document     13

Page notes     96, 174

Page numbers on printed version     319

Page orientation (print)     262

Page size     27, 134, 141, 145

Page view     155

Pages panel     88

Pagina     249

Pagination     137, 248

Palettes     52

Panel align     97

Panel Colors     91

Panel Glyphs     95

Panel Layer     89

Panel Notes     96

Panel Pages     88

Panel styles     92

Panel Table styles     94

Panel Templates     90

Panel toolbar     87

Paper size     141, 145

Paper size (print)     262

Paragraph     102

Paragraph frame from clipboard     162

Paragraph Properties     92

Paragraph style     19, 349, 351

Paragraph style for tweets     346

Paragraph styles     92

Path     355

Path operations     373

Path segment     356

PDF     258

PDF export options     281

PDF/X     281

Perception (images)     471

Personalization     443

Place document template     181

Place images     149

Place layout template     183

Placeholder images     265

Placing a story     22

Placing snippets     187

Placing stories in the layout     434

Posting     346

PostScript fonts     416

PostScript printing     271

Preferences     443

Preferences for keyboard     460

Preferences for program     444

Preferences Image Frame / Image:     452

Preflight     475

Preflight before printing     475

Presence     354

Presets     462

PressMatrix interface     326, 328

Preview images (print)     265

Print     258

Print document     260

Print preset     278, 279

Print settings     260

Printing     260

Printing a book     280
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Profile     354

Program functions     6

Program preferences     444

Programming interface     341

Properties of documents     137

Proportional image     149

Proportional lining figures     418

Proportionally fit image     149

Publishing a story     329

Publishing to WordPress     332

- Q -
Quit program     50

Quotation marks     463

Quotes     17

- R -
reassign     97

Recently opened files     43

Recommended work folders     128

Reduce points     373

Reference     309

Reference (footnote)     169

Register (keyword/name/company)     251

Register mark     176

Registers     174

Relative colorimetric     471

Replace     172

Replace during spell checking     463

Replace with     172

Reproduction priority     471

RGB     471

Rotation     54

Rows tab     383

Row-Wise     383

Rule     102

Rules     110

- S -
Saturation (graphics)     471

Save document template     181

Save template     38

Scale content     85

Scope of performance     5

Script view     155

Search for     172

Segment (Bézier)     356

Select cell     399

Select column     399

Select paragraph frame     162

Select row     399

Select table     399

Select table body     399

Selecting properties     67

Selecting text     155

Selecting values     67

Selection     54

Setting up a library     200

Setting up a print preset     278

Setting up a workflow     440

Setting up an e-paper     326, 328

Settings (e-paper)     326

Shadow     110

Share a document     422

Shear     389

Short messages     338

Show     81

Simplify path     373

Small caps     418

Snap to baseline grids     71

Snippet     187

Social networks     338

source file     97

Special characters     95, 155, 463

Spell checking     463, 467

Spellcheck word     463

Spelling and autocorrection     463

Spline (Bézier)     356

Status     427, 440

Status bar     85

Status view     458

Stories     428

Story     14, 21, 429

Story document     13

Story template     14, 186, 430

Story templates     180

Story type     19

Stroke     64, 389

Stroke tab     383

Structure     319, 381

Structure levels     309

Structure of documents     13

Style     19, 305

Style name     220

Style sheet     19, 220, 221

Style sheet (table)     396

Style sheet (text in table)     396

Style sheets     189, 195, 200, 218

Style template     19

Styles     102

Styles panel     92

Subtract frame     366
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Swap cell contents     399

Swap column content     399

Swap columns     399

Swap row content     399

Swap rows     399

Synchronize     84

Synchronizing book files     248

- T -
Table     17, 54, 120

Table example     407

Table geometry     16

Table Inspector     120

Table of contents     15, 256

Table style sheet     16, 94

Table style sheets     189, 195, 200, 209

Table styles     94

Table Styles panel     94, 383

Table tool     16

Table wizard     16

Tables     16, 380

Tabular lining figures     418

Teamwork     426

Template document     38

Templates     189

Templates panel     90

Text     102

Text anchors     174, 179

Text content     54, 155

Text editing by drag and drop     155

Text editor     155

Text file     14

Text flow     309

Text frame     64

Text frame from clipboard     162

Text Inspector     102

Text notes     96, 174

Text on a baseline grid     71

Text on path     155

Text prior to layout     22

Text selection     155

Text style     19

Text styles     92

Text tab     389

Text usage     137, 349, 351

Text wrap     373

Texts as stories     429

Thumbnails (print)     267

Tile horizontally     155

Toolbar     52, 54

Toolbar Collaboration     84

Toolbar Default     82

Toolbar Panels     87

Toolbar View     83

Toolbars     81

Tools     54

Transferring content (Library)     213

Transferring properties     67

Transparenzreduzierung     272

Truetype fonts     416

Tweet     338

Twitter     338, 344

Twitter account     338, 341

Twitter API key     344

Twitter API secret     344

Twitter app     341

Twitter developer account     338

Type on path     155

- U -
Underset     155, 475

Unlinking     69

Unlinking frames     69

Use document template     181

User dictionary     463

User interface     24

User-defined page     141

- V -
Versions (program)     6

Vertical justification     389

View modes     155

View toolbar     83

Visible grids (print)     264

- W -
Website MarkStein Publishing     49

Welcome page     2

WordPress blog     329

WordPress connection data     329

Work preparation     128

Workflow     128, 440

Workgroup Edition     427

Working in teams     426

Working methods     127

Working windows     24

Working with libraries     188

Working with markers     174

Working with status     440

Working with tables     380

Workspace     52
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- Z -
Zoom in     54

Zoom out     54
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